Subject: Re: [trill] [rbridge] TRILL Multi-topology encoding draft

From: Donald Eastlake <[email-masked]>
Date: Tue, 1 May 2012 15:51:32 -0400

While this certainly encodes topology into frames, it is not clear to
me that the technique using a new tag is generally supported by
existing TRILL silicon.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Mar 26, 2012 at 12:54 PM, Tissa Senevirathne (tsenevir)
<[email-masked]> wrote:
> Dear All
>
>
> We have posted draft-tissa-trill-mt-encode-00. This draft discuss methods
> that can be used to encode multi topology id without exhausting nickname
> space or adding additional control plane extensions to abbreviate absolute
> topology. Please let us know your comments.
>
>
>
> Abstract:
>
>
>
>    Two alternative methods of encoding Multi Topology Identifier within
>
>    the TRILL data frames are presented. Methods proposed herein do not
>
>    require overloading TRILL RBridge nickname to encode Multi Topology
>
>    Identifier.
>
>
>
> Thanks
>
> Tissa
>
>
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge
>

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 1 May 2012 16:00:23 -0700

Hi Donald

In the ID we have specified a backward compatibility mode where one can use NH-VLAN to encode the multi topology ID on pt-pt links.

-----Original Message-----
From: Donald Eastlake [mailto:[email-masked]] 
Sent: Tuesday, May 01, 2012 12:52 PM
To: Tissa Senevirathne (tsenevir)
Cc: [email-masked]
Subject: Re: [rbridge] TRILL Multi-topology encoding draft

While this certainly encodes topology into frames, it is not clear to me that the technique using a new tag is generally supported by existing TRILL silicon.

Thanks,
Donald

On Mon, Mar 26, 2012 at 12:54 PM, Tissa Senevirathne (tsenevir) <[email-masked]> wrote:
> Dear All
>
>
> We have posted draft-tissa-trill-mt-encode-00. This draft discuss 
> methods that can be used to encode multi topology id without 
> exhausting nickname space or adding additional control plane 
> extensions to abbreviate absolute topology. Please let us know your comments.
>
>
>
> Abstract:
>
>
>

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 2 May 2012 09:15:41 -0700

When using the outer-VLAN, while the frame format itself would
be backwards compatible, I don't believe existing silicon would
actually be able to make use of it.

So it depends on what we mean by "backwards compatibility"?

Do we need the data plane to be backwards compatible?
If so, neither encoding mechanism works.

Or do we need just the frame format to be backwards compatible?
Then using the outer VLAN works.

Anoop

On Tue, May 1, 2012 at 4:00 PM, Tissa Senevirathne (tsenevir)
<[email-masked]> wrote:
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 4 May 2012 15:37:35 -0700

This encoding happens hop-by-hop. Which means when interfacing with RBridges that are not capable of understanding the proposed encoding methods, RBridges may not use the proposed encoding on those interfaces, thus maintaining the backward compatibility. This is possible because TRILL header remain unchanged and encoding happens as part of the outer header. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Wednesday, May 02, 2012 9:16 AM
To: Tissa Senevirathne (tsenevir)
Cc: Donald Eastlake; [email-masked]
Subject: Re: [trill] [rbridge] TRILL Multi-topology encoding draft

When using the outer-VLAN, while the frame format itself would be backwards compatible, I don't believe existing silicon would actually be able to make use of it.

Anoop