Subject: [trill] trill ecmp utilization

From: [email-masked]
Date: Wed, 23 May 2012 11:33:01 +0800

Hi,

I have a problem on the definition of ECMP  utilization in TRILL OAM Req 
draft, which said that:  "OAM MAY provide functionality to monitor 
utilization of ECMP paths to specified destination RBridges. Utilization 
is defined as distribution of traffic over different ECMP members."

Given the figure below, RB1 is ingress Rbridge and RB9 is egress Rbridge, 
RB2 has three downstream RBs(RB3, RB4 and RB5) that can reach RB9, and RB6 
has two downstream RBs（RB7 and RB8）to RB9, so there are all 6 ECMP paths 
from RB1 to RB9.

 Then, my question is：
In the current text, does "ECMP member" mean one specific path from RB1 to 
RB9(such as RB1-RB2-RB3-RB6-RB7-RB9)? or one specific node(such as RB2)?

Please correct me if my understanding is not correct.

Best Regard,
Xuehui

---

From: Sam Aldrin <[email-masked]>
Date: Tue, 22 May 2012 22:32:44 -0700

It is per path, not node.

Sam

Sent from my iPhone

On May 22, 2012, at 8:33 PM, [email-masked] wrote:

> 
> Hi, 
> 
> I have a problem on the definition of ECMP  utilization in TRILL OAM Req draft, which said that:  "OAM MAY provide functionality to monitor utilization of ECMP paths to specified destination RBridges. Utilization is defined as distribution of traffic over different ECMP members." 
> 
> 
> Given the figure below, RB1 is ingress Rbridge and RB9 is egress Rbridge, RB2 has three downstream RBs(RB3, RB4 and RB5) that can reach RB9, and RB6 has two downstream RBs（RB7 and RB8）to RB9, so there are all 6 ECMP paths from RB1 to RB9. 
> 
>  Then, my question is： 
> In the current text, does "ECMP member" mean one specific path from RB1 to RB9(such as RB1-RB2-RB3-RB6-RB7-RB9)? or one specific node(such as RB2)? 
> 
> 
> 
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: [email-masked]
Date: Wed, 23 May 2012 16:13:25 +0800

Hi Sam， 

Thanks for your reply.

with ecmp utilization of all ecmp paths, you may find that a hash 
polarization happens, then what will you do about this?

Best regards,
Xuehui

Sam Aldrin <[email-masked]> 
发件人:  [email-masked]
2012-05-23 13:32

收件人
"[email-masked]" <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: [trill] trill ecmp utilization

Sam

Sent from my iPhone

Hi, 

 Then, my question is： 

Best Regard, 
Xuehui

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 23 May 2012 10:38:49 -0400

Hi,

> polarization happens, then what will you do about this?

Polarization is a very well known potential problem. I suppose if you
find hash polarization is happening, you should tell the implementors
of TRILL for your RBridges to fix their implementations.

The ECMP hashing should include some quantity that is unique per
RBridge in a campus, such as the IS-IS System ID or a nickname.
Perhaps the base protocol specification should have said this, but it
didn't, so perhaps it should be included in the Clarifications and
Corrections draft.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> utilization of ECMP paths to specified destination RBridges. Utilization is
> defined as distribution of traffic over different ECMP members."
>
>
> https://www.ietf.org/mailman/listinfo/trill_______________________________________________
>
> trill mailing list
> [email-masked]