Subject: [trill] Should we adopt draft-dunbar-trill-directory-assisted-edge-05.txt as a WG document?

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Jun 2012 11:48:16 -0700

<http://http://tools.ietf.org/html/draft-dunbar-trill-directory-assisted-edge-05>

We've discussed earlier versions of this document in the WG in the past, 
and it seems like useful information for a technique that helps with ARP 
and ND scaling. It does not include any protocol changes or extensions.

The document is intended as an informational document (it says "Intended 
status: Standard Track" but that is incorrect) explaining how 
directories can fit into TRILL.

Note that there is claimed IPR associated with the draft:
<https://datatracker.ietf.org/ipr/1788/>

Please send comments to the TRILL list before June 27.

Thanks,
    Erik

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 14 Jun 2012 17:35:39 -0700

I think this is an interesting problem/solution,
but I think it falls short in discussing how the
directory should be created and what protocol
should be used for the directory server.

Implementing something like this would mean
that ARP/ND messages would all have to be
forwarded in software (otherwise hosts would
have a problem creating their ARP caches),
which is not mentioned in the document.

Anoop

On Thu, Jun 14, 2012 at 11:48 AM, Erik Nordmark <[email-masked]> wrote:
> We've discussed earlier versions of this document in the WG in the past, and
> it seems like useful information for a technique that helps with ARP and ND
> scaling. It does not include any protocol changes or extensions.
>
> status: Standard Track" but that is incorrect) explaining how directories
> can fit into TRILL.
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 14 Jun 2012 19:16:53 -0700

Hi,

I read the draft and the problem statement is clearly laid out.
This is surely an interesting problem and could be many ways to solve it.
Directory assistance is one of the solutions.

As the document doesn't specify the solution part of it, I would prefer to have this document converted to as framework and requirements document. A solutions document could be worked out separately.

If the decision is to convert as FW doc, authors may want to re-spin a new version prior to adoption, clearly laying out the framework to  solve the problem. Otherwise, I personally feel it wouldn't be much value add to have an informational document just describing the problem without solution details.

Cheers
Sam

Sent from my iPad

On Jun 14, 2012, at 11:48 AM, Erik Nordmark <[email-masked]> wrote:

> We've discussed earlier versions of this document in the WG in the past, and it seems like useful information for a technique that helps with ARP and ND scaling. It does not include any protocol changes or extensions.
> 
> The document is intended as an informational document (it says "Intended status: Standard Track" but that is incorrect) explaining how directories can fit into TRILL.
>

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 15 Jun 2012 16:28:32 +0000

Thanks to Anoop and Sam's opinion on this draft. 

This draft initially had technical content, e.g. the detailed mechanism to achieve Pull model and Push model. As we peel the onion and explore more details of the mechanisms, a lot more options for the detailed mechanisms were mentioned to achieve the goal. It will be a huge document if all the options are included. 

Therefore, the TRILL WG chairs suggested to remove the technical content and make the draft as framework informational draft. After WG agree to general framework, multiple drafts can be written to describe various options and debate on which one is suitable or all being optional, etc. 

I am fine with re-spinning the draft by changing the name to "draft-trill-directory-framework-requirement". 

What do people think?

Linda Dunbar

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Anoop Ghanwani
> Sent: Thursday, June 14, 2012 7:36 PM
> To: Erik Nordmark
> Cc: [email-masked]
> Subject: Re: [trill] Should we adopt draft-dunbar-trill-directory-
> assisted-edge-05.txt as a WG document?
>

---

From: Radia Perlman <[email-masked]>
Date: Fri, 15 Jun 2012 09:59:59 -0700

I think it would be a good idea to have multiple drafts, each one
focused on a particular dimension of the problem, and let this be
framing the problem and rationale.  But at any rate, I support
adopting this as a WG draft.

Radia

---

From: Yizhou Li <[email-masked]>
Date: Mon, 18 Jun 2012 09:44:13 +0800

I have read the draft and support adopting it as an WG draft.

Yizhou

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Erik Nordmark
Sent: Friday, June 15, 2012 2:48 AM
To: [email-masked]
Subject: [trill] Should we adopt
draft-dunbar-trill-directory-assisted-edge-05.txt as a WG document?

<http://http://tools.ietf.org/html/draft-dunbar-trill-directory-assisted-edg
e-05>

Thanks,
    Erik

---

From: [email-masked]
Date: Mon, 18 Jun 2012 10:22:37 +0800

Support!

Linda Dunbar <[email-masked]> 
发件人:  [email-masked]
2012-06-16 00:28

收件人
Anoop Ghanwani <[email-masked]>, Erik Nordmark <[email-masked]>
抄送
Sam Aldrin <[email-masked]>, 'Igor Gashinsky' <[email-masked]>, 
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
主题
Re: [trill] Should we adopt 
draft-dunbar-trill-directory-assisted-edge-05.txt as a WG document?

This draft initially had technical content, e.g. the detailed mechanism to 
achieve Pull model and Push model. As we peel the onion and explore more 
details of the mechanisms, a lot more options for the detailed mechanisms 
were mentioned to achieve the goal. It will be a huge document if all the 
options are included. 

Therefore, the TRILL WG chairs suggested to remove the technical content 
and make the draft as framework informational draft. After WG agree to 
general framework, multiple drafts can be written to describe various 
options and debate on which one is suitable or all being optional, etc. 

I am fine with re-spinning the draft by changing the name to 
"draft-trill-directory-framework-requirement". 

What do people think?

Linda Dunbar

---

From: [email-masked]
Date: Mon, 18 Jun 2012 10:24:56 +0800

I have read the draft. As a framework informational draft, it's fine. I 
support adopting it as a WG draft.

Thanks,
Zhai Hongjun
""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
 Protocol Development Dept.VI, Central R&D Institute, ZTE Corporation
 No. 68, Zijinghua Road, Yuhuatai District, Nanjing, P.R.China, 210012
 
 Zhai Hongjun
 
 Tel: +86-25-52877345
 Email: [email-masked]
"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

收件人

What do people think?

Linda Dunbar

---

From: <[email-masked]>
Date: Mon, 18 Jun 2012 13:23:32 -0400

As an informational framework-like draft, I support WG adoption of this draft.

There are likely to be opportunities to use the same protocol(s) for directory
access as nvo3 will use, with differences based on encapsulation differences
(trill needs identify and address the remote RBridge at layer 2, nvo3 needs
to identify and address the remote NVE at layer 3).

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Erik
> Nordmark
> Sent: Thursday, June 14, 2012 2:48 PM
> To: [email-masked]
> Subject: [trill] Should we adopt draft-dunbar-trill-directory-assisted-edge-
> 05.txt as a WG document?
> 
>

---

From: Mingui Zhang <[email-masked]>
Date: Tue, 19 Jun 2012 07:36:12 +0000

I Support it is adopted a WG informational framework draft.

Thanks,
Mingui

> Subject: [trill] Should we adopt draft-dunbar-trill-directory-assisted-edge-05.txt
> as a WG document?
> 
> 
> <http://http://tools.ietf.org/html/draft-dunbar-trill-directory-assisted-edge-05
> >
>

---

From: "Naveen Nimmu" <[email-masked]>
Date: Tue, 19 Jun 2012 07:59:45 +0000

+1 support

Thanks
naveen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mingui Zhang
Sent: Tuesday, June 19, 2012 1:06 PM
To: Erik Nordmark; [email-masked]
Subject: Re: [trill] Should we adopt draft-dunbar-trill-directory-assisted-edge-05.txt as a WG document?

Thanks,
Mingui

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 19 Jun 2012 18:49:55 +0000

Dear All

I have some clarifications and suggestions.

1. Currently TRILL charter says the following 
  "2) Development, within the TRILL protocol context, of requirements
  and specifications for broadcast/multicast (multi-destination) frame reduction; e.g., ARP/ND (Neighbor Discovery) reduction through use of the TRILL ESADI protocol."

I would like to propose to make this framework document a more generic document that address framework for "broadcast/multicast reduction in TRILL" and make ESADI and Directory assisted as part of that and also explain how they fit in to the overall framework. Otherwise it is kind of odd to have a framework for just one approach and not the other.

2. Based on the TRILL WG web page  this draft has a related IPR. If we are proposing to move this as a framework document to the WG status, it is important to clarify how the IPR applies to solutions coming from the framework. In general sense it may not be a good idea to have a framework document that has IPR restrictions. Because framework documents are  too broad in scope.

Thanks
Tissa
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Thursday, June 14, 2012 11:48 AM
To: [email-masked]
Subject: [trill] Should we adopt draft-dunbar-trill-directory-assisted-edge-05.txt as a WG document?

The document is intended as an informational document (it says "Intended
status: Standard Track" but that is incorrect) explaining how directories can fit into TRILL.

Thanks,
    Erik

---

From: Russ White <[email-masked]>
Date: Wed, 20 Jun 2012 09:08:32 -0400

As a framework document, I support the adoption of this draft as a WG
document.

Russ

-- 
<><
[email-masked]
[email-masked]