Subject: [trill] RtgDir review: draft-ietf-trill-arp-optimization

From: Geoff Huston <[email-masked]>
Date: Sat, 16 Apr 2016 11:44:11 +1000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-trill-arp-optimization-05.txt
Reviewer: Geoff Huston
Review Date: 16 April 2016
IETF LC End Date: date-if-known 
Intended Status: copy-from-I-D

Summary: 
	This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:
	I found the draft concise and clear. It was readable and readily understood.

Major Issues:
	No major issues found

Minor Issues:
	No minor issues found.

Nits:
	Minor:
	 section 2: “...receive and save such mapping information also.” seems a bit stilted  and I would say “also receive and save such mapping information.

         section 3.1 "populate the information of sender's IP/MAC in its ARP table”. Do the authors really mean "ARP table" if the information was learned by ND? i.e. its clear that the authors are referring to the local IP/MAC address table, but the previous text tends to associated ARP with IPv4 and ND with IPv6. Perhaps “AARP/ND table” ?

---

From: Liyizhou <[email-masked]>
Date: Mon, 18 Apr 2016 02:50:18 +0000

Hi Geoff,

Thank you for the review and comments. I will update the text as you suggested in next revision.

Thanks,
Yizhou

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Geoff Huston
Sent: Saturday, April 16, 2016 9:44 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [trill] RtgDir review: draft-ietf-trill-arp-optimization

Hello,

Summary: 

Comments:

Major Issues:
	No major issues found

Minor Issues:
	No minor issues found.

Nits:
	Minor:

         section 3.1 "populate the information of sender's IP/MAC in its ARP table”. Do the authors really mean "ARP table" if the information was learned by ND? i.e. its clear that the authors are referring to the local IP/MAC address table, but the previous text tends to associated ARP with IPv4 and ND with IPv6. Perhaps “AARP/ND table” ?
_______________________________________________
trill mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trill

---

From: Liyizhou <[email-masked]>
Date: Mon, 25 Apr 2016 00:44:25 +0000

Hi Geoff,

I have uploaded the new version to reflect your suggestions. Thank you.

Rgds,
Yizhou

-----Original Message-----
From: Liyizhou 
Sent: Monday, April 18, 2016 10:50 AM
To: 'Geoff Huston'; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [trill] RtgDir review: draft-ietf-trill-arp-optimization

Hi Geoff,

Thanks,
Yizhou

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Geoff Huston
Sent: Saturday, April 16, 2016 9:44 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [trill] RtgDir review: draft-ietf-trill-arp-optimization

Hello,

Summary: 

Comments:

Major Issues:
	No major issues found

Minor Issues:
	No minor issues found.

Nits:
	Minor: