Subject: Re: [trill] TRILL deployment

From: sujay gupta <[email-masked]>
Date: Sat, 4 Jun 2016 09:12:13 -0700

Chipset support for OAM offload is another impending problem.
That said we have seen successful deployments of TRILL in large networks
Regards,
-Sujay

On Fri, May 27, 2016 at 4:25 AM, Jon Hudson <[email-masked]> wrote:

>
> 110% agree
>
> It's the vendor implemented tools that are primarily at issue.
>
> Jon
>
> > On May 26, 2016, at 6:12 PM, Donald Eastlake <[email-masked]> wrote:
> >
> >> On Thu, May 26, 2016 at 3:50 AM, Jon Hudson <[email-masked]>
> wrote:
> >>
> >>
> >> Main issue that I know from customers is the lack of consistent tools
> to deep dive debug it.
> >
> > It seems to me that this is a lack of user tools, not any inherent
> > problem with TRILL. TRILL has:
> > TRILL OAM (continuity fault management): RFCs 6905, 7174, 7455, 7784
> > MIBs: RFCs 6850, 7784
> > Supports BFD: RFC 7175
> > Has performance monitoring specified: RFC 7456
> >
> > In addition, if a management station peers as an RBridge, it would
> > have direct access to the link state data base.
> >
> > So I really don't see why there should be a problem with implementing
> > good TRILL debugging tools.
> >
> > Thanks,
> > Donald
> > ===============================
> > Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
> > 155 Beaver Street, Milford, MA 01757 USA
> > [email-masked]
> >
> >> Jon
> >>
> >>
> >> On May 26, 2016, at 12:01 AM, devon ietf <[email-masked]> wrote:
> >>
> >> why is trill not so widely deployed. It's been around for several years
> and xSTP protocols
> >> are really bad, then too i don't see customers adopting TRILL as
> widely. what's wrong ?
> >>
> >> _______________________________________________
> >> trill mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/trill
> >>
> >>
> >> _______________________________________________
> >> trill mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/trill
> >>
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Jon Hudson <[email-masked]>
Date: Sat, 4 Jun 2016 14:17:16 -0700

Agreed on OEM chipset support, I would add good chipset support for multicast as well.

And you are right, we have many significant deployments.  I know of one small vendor with over 2500 customers deployed. 

Jon

You may have mail
> On Jun 4, 2016, at 9:12 AM, sujay gupta <[email-masked]> wrote:
> 
>> >> On Thu, May 26, 2016 at 3:50 AM, Jon Hudson <[email-masked]> wrote:
>> >>
>> >>
>> >> Main issue that I know from customers is the lack of consistent tools to deep dive debug it.
>> >
>> >> why is trill not so widely deployed. It's been around for several years and xSTP protocols
>> >> are really bad, then too i don't see customers adopting TRILL as widely. what's wrong ?
>> >>