Subject: Re: [trill] Mirja Kühlewind's No Objection on draft-ietf-trill-irb-13: (with COMMENT)

From: Donald Eastlake <[email-masked]>
Date: Tue, 5 Jul 2016 09:35:52 -0400

Hi Mirja,

A -14 version has been uploaded that is intended to resolve your comment.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Wed, Jun 29, 2016 at 9:49 PM, Donald Eastlake <[email-masked]> wrote:
> Hi Mirja,
>
> Thanks for your comments. See below.
>
> On Wed, Jun 29, 2016 at 6:13 PM, Mirja Kuehlewind <[email-masked]> wrote:
>> Mirja Kühlewind has entered the following ballot position for
>> draft-ietf-trill-irb-13: No Objection
>>
>> ...
>>
>> ----------------------------------------------------------------------
>> COMMENT:
>> ----------------------------------------------------------------------
>>
>> Two minor comments:
>>
>> 1) There are only a few SHOULDs and MUSTs in this whole document
>>    and where they are used it is often not very clear what the action
>>    is that should follow and how it should be implemented
>>   (e.g. "The network operator MUST ensure the consistency of the
>>    tenant ID on each edge RBridge for each routing domain.").
>>   And maybe there are actually more case where normative
>>   language should be used?
>>   Please double-check the use of normative language in this document!
>
> OK.
>
>>  2) A similar question on the following part:
>>   „If a tenant is deleted on an edge RBridge RB1, RB1 SHOULD re-
>>    advertise the local tenant Data Label, tenant gateway MAC, and
>>    related IP prefixes information of the rest tenants to other edge
>>    RBridges. […] Therefore the transient routes consistency won't
>>   cause issues other than wasting some network bandwidth.“
>>   Wasting network resources actually can be an issue.
>>   So why is this not an MUST?
>
> Wasting bandwidth can be an issue but is not necessarily an issue,
> particularly if it occurs only during a brief transient period. TRILL
> does not make it mandatory to implement with the maximum link
> utilization efficiency. For example, TRILL multi-destination traffic
> is send over a distribution tree. If there are no devices interested
> in traffic in a particular VLAN further down a branch of the tree, it
> is recommended that traffic heading down that branch be pruned. But
> this is not mandatory. The TRILL campus will operate "correctly"
> without such pruning and if someone wants to make a very simple, low
> end implementation without pruning, so be it. (As far as I know, all
> existing TRILL implementation do prune distribution trees.)
>
> Thanks,
> Donald
> ===============================
>  Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
>  155 Beaver Street, Milford, MA 01757 USA
>  [email-masked]

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 5 Jul 2016 15:52:44 +0200

Thanks! I had a quick look and this looks good to me. Also on the 2. point 
below, I know understand why there is a SHOULD; you potentially could add one 
more sentence to explain why this is a SHOULD. But I leave this on you.

Mirja