Subject: [trill] Fwd: New Version Notification for draft-eastlake-trill-ecn-support-01.txt

From: Donald Eastlake <[email-masked]>
Date: Fri, 8 Jul 2016 12:58:35 -0400

--------- Forwarded message ----------
From: <[email-masked]>
Date: Fri, Jul 8, 2016 at 12:57 PM
Subject: New Version Notification for
draft-eastlake-trill-ecn-support-01.txt
To: "Donald E. Eastlake 3rd" <[email-masked]>, Bob Briscoe <
[email-masked]>

A new version of I-D, draft-eastlake-trill-ecn-support-01.txt
has been successfully submitted by Donald E. Eastlake and posted to the
IETF repository.

Name:           draft-eastlake-trill-ecn-support
Revision:       01
Title:          TRILL: ECN (Explicit Congestion Notification) Support
Document date:  2016-07-08
Group:          Individual Submission
Pages:          18
URL:
https://www.ietf.org/internet-drafts/draft-eastlake-trill-ecn-support-01.txt
Status:
https://datatracker.ietf.org/doc/draft-eastlake-trill-ecn-support/
Htmlized:
https://tools.ietf.org/html/draft-eastlake-trill-ecn-support-01
Diff:
https://www.ietf.org/rfcdiff?url2=draft-eastlake-trill-ecn-support-01

Abstract:
   Explicit congestion notification (ECN) allows a forwarding element to
   notify downstream devices, including the destination, of the onset of
   congestion without having to drop packets. This document extends this
   capability to TRILL switches, including integration with IP ECN.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 15 Jul 2016 21:11:21 +0100

Sue & Jon (as trill chairs) and TRILLers generally,

I'm not familiar with custom & practice in the TRILL WG, but is it 
appropriate to discuss adoption of this draft yet?

*Background:**
*ECN was added to IP in 2001 (Proposed Std) and is now finally starting 
to happen. Network support is confined to data centres at the mo. And 
bottlenecks on the public Internet including IXPs need to be next. Hence 
the need for a spec of how to support ECN in TRILL.

*Status:**
*Some of you will recall in Buenos Aires Donald & I presented 3 ways of 
solving the problem of supporting ECN in TRILL.
#1 violated layering , so was summarily rejected.
#2 was the only one written up in draft-00
#3 was much better, but only thought up after we submitted draft-00.

In draft-01, we've completely replaced solution #2 with the preferred 
solution #3.
There are no holes in the text now - it's nice and simple and all ready 
to go.

It's fairly terse, so it might need more explanation.
Pls read, comment, bash.

Cheers

Bob

On 08/07/16 17:58, Donald Eastlake wrote:
> From: <[email-masked] <mailto:[email-masked]>>
> To: "Donald E. Eastlake 3rd" <[email-masked] 
> <mailto:[email-masked]>>, Bob Briscoe <[email-masked] 
> <mailto:[email-masked]>>
>
>
> Status: https://datatracker.ietf.org/doc/draft-eastlake-trill-ecn-support/
> Htmlized: https://tools.ietf.org/html/draft-eastlake-trill-ecn-support-01
> Diff: 
> until the htmlized version and diff are available at tools.ietf.org 
> <http://tools.ietf.org>.
>
> The IETF Secretariat
>
>
>
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>
> -- 
> ________________________________________________________________
> Bob Briscoe                               http://bobbriscoe.net/

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 16 Jul 2016 01:02:00 -0400

Bob: 

This is exciting work .    It is good to get it into WG adoption . Let's
chat early in the week so we can determine if when we should start the WG
adoption call.

Sue 

From: trill [mailto:[email-masked]] On Behalf Of Bob Briscoe
Sent: Friday, July 15, 2016 4:11 PM
To: [email-masked]; [email-masked]
Cc: Donald Eastlake
Subject: [trill] Adoption? draft-eastlake-trill-ecn-support-01: Idea thought
up after -00

Background:
ECN was added to IP in 2001 (Proposed Std) and is now finally starting to
happen. Network support is confined to data centres at the mo. And
bottlenecks on the public Internet including IXPs need to be next. Hence the
need for a spec of how to support ECN in TRILL.

Status:
Some of you will recall in Buenos Aires Donald & I presented 3 ways of

In draft-01, we've completely replaced solution #2 with the preferred
solution #3.
There are no holes in the text now - it's nice and simple and all ready to
go.

Cheers

Bob

--------- Forwarded message ----------

To: "Donald E. Eastlake 3rd" <[email-masked]>, Bob Briscoe
<[email-masked]>

Abstract:

The IETF Secretariat

---

From: Bob Briscoe <[email-masked]>
Date: Sat, 16 Jul 2016 15:23:40 +0100

Sue,

OK - will look out for you and Donald and try and make sure we're all in 
a corridor with identical space-time coordinates at some point.

I'm interested to see if anyone will implement ECN support in trill.
So, I'm hoping that adoption might make it easier for an implementer to 
make the case for working on this.

Bob

On 16/07/16 06:02, Susan Hares wrote:
>
> Bob:
>
> This is exciting work .    It is good to get it into WG adoption . 
> Let’s chat early in the week so we can determine if when we should 
> start the WG adoption call.
>
> Sue
>
> *From:*trill [mailto:[email-masked]] *On Behalf Of *Bob Briscoe
> *Sent:* Friday, July 15, 2016 4:11 PM
> *To:* [email-masked]; [email-masked]
> *Cc:* Donald Eastlake
> *Subject:* [trill] Adoption? draft-eastlake-trill-ecn-support-01: Idea 
> thought up after -00
>
> *Background:
> *ECN was added to IP in 2001 (Proposed Std) and is now finally 
> starting to happen. Network support is confined to data centres at the 
> mo. And bottlenecks on the public Internet including IXPs need to be 
> next. Hence the need for a spec of how to support ECN in TRILL.
>
> *Status:
> *Some of you will recall in Buenos Aires Donald & I presented 3 ways 
> of solving the problem of supporting ECN in TRILL.
> There are no holes in the text now - it's nice and simple and all 
> ready to go.
>
>     until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>
>     The IETF Secretariat
>
>
>
>
>     [email-masked] <mailto:[email-masked]>
>
>     Bob Briscoehttp://bobbriscoe.net/
>

---

From: "Susan Hares" <[email-masked]>
Date: Sun, 17 Jul 2016 00:13:19 -0400

Bob: 

We have some trill developers who will be here.   I'll chat with Donald and
the developers. 

Sue 

From: trill [mailto:[email-masked]] On Behalf Of Bob Briscoe
Sent: Saturday, July 16, 2016 10:24 AM
To: Susan Hares; [email-masked]; [email-masked]
Cc: 'Donald Eastlake'
Subject: Re: [trill] Adoption? draft-eastlake-trill-ecn-support-01: Idea
thought up after -00

Sue,

OK - will look out for you and Donald and try and make sure we're all in a
corridor with identical space-time coordinates at some point.

I'm interested to see if anyone will implement ECN support in trill.
So, I'm hoping that adoption might make it easier for an implementer to make
the case for working on this.

Bob

Bob: 

Sue 

Background:

Status:

Cheers

Bob

--------- Forwarded message ----------

Abstract:

The IETF Secretariat