Subject: [tsv-area] [[email-masked]: [dtn-interest] New bundle internet draft and paper comparing protocols forreliability errored delivery.]

From: Wesley Eddy <[email-masked]>
Date: Tue, 17 Jul 2007 23:35:44 -0400

The following announcement may be of interest to TSV-AREA in two contexts:

a) We've been working with and analyzing protocols over UDP-Lite, which is
   a TSV product, and have tried to clearly spell out the support at other
   layers of the stack that's needed to get utility out of using UDP-Lite.
   Due to layering and tunneling of protocols that include checksums
   with different coverage, the effects are not always what's desired.

b) Reliability and robustness are general transport topics, and Saratoga
   LTP, and DTN bundling have some approaches that are at least slightly
   different from existing IETF standards.  Saratoga's approach is heavily
   focused on the filling the requirements of specific pieces of content.
   The checksum we propose adding to DTN's bundle protocol also only
   covers the content (payload), and allows other fields to change in
   transit, which differs from psuedoheader use and transport header
   inclusion in typical Internet transport checksums.

Here are quick links to the documents:
http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/internet-drafts/draft-wood-dtnrg-saratoga/wood-eddy-checksum-coverage-submitted.pdf
http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/internet-drafts/draft-eddy-dtnrg-checksum/draft-eddy-dtnrg-checksum-00a.txt
Lloyd's note below explains more in the context of ongoing DTNRG work.

----- Forwarded message from Lloyd Wood <[email-masked]> -----

To: [email-masked]
From: Lloyd Wood <[email-masked]>
Subject: [dtn-interest] New bundle internet draft and paper comparing protocols forreliability errored delivery.
Date: Tue, 17 Jul 2007 21:35:54 +0100

We have written up a paper examining reliability in protocols, and comparing four different transport protocols that offer delivery of errored data to applications. The insights gained in this work allow us to identify areas of the Licklider and bundle protocols where reliability suffers and more design work is needed. This paper fleshes out the ideas I expressed at the Dublin meet.

http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/internet-drafts/draft-wood-dtnrg-saratoga/wood-eddy-checksum-coverage-submitted.pdf
Checksum Coverage and Delivery of Errored Content
Lloyd Wood, Wesley M. Eddy, Jim McKim and Will Ivancic

Abstract -
   We examine how the overall reliability of network
   protocol stacks is affected by the use of error-detecting
   checksums and Cyclic Redundancy Checks at each protocol
   layer. How these checksums cover their frames and payloads can
   affect the reliability of the rest of the stack, particularly higher
   layers, and the resulting delivery of data. We then apply insights
   gained to a comparison of new protocols promising delivery of
   packets with payload errors, to determine how well those
   protocols achieve that goal when used in realistic stacks.

The above paper has been submitted to ACM Computer Communications Review for review by the Review.

We have also done some work to address one of the areas of weakness that we have identified in that paper, by writing an internet-draft:
http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/internet-drafts/draft-eddy-dtnrg-checksum/draft-eddy-dtnrg-checksum-00a.txt
The DTN Bundle Protocol Payload Checksum Block
Wesley M. Eddy and Lloyd Wood.

Abstract -
   The Delay-Tolerant-Networking Bundle Protocol includes a custody
   transfer mechanism to provide acknowledgements of receipt for
   particular bundles.  No checksum is included in the basic DTN Bundle
   Protocol, however, so it is not possible to verify that bundles have
   been either forwarded or passed through various convergence layers
   without errors having been introduced.  This document partially
   rectifies the situation by defining a Bundle Protocol extension for
   carrying payload checksums and describes how its use can be
   integrated with both custody transfer and fragmentation.

This draft is currently pre-submission, as the drafts archive is not accepting submissions until after next week's IETF meet. Once the archive reopens, we will submit -00.

Enjoy! See you in Chicago.

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]> 
_______________________________________________
dtn-interest mailing list
[email-masked]
http://mailman.dtnrg.org/mailman/listinfo/dtn-interest

----- End forwarded message -----

-- 
Wesley M. Eddy
Verizon Federal Network Systems

---

From: Lloyd Wood <[email-masked]>
Date: Fri, 20 Jul 2007 17:17:43 +0100

I should add that Saratoga, which uses UDP and UDP-Lite to deliver files and stream content, is described in
http://www.ietf.org/internet-drafts/draft-wood-dtnrg-saratoga-01.txt

We'll be presenting on this to tsv-area in Chicago.

cheers,

L.

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 25 Jul 2007 13:32:21 +0100

>We'll be presenting on this to tsv-area in Chicago.

Wes's slides yesterday are available with all other material describing Saratoga at:
http://www.ee.surrey.ac.uk/Personal/L.Wood/saratoga/

fyi,

L.