Subject: Re: [Tsvwg] RFC2960bis ... heads up Steve

From: "Randall R. Stewart" <[email-masked]>
Date: Wed, 16 May 2001 06:42:34 -0500

Jim Bound wrote:
> 
> Let me see if I got right what the story is at this point.
> 
> If node uses global dst addr in ip hdr for INIT then address parameters
> are global, and its src addr in ip hdr is global also.
> 
> If node receives INIT at one of its global addrs (meaning the address
> parameters are global) then  it can send INIT-ACT with site-local
> src addr and its address parameters as site-local if it so desires, and of
> course is responding to global dst addr where the INIT came from.
> 

I think the above works... because if the node foolishly responds
with a site-local source and a destination ip address of a
global... if it is outside the site.. it will be dropped by
a border router...  

If it comes up, then the site locals will be ok but I have
the sneaking hunch other problems await this association depending
on how address selection is done in the kernel. If it depends on
the IPv6 level of the  stack and send a HB ---> to the peers site-local
I bet it will fill in a site-local. This will cause a OOTB response
and thus the assoc will tumble... but this will be because the
source did not properly control its source ip address...sigh.. a
pitfall but more a implementation fault... possibly..

> But in the above case neither can use link-local as address parameters.

I would agree with the above..

> 
> If node sends INIT with dst addr in ip hdr is site-local then it can have
> addr parameters that are site-local or global, but its src addr in ip hdr
> can be site-local or global.

Here there is no possible problem since if your peer is outside the
site, the border router will drop it and you will retry until you
fail to bring up the association.. a good thing :)

> 
> Node responding to INIT with INIT-ACK can respond with site-local or
> global.
> 
> But again in the above case neither can use link-local.

Yep..

> 
> Lastly there is no case where link-locals are recommended to be used as
> address parameters.

Well, one I think... you may list Link-Local's in address parameters
if and only if:

A) You are sending to link local (ip header wise)
B) Any link local you list MUST be on the same network/link.

Now I am not clear (and it sounds like no one really is) a safe
way to determine B (yet). So short of sending oneself a message
you will end up even in the Link-Local case NOT sending any 
link-local parameters in the INIT/INIT-ACK... you might put in
the address you are sending to.. but that is all..

> 
> But this won't be in 2960bis and in some other document..

No, I think we may get it in the BIS yet.

> 
> And this work should be done in the IPv6 working group.

Not done by the IPv6 wg, but consenses reached there that we
have the right rules... I think..

> 
> It is unkown if this other document is standards tracked or not.
> 
> Is this the consenus of the working group?

I think the idea here is to try to get a consenses that we have
the right rules by NG and then funnel this honed consensus
back into the BIS.

R

> regards,
> /jim
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Randall R. Stewart
[email-masked] or [email-masked]
815-342-5222 (cell) 815-477-2127 (work)

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Jim Bound <[email-masked]>
Date: Wed, 16 May 2001 08:57:33 -0400 (EDT)

Randy,

OK ... 

later

/jim