Subject: Re: [Tsvwg] RFC2960bis ... (SCTP in a dentist office)

From: Jonathan Wood <[email-masked]>
Date: Thu, 10 May 2001 12:47:20 -0700 (PDT)

I agree with rules A1-A3, and B1-B3, but not the rest for
the reasons stated in my previous email ("this is not the
place to solve this problem").

However, I would agree if we changed the MUSTs to SHOULDs
in A4-A6 and B4-B5. (What happened to A5, BTW?)

Jonathan

>
>Now here are the basic rules I have devised for the BIS ..
>****Jim please take a close look at these and either 
>educate me or critic them :/
>
> "
> 5.1.2.1 Special rules for IPv6 address scoping
> 
>     When selecting IPv6 addresses to include as parameters in the INIT
>     chunk the following rules MUST be applied:
> 
>     A1) The INIT chunk MUST NOT include any IPv6 Link Local
>         address parameters.
> 
>     A2) An IPv6 Link Local address MAY be used has a destination
>         address for an SCTP packet containing an INIT chunk.
> 
>     A3) If the destination address of the INIT is a Site-Local or
>         Link Local address, then both Site-Local and Global IPv6
>         address parameters SHOULD be included in the INIT chunk.
> 
>     A4) If the destination address of the INIT is an IPv6 Global
>         address then the sender MUST NOT include any Site-Local
>         IPv6 address parameters in the INIT chunk.
> 
>     A6) If the destination address of the INIT is an IPv4 Address
>         then the sender MUST NOT include any Site-Local IPV6
>         address parameters in the INIT chunk.
> 
>     When responding to an INIT chunk and selecting IPv6 address
>     parameters to be included in the INIT-ACK chunk, the following
>rules
>     MUST be applied:
> 
>     B1) The INIT-ACK chunk MUST NOT include any IPv6 Link Local
>         address parameters.
> 
>     B2) If the source address of the SCTP packet containing the INIT
>         chunk is a IPv6 Link-Local address, then both Site-Local and
>         Global IPv6 address parameters SHOULD be included in the
>         INIT-ACK chunk.
> 
>     B3) If the source address of the SCTP packet containing the INIT
>         chunk is an IPv6 Site-Local address, then both Site-Local
>         and Global IPv6 address parameters SHOULD be included in
>         the INIT-ACK chunk.
> 
>     B4) If the source address of the SCTP packet containing the INIT
>         chunk is an IPv6 Global address, then the sender MUST NOT
>         include any Site-Local IPv6 address parameters in the
>         INIT-ACK chunk.
> 
>     B5) If the source address of the SCTP packet containing the INIT
>         chunk is an IPv4 address, then the sender MUST NOT
>         include any Site-Local IPv6 address parameters in the
>         INIT-ACK chunk.
> 
> "
> 
>-- 
>Randall R. Stewart
>Systems & Solutions Engineering
>Cisco Systems Inc.
>[email-masked] 815-342-5222 or 815-477-2127
>
>
>
>---
>You are currently subscribed to sigtran as: [email-masked]
>To unsubscribe send a blank email to 
[email-masked]

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 10 May 2001 15:51:01 -0500

> in A4-A6 and B4-B5. (What happened to A5, BTW?)
Opps... A6) is a typo and should be A5 :/

Now as far as A4-A6 and B4-B5... Please to tell me how you will
prevent losing the association?

Someone, somewhere on two different sites (aka cisco and sun) will set
a host to siteaddress FECO::0001 one of them being a machine I send
an INIT to destined for a global address...

and then when I send you a INIT, you will send me the INIT-ACK with
FECO::0001
inside it (with out rule B4). Then of course I will send a HB to 
FEC0::0001, not knowing that you are not on my site... (unless Jim
has a way for me to tell.. I don't know it... Jim??) 

When the local machine configured to FEC0::0001 gets the HB, of course
being
a SCTP capable machine, it will send back an OOTB abort and thus
our association will go in the dumper...

How can you avoid this may I ask?

Either you or Jim need to tell me this before I would be willing
to agree with you..

R