Subject: Re: [Tsvwg] Why Payload Protocol in every data chunk?

From: [email-masked]
Date: Thu, 11 Jul 2002 15:37:21 -0400

Michael,
Thanks for the answer.  I guess I buy your 2nd reason more than the 1st. I 
can see several problems with upper layers sharing an association!
DaveS.

Michael Tuexen <[email-masked]>
07/11/2002 01:58 PM

        To:     [email-masked]
        cc:     [email-masked]
        Subject:        Re: [Tsvwg] Why Payload Protocol in every data chunk?

Dave,

you got the reason. So you can transport multiple upper layers
within on association. The PPI is transported between the SCTP
endpoints and given to the upper layer.

It can also be used for packet inspection in nodes between the
end points. You do not have to rely on the port numbers. Something
ethereal, for example, does and can dissect the SIGTRAN protocols even
if the well known ports are not used.

Best regards
Michael

On Thursday, July 11, 2002, at 06:56 PM, [email-masked] wrote:

> Can anyone explain why we have the payload protocol parameter in every
> data chunk?  The only reason I can come up with would be to allow an
> association to be shared by multiple upper layers, otherwise this value
> could be exchanged only once, during assoc initialization...
> I realize its late to change such a thing, but I'm just curious.
>
> Thanks,
> Dave Sclarsky
> Radisys Corporation
> 520 Fellowship Road
> Suite C-304
> Mt. Laurel, NJ 08054
> email:[email-masked]
>
>
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
>
>
[email-masked]

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "La Monte Henry Piggy Yarroll" <[email-masked]>
Date: Fri, 12 Jul 2002 05:25:06 -0500

The PPID is really intended to make life easier for middle boxes in
general, not just sniffers.  E.g. L4-aware routers can more reliably
identify different kinds of flows for QoS-based classification.  You
don't want to force middle boxes into maintaining state for each
association--that doesn't scale.