Subject: [Tsvwg] SCTP RTT measurement question.

From: Sasha Ruditsky <[email-masked]>
Date: Mon, 29 Jul 2002 11:26:43 -0400

Hi 

I have SCTP RTT measurement question. 
RFC 2960 in 6.3.1 C4) suggests:
	...a new RTT measurement MUST be made each round trip...

and in 8.3 
	... chunk which can be used for updating path RTT 
	(usually including first transmission DATA, INIT, COOKIE ECHO,
HEARTBEAT etc.)...

The problem is that I do not see any mechanism to measurement of RTT each
round trip.
(Of course I may send HEARTBEAT each RTT, but...)

Please help me understand what do I miss.

Thanks
Sasha

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: [email-masked]
Date: Mon, 29 Jul 2002 18:33:34 +0300

Hi Sasha!

> -----Original Message-----
> From: ext Sasha Ruditsky [mailto:[email-masked]]
> Sent: 29. July 2002 18:27
> To: [email-masked]
> Subject: [Tsvwg] SCTP RTT measurement question.
> 
> 
> Hi 
> 

	At the beginning of the paragraph it says "when data is in flight". Of course, this means that if you are transferring data and you have new DATA chunks to use as a measure of the RTT, you MUST make that measure. Otherwise, just do your best :-).

	BR Iván Arias Rodríguez

---

From: Sasha Ruditsky <[email-masked]>
Date: Mon, 29 Jul 2002 11:49:00 -0400

Hi Iván

My problem is that I cannot understand HOW I can use these 
new DATA chunks for RTT measurements.
............
I may measure the time between DATA and the corresponding SACK,
but spec does not always guarantee that SACK will be sent immediately 
in response to DATA.

Sasha

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Monday, July 29, 2002 11:34 AM
To: [email-masked]; [email-masked]
Subject: RE: [Tsvwg] SCTP RTT measurement question.

	Hi Sasha!

> Please help me understand what do I miss.

	At the beginning of the paragraph it says "when data is in flight".
Of course, this means that if you are transferring data and you have new
DATA chunks to use as a measure of the RTT, you MUST make that measure.
Otherwise, just do your best :-).

	BR Iván Arias Rodríguez