Subject: [Tsvwg] about HighData

From: Lili Wang <[email-masked]>
Date: Wed, 17 Jul 2002 10:10:36 -0400 (EDT)

Henderson, Thomas R wrote:
>The pipe variable SHOULD NOT be used to limit transmissions after a
>retransmission timeout, even though Update() and NextSeg() can be used to
>intelligently select segments for transmission.  Furthermore,
>RecoveryPoint
>SHOULD NOT be changed upon a retransmission timeout, and additional fast
>recovery phases SHOULD NOT be initiated until a cumulative ACK is
>received
>for RecoveryPoint."

   It seems from the draft that fast recovery can be invoked before
finishing retransmiting past HighData after timeout. 
Even if it is not allowed to invoke fast recovery in that case,
using NextSeg() may cause some packets not allowed to
retransmit after timeout() when HighData is not reset.
Some packets that are below HighData and do not meet the 
criteria(a)-(c)in LeftNetwork() will not be returned by  
NextSeg(), even if they are not retransmitted and need to 
retransmit after a timeout. 

Lili

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Wed, 17 Jul 2002 11:41:25 -0700

> -----Original Message-----
> From: Ethan Blanton [mailto:[email-masked]]
> 
> The algorithm for packet selection during the slow start following a
> timeout is not specified by this draft.
> 
> Since NextSeg is as such not used after a timeout, LeftNetwork also
> does not need special-cased.
> Ethan
> 

OK, I think that Ethan's post clarifies things considerably.  But based on
this, the last sentence in 5.1 would need to be changed to align with this
(since use of NextSeg() is currently recommended).  

I would suggest referencing RFC2883 for information, and stating that this
algorithm can (should?) be used with RFC2883.  

Tom