Subject: RE: [Tsvwg] HEARTBEAT/cwnd

From: [email-masked]
Date: Thu, 25 Jul 2002 15:40:59 +0300

Hi!

	With HEARTBEAT you are testing the reachability of the addresses... With DATA chunks you are testing their capacity...

	So, as far as you are not testing the capacity of the pipe, you reduce your assumptions about the throughput... You might know that it is still working, but you don't know how much can you put there... maybe it got congested... :-/

	And about the period... Well, you send DATA chunks as long as you have something to send... However, you just send HEARTBEATs every now and then to addresses that do not have any traffic... The idea is that you don't really send many HEARTBEATs, so you don't flood the network with "useless" bytes (I'm not saying they are useless, just that they don't carry any user data)...

	BR Iván Arias Rodríguez

> -----Original Message-----
> From: ext Tolga Asveren [mailto:[email-masked]]
> Sent: 25. July 2002 15:47
> To: [email-masked]
> Subject: RE: [Tsvwg] HEARTBEAT/cwnd
> 
> 
> Ivan,
> 
> Then what is the reason that HEARTBEAT does not prevent cwnd 
> to shrink? What
> is the difference between HEARTBEAT and DATA from congestion control
> procdures point of view, if they are sent with the same period?
> 
> 
>     Tolga
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]
> > Sent: Thursday, July 25, 2002 7:13 AM
> > To: [email-masked]; [email-masked]
> > Subject: RE: [Tsvwg] HEARTBEAT/cwnd
> >
> >
> > 	Hi Tolga!
> >
> > 	See my comments inline...
> >
> > > -----Original Message-----
> > > From: ext Tolga Asveren [mailto:[email-masked]]
> > > Sent: 25. July 2002 3:03
> > > To: [email-masked]
> > > Subject: [Tsvwg] HEARTBEAT/cwnd
> > >
> > >
> > > In RFC2960 it is said at the end of page87:
> > > "When the endpoint does not transmit data on a given
> > > transport address, the
> > > cwnd of the transport address should be adjusted to
> > > max(cwnd/2), 2*MTU) per
> > > RTO"
> > >
> > > Does HEARTBEAT prevent cwnd to shrink if send in a period
> > > less than RTO or
> > > not? (Although it is RECOMMENDED to send HEARTBEAT at a period of
> >
> > 	Nope... You must transmit data... A HEARTBEAT might change
> > the "idle situation" of an address, but this is a different
> > thing... I.e., if you send a HEARTBEAT, you restart your "idle
> > timer" for that address, but the "shrinking timer" is still
> > running until you send some DATA chunk to that address...
> >
> > > HB.interval+RTO+jittering of +/- 50%, I assume I can send it
> > > with a lower
> > > period given that only RECOMMENDED keyword is used)
> >
> > 	Or you may even not send them at all...
> >
> > 	You are right, it is a recommendation (not to flow the
> > network with HEARTBEATs/ACKs), but you could use another method
> > if you think that it is more reasonable for your purposes...
> >
> > 	BR Iván Arias Rodríguez
> >
> > >     Tolga
> > >
> > >
> > > _______________________________________________
> > > tsvwg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/tsvwg
> > >
> 
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 25 Jul 2002 09:05:02 -0400

Ivan,

> Sent: Thursday, July 25, 2002 8:41 AM
> 	With HEARTBEAT you are testing the reachability of the
> addresses... With DATA chunks you are testing their capacity...
[TOLGA] I agree using HEARTBEAT to avoid cwnd shrinking would be using them
for something, which is not the real intention.
>
> 	So, as far as you are not testing the capacity of the pipe,
> you reduce your assumptions about the throughput... You might
> know that it is still working, but you don't know how much can
> you put there... maybe it got congested... :-/
[TOLGA] But also with HEARTBEAT I am sending some amount of bytes through
the pipe. Let's say length of the DATA I send and my HEARTBEAT are the same.
Then what is the difference if they are sent with the same period? In fact I
understand your explanation but then why cwnd does not shrink with user data
of any length? RFC depends there just on the period. What will happen if I
send for some time a high volume traffic (and let's assume cwnd grows) then
the volume decreases, but still messages are sent with a period lower than
RTO. cwnd still stays the same. But based on your argument again we are not
sure whether the throughtput of the pipe is as much as before.
>
> 	And about the period... Well, you send DATA chunks as long
> as you have something to send... However, you just send
> HEARTBEATs every now and then to addresses that do not have any
> traffic... The idea is that you don't really send many
> HEARTBEATs, so you don't flood the network with "useless" bytes
> (I'm not saying they are useless, just that they don't carry any
> user data)...
[TOLGA] Yes, but to avoid cwnd to shrink, on the SCTP-user I will need to
generate some messages, which don't really contain usefull information.