Subject: RE: [Tsvwg] HEARTBEAT/cwnd

From: [email-masked]
Date: Thu, 25 Jul 2002 14:13:18 +0300

Hi Tolga!

	See my comments inline...

> -----Original Message-----
> From: ext Tolga Asveren [mailto:[email-masked]]
> Sent: 25. July 2002 3:03
> To: [email-masked]
> Subject: [Tsvwg] HEARTBEAT/cwnd
> 
> 
> In RFC2960 it is said at the end of page87:
> "When the endpoint does not transmit data on a given 
> transport address, the
> cwnd of the transport address should be adjusted to 
> max(cwnd/2), 2*MTU) per
> RTO"
> 
> Does HEARTBEAT prevent cwnd to shrink if send in a period 
> less than RTO or
> not? (Although it is RECOMMENDED to send HEARTBEAT at a period of

	Nope... You must transmit data... A HEARTBEAT might change the "idle situation" of an address, but this is a different thing... I.e., if you send a HEARTBEAT, you restart your "idle timer" for that address, but the "shrinking timer" is still running until you send some DATA chunk to that address...

> HB.interval+RTO+jittering of +/- 50%, I assume I can send it 
> with a lower
> period given that only RECOMMENDED keyword is used)

	Or you may even not send them at all...

	You are right, it is a recommendation (not to flow the network with HEARTBEATs/ACKs), but you could use another method if you think that it is more reasonable for your purposes...

	BR Iván Arias Rodríguez 

>     Tolga
> 
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 25 Jul 2002 08:46:59 -0400

Ivan,

Then what is the reason that HEARTBEAT does not prevent cwnd to shrink? What
is the difference between HEARTBEAT and DATA from congestion control
procdures point of view, if they are sent with the same period?

    Tolga

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Thursday, July 25, 2002 7:13 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Tsvwg] HEARTBEAT/cwnd
>
>
> 	Hi Tolga!
>
> 	Nope... You must transmit data... A HEARTBEAT might change
> the "idle situation" of an address, but this is a different
> thing... I.e., if you send a HEARTBEAT, you restart your "idle
> timer" for that address, but the "shrinking timer" is still
> running until you send some DATA chunk to that address...
>
> 	You are right, it is a recommendation (not to flow the
> network with HEARTBEATs/ACKs), but you could use another method
> if you think that it is more reasonable for your purposes...
>
> 	BR Iván Arias Rodríguez
>
> >     Tolga
> >
> >

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 25 Jul 2002 15:01:33 +0200

Tolga,

the HEARTBEAT procedure was designed for path supervision in case of an 
idle
path (all but the primary are normally idle, sometimes even the primary 
is idle).

During the idle period HEARTBEATS are used for RTT measurement. The time 
to detect the
path failure depends on the rate of the HEARTBEATS. But it is not so 
important to know
that an idle path is not working. Therefore the HEARTBEAT.Interval was 
added to the RTT
and a relative hight value of HEARTBEAT.interval was chosen.

Also only DATA chunks are limited by the congestion/flow control because 
you can have
multiple of them in flight. You can have only one HEARTBEAT in flight 
per path. If the timer runs
off you assume that it was lost and you do exponential back off for that 
path.

Best regards
Michael

>> if you think that it is more reasonable for your purposes...
[email-masked]