Subject: RE: [Tsvwg] SCTP:flight size

From: [email-masked]
Date: Wed, 31 Jul 2002 15:25:05 +0300

Of course but, if they have timed-out, they are always marked for retransmission, and they are not considered to be "in the air" anymore...

	BR Iván Arias Rodríguez

> -----Original Message-----
> From: ext Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 31. July 2002 15:19
> To: Randall Stewart
> Cc: Khan, Mohammad; [email-masked]'; Pathak, Sunil K; Subramaniam,
> Siva; Patel, Chirayu
> Subject: Re: [Tsvwg] SCTP:flight size
> 
> 
> Randall,
> 
> ...and not timed-out and not marked for retransmission...
> 
> --brian
> 
> On Wed, 31 Jul 2002, Randall Stewart wrote:
> 
> > Yes,
> > 
> > it is what you have sent but is "in the air" and un-acknowledged.
> > 
> > R
> > 
> > "Khan, Mohammad" wrote:
> > > 
> > > Randall,
> > > Can I take the flightsize as "the number of bytes not 
> acknowledged by peer
> > > for the specific destination address"
> > > Regds
> > > kashif
> > > 
> > > 
> > > 
> > > -----Original Message-----
> > > From: Randall Stewart [mailto:[email-masked]]
> > > Sent: Tuesday, July 30, 2002 7:03 PM
> > > To: Khan, Mohammad
> > > Cc: [email-masked]'; Pathak, Sunil K
> > > Subject: Re: [Tsvwg] SCTP:flight size
> > > 
> > > "Khan, Mohammad" wrote:
> > > >
> > > > Hi All,
> > > > In sctpimpguide-05.txt section 2.14.2 a variable 
> flightsize is specified.
> > > Is
> > > > it the size of data requested by the SCTP User? Pls confirm.
> > > > Regards
> > > > kashif
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > tsvwg mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/tsvwg
> > > Kashif:
> > > 
> > > Flight size is the number of bytes "in-transit" to the remote
> > > peer. We probably should have a defintion here.. since I see
> > > we have slipped back in to specifying it.. something we
> > > tried to avoid the first time around :-0... but I guess
> > > it is hard NOT to mention it .
> > > 
> > > R
> > > 
> > > --
> > > Randall R. Stewart
> > > [email-masked] 815-342-5222 (cell phone)
> > > 
> > > _______________________________________________
> > > tsvwg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/tsvwg
> > 
> > -- 
> > Randall R. Stewart
> > [email-masked] 815-342-5222 (cell phone)
> > 
> > _______________________________________________
> > tsvwg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/tsvwg
> 
> -- 
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 31 Jul 2002 06:42:26 -0600

Iván,

prsctp packets are not always marked for retransmission after timeout...

--brian

---

From: Randall Stewart <[email-masked]>
Date: Wed, 31 Jul 2002 09:14:35 -0500

Brian:

You are correct in that a prsctp packet may not marked for
retransmission after a time-out. If it is decided that we
will NOT retransmit it we end up marking it to be skipped
by.. but it is also not considered inflight...  so I guess
in summary:

Packets are considered in flight if:

1) They are NOT marked for retransmission
<and>
2) They are NOT marked to be skipped or dropped (pr-sctp)
<and>
3) They have been transmitted and are un-acknowledged.

A timeout of course causes 1 and or 2 to happen to anything
in flight.

R

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 31 Jul 2002 11:06:29 -0600

Randall,

What about FR and bursts?

--brian

---

From: Randall Stewart <[email-masked]>
Date: Wed, 31 Jul 2002 12:31:43 -0500

What does FR and bursts have to
do with flight size?

If you FR something it remains in flight. If you recoginize
it as needing FR but can't due to a cwnd limit.. its
back to being marked for retransmission... in effect the FR
marks it for retransmission and then you try to send...

I don't see any ambiguity here..

R

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 31 Jul 2002 17:58:19 -0600

Randall,

If FR marks for retransmission but doesn't reduce
flight size then (1) below is incorrect.

--brian