Subject: [Tsvwg] Re: tsvwg digest, Vol 1 #701 - 7 msgs

From: venkat venkatsubra <[email-masked]>
Date: Tue, 23 Jul 2002 11:43:06 -0500

Mark,
I think the ssthresh (along with other information like
smoothed rtt estimator, etc.) is cached in the routing
entry if it is not the default route. When using PMTUD
a  host route is created  anyway.  These values get saved
there.
Venkat

> Message: 2
> To: Reiner Ludwig <[email-masked]>
> From: Mark Allman <[email-masked]>
> Reply-To: [email-masked]
> cc: Sally Floyd <[email-masked]>, [email-masked]
> Subject: Re: [Tsvwg] Re: Limited Slow-Start for TCP with Large Congestion Windows
> Organization: BBN Technologies/NASA GRC
> Date: Sun, 21 Jul 2002 22:45:33 -0400
>
> >  From own experience, I'm convinced that the per-route metrics
> > implemented in BSD4.4-Lite (see Stevens Vol.2) is an extremely
> > elegant solution to the slow start overshoot problem: A TCP that
> > terminates stores its ssthresh in the per-route metrics, and
> > subsequent TCPs going via the same (explicit) route initialize
> > their ssthresh from there. Those were early attempts of a
> > congestion manager ...
>
> I am not familiar with the implementation at all, so I am trying to
> understand this....  My workstation has one route entry --- all
> traffic goes one way.  So, does that mean that all my connections
> share some cached ssthresh value?  That would not seem right to me.
> On the other hand, if all my connections to a.b.c.d share an
> ssthresh value that seems more reasonable.
>
> Thanks,
> allman
>
> --
> Mark Allman -- NASA GRC/BBN -- http://roland.grc.nasa.gov/~mallman/
>

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Fri, 26 Jul 2002 07:59:30 -0500

Venkat:

You are correct here.. the only thing I will add is
a bit further on Mark's query on the default route.
I believe what would happen is that the default route
is cloned. Thus the default route itself would NOT
get the these values stored against it. The cloned route
hangs around for a bit and may get re-used if someone
else "connects" to the same host. So basically it
works real well in that only connections to the same
host share these values... 

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)