Subject: RE: [Tsvwg] What are the test setup & scenarios for IPv6 at the i ncoming SCTP bakeoff

From: Tuexen Michael <[email-masked]>
Date: Wed, 3 Jul 2002 16:13:14 +0200

Dear Simon,

see my comments below.

Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CC SE 7    e-Mail: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, July 03, 2002 2:24 PM
> To: [email-masked]
> Subject: [Tsvwg] What are the test setup & scenarios for IPv6 at the
> incoming SCTP bakeoff
> 
> 
At the bakeoffs we use always (almost) the same setup.
> Hi All,
> 
> At the incoming SCTP bakeoff, what the test setups for IPv6 
> will look like?
>  What are the test scenarios for IPv6? Will the followings be tested?
> IPv6 -> IPv6 associations (single homed? multi-homed?)
You normally get two ethernet connections. Each gives you access
to an IPv4 net and an IPv6 net. Routers make sure that everyone can
be reached. So if you have a IPv6 only implementation you can use it,
if you have a IPv4 only inplementation you can use it, if you have a 
dual stack implementation you can use IPv4 and IPv6 at the same time.
> dual stack ipv4 & ipv6  ?
Supported.
> ip4->ipv6(mapped as a v4 addr)
> ipv6 tunneled over ipv4 ?
Test testbed routes v6 and v4 and provides no tunneling. 
> 
> Thanks in advance.
> 
> Simon
> 
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Andreas Jungmaier <[email-masked]>
Date: Wed, 10 Jul 2002 17:01:51 +0200

Dear Simon, dear all, 

as Michael already explained, the setups will be similar to the last
interop tests.
That meaning: we use FreeBSD boxes as gateway routers which support
IPv4 and IPv6 and you get two ethernet drops in two IPv4 class C
subnets, respectively two IPv6 global and site-local /64 prefixes,
from which your IPv6 host will auto-configure global, site-local and 
link-local IPv6 addresses.

> >  What are the test scenarios for IPv6? 
I am currently planning the scenarios as well as the setup for 
the interop. In about 2 weeks time I will notify all registered
participants, and mail them a detailed plan for address
configuration and network and such.

Testing will be based on the document
http://search.ietf.org/internet-drafts/draft-stewart-tsvwg-sctpscore-00.txt
and I will try to outline a detailed set of scenarios for
the 5 days of the interop, in two weeks time.

> > Will the followings be tested?
> > - IPv6 -> IPv6 associations (single homed? multi-homed?)
> > - dual stack ipv4 & ipv6  
Yes. As you wish.

> > ip4->ipv6(mapped as a v4 addr)
Have not really looked into this way of operation. But I am 
sure that SCTP implementations will not support it !
(see RFC 2960, page 27: 
"Note: A sender MUST NOT use an IPv4-mapped IPv6 address [RFC2373]
 but should instead use an IPv4 Address Parameter for an IPv4
 address." )

> > ipv6 tunneled over ipv4 ?
I am not sure why we would want this. It is just a tool
for internet deployment, we will have an all-IPv4 and all-IPv6 
network.

Hope that helps, 
should you have any more questions, please do not hesitate to contact
me directly.

Best regards.
Andreas

- -- 
- ---------------------------------------------------------------------------
Dipl.-Ing. Andreas Jungmaier              |  Stop sending E-POSTCARDS ! 
Computer Networking Technology Group      |  Send E-MAILS --  Use PGP !
University of Essen                       | 
http://www.exp-math.uni-essen.de/~ajung   |   http://www.gnupg.org
My PGP Key-ID: D3824AC0                   |   http://wwwkeys.pgp.net
- ---------------------------------------------------------------------------
My PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0 
- ---------------------------------------------------------------------------

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 10 Jul 2002 18:23:20 +0200

Dear all,
just a clarification below.
Best regards
Michael
On Wednesday, July 10, 2002, at 05:01 PM, Andreas Jungmaier wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Dear Simon, dear all,
>
You still have to configure the IPv4/IPv6 routes on your host manually.
> - 
> ---------------------------------------------------------------------------
> - 
> ---------------------------------------------------------------------------
> - 
> ---------------------------------------------------------------------------
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
>
> iD8DBQE9LExfXAsLBNOCSsARAoDyAJ9BOI3BuyRirfLeXNLoZ2IPCmYNlQCeIjWm
> EB3qbJgAsnocFx1q5DGBRd0=
> =Qrvk
> -----END PGP SIGNATURE-----
>
>
[email-masked]

---

From: Peter Lei <[email-masked]>
Date: Thu, 11 Jul 2002 00:25:31 -0500

comment on v4-mapped addresses below--
--peter

>  but should instead use an IPv4 Address Parameter for an IPv4

Simon, I'm not sure what you're referring to exactly.  v4-mapped addresses
only really make sense on a dual-stack host communicating with a v4 only
host (eg. you don't see v4-mapped addresses on the wire).  So, v4-mapped
support is implementation and application dependent (ie. I as the v4 host
couldn't care less if your socket is AF_INET or AF_INET6, as long as you
accept my v4 packets and you send v4 packets to me...).

Our implementation currently allows you to connect/sendto v4 or v4-mapped
addresses in an AF_INET6 socket; connections from a v4 host can be sent
up the socket as v4 or v4-mapped, depending on the socket option/kernel
tunable.  Of course, if the AF_INET6 socket has been set to V6_ONLY, then
no v4-mapped addresses are allowed.