Subject: [Tsvwg] Question about SCTP association

From: 廖彥彰 <[email-masked]>
Date: Wed, 14 Aug 2002 16:00:41 +0800

Hello:

Can a SCTP multi-homing association connect to different hosts?

Yien-Chang

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Coene Lode <[email-masked]>
Date: Wed, 14 Aug 2002 13:26:38 +0200

Siemens atea
atealaan 34          2200 Herentals, Belgium
E-mail: [email-masked]
Tel: +32-14-252081
Fax: +32-14-253212

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, August 14, 2002 10:01 AM
> To: [email-masked]; [email-masked]
> Subject: [Tsvwg] Question about SCTP association
> 
> 
> Hello:
> 

No.
What you are talking about is a cluster of hosts.
A host acts as a endpoint with one or more IP addresses.
The association will connect to the endpoint with 
one or more IP addresses of that particular endpoint. 
If you want to reach another host(= a different endpoint) 
then you'll have to setup another association with that particular host.
A single association that ends up on different hosts 
implies state sharing across those hosts and that 
doesn't seem to look (to me) as a easy problem. 
And gives us problems with the definition and use of the term endpoint.
It boils down to the namespace problem as was shown in 
Elliot's IRTF presentation in the plenary at Yokohama. 

http://www1.ietf.org/mail-archive/ietf/Current/msg16574.html