Subject: Re: [Tsvwg] AD review of: draft-ietf-sigtran-sctp-mib-07.txt

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 28 Aug 2002 04:30:33 -0600

Bert,

I was not disagreeing with your comments:  I found all
of your comments valuable and agree that the text should
be changed to address the issues you have raised.

On another note, I would like to see the SCTP MIB come into
much closer alignment with the TCP MIB.

--brian

On Wed, 28 Aug 2002, Wijnen, Bert (Bert) wrote:

> Thanks for explaining how your implementation handles zero.
> This exactly points out why I want the behaviour documented
> in the DESCRIPTION clause, so that we can get the same and
> interoperable implementations. And so that a management
> station does know what exactly it means when it finds 
> (or sets) such a value.
> 
> Thanks,
> Bert 
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: dinsdag 27 augustus 2002 23:21
> > To: Wijnen, Bert (Bert)
> > Cc: [email-masked]; Shawn Routhier (E-mail)
> > Subject: Re: [Tsvwg] AD review of: draft-ietf-sigtran-sctp-mib-07.txt
> > 
> > 
> > Bert,
> > 
> > On Mon, 26 Aug 2002, Wijnen, Bert (Bert) wrote:
> > 
> > [snip]
> > > - A number of objects like sctpRtoMin, sctpRtoMax etc have 
> > >   as data type Unsigned32. That means it can have a value of zero.
> > >   I wonder if a zero value makes sense. If it does, then maybe
> > >   it has special meaning? If so then pls describe. If it
> > >   does not make sense, then better add a range to exclude it.
> > >   I also wonder if a value of 1 or 2 millisecodns or such makes
> > >   sense. If not, maybe say some words about it or add a lower range
> > >   that sort of specifies the minimum that makes sense.
> > >   Does Max have to be GE than Min ??
> > [snip]
> > 
> > A value of zero means that retransmissions will be immediate or at
> > the granularity of the clock.
> > 
> > [snip]
> > > - sctpAssocHeartBeatTimer
> > >   what would a value of zero mean?
> > >   do values like 1 or 2 milliseconds make sense?
> > [snip]
> > 
> > A value of zero means that heartbeats would not be delayed.
> > 
> > Our implementation permits zero to be assigned to these protocol
> > parameters for use in specific high-performance environments.
> > 
> > --brian
> > 
> > -- 
> > Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> > [email-masked]    ¦ world; the unreasonable one persists in  ¦
> > http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
> >                         ¦ Therefore  all  progress  depends on the ¦
> >                         ¦ unreasonable man. -- George Bernard Shaw ¦
> > 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 28 Aug 2002 12:04:02 +0200

Thanks,
Bert