Subject: [Tsvwg] archive

From: Randall Stewart <[email-masked]>
Date: Wed, 07 Aug 2002 05:40:30 -0500

Dear all:

Well after a bit of shuffling and several emails with
my IT dept.. I have found:

1) Yes IT can build an archive for sctp-impl 
2) But NO external people can't access it :-0

So I have decided to NOT depend on ITS and fix it myself :-0
(I should have did this from the beginning)... so

You will now find (after the 24 hours it takes to be added of
course :-/) that at:

http://www.sctp.org

a email archive of all discussion sent to the
[email-masked]
list.

It uses hypermail which is nice ..

Enjoy

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Arun Prasad <[email-masked]>
Date: Wed, 07 Aug 2002 19:38:52 +0100

Hi all,
    Just an implementation querry.... Does anyone have tried IPV6 support for
Solaris ??... if so

* I guess using recvmsg is the only solution to get the Destination address of the
   received IPV6 packet...

* Does the procedure stated in rfc:2292 fetches the IP-ADDR (ie., by using
IPPROTO_IPV6 and IPV6_PKTINFO constants in recvmsg)???
    Its always returning IPV6 address as zero for the sample program written here....

Does Solaris fully support this ( or Iam goofing up anything...)

Thanks
-arun

The sample code which I used to test.... This program receivs a IPV6 packet
generated for address "::1"
#include <stdio.h>

#include <sys/types.h>
#include <sys/socket.h>

#include <netinet/in.h>
#include <arpa/inet.h>

#include <netinet/in_systm.h>
#include <netinet/ip.h>
#include <netinet/ip_icmp.h>

main()
{
int hlen,sfd,i;
socklen_t *len=(socklen_t *) malloc(sizeof(socklen_t));
struct sockaddr_in6 skdaddr;
char str[50];
int on=1;

const size_t ADO_BUF_SIZE = 1024;
const size_t BUFFER_LENGTH = 65536;

int ret;
uint8_t *ado_buffer;
uint8_t *my_buffer;
struct msghdr msg;
struct iovec iov;
int found = 0;
struct in6_pktinfo *info;
struct cmsghdr *cm;
struct in6_addr sender_address;
struct cmsghdr *rcmsgp;

ado_buffer = (uint8_t *)malloc(ADO_BUF_SIZE);
if (ado_buffer == NULL) exit(0);

my_buffer = (uint8_t *)malloc(BUFFER_LENGTH);
if (my_buffer == NULL) exit(0);

/* qui setti correttamente il buffer di destinazione */
iov.iov_base = my_buffer;
iov.iov_len = BUFFER_LENGTH;

memset(&msg, 0, sizeof(msg));

msg.msg_iov = &iov;
msg.msg_iovlen = 1;
msg.msg_control =(void*) ado_buffer;
msg.msg_controllen = ADO_BUF_SIZE;

rcmsgp = (struct cmsghdr *)ado_buffer;

rcmsgp->cmsg_level = IPPROTO_IPV6;
rcmsgp->cmsg_type  = IPV6_PKTINFO;
rcmsgp->cmsg_len   = CMSG_LEN (sizeof (struct in6_pktinfo));

if((sfd= socket(AF_INET6, SOCK_RAW,132 ))<0)
  printf("sock_create failed %d",sfd);

setsockopt(sfd, IPPROTO_IPV6, IPV6_PKTINFO,  &on, sizeof(on));

for(;;)
{
ret = recvmsg(sfd, &msg, 0);
printf ("ret - %d\n",ret);

for (cm =CMSG_FIRSTHDR(&msg); cm != NULL; cm = CMSG_NXTHDR(&msg, cm)) {
      printf ("chiki...\n");
      printf ("level = %d,type =%d\n",cm->cmsg_level,cm->cmsg_type);
   if (cm->cmsg_level == IPPROTO_IPV6 &&
            cm->cmsg_type == IPV6_PKTINFO ) {
      info = (struct in6_pktinfo*)CMSG_DATA(cm);
      printf ("HURRAY.\n");
      inet_ntop(AF_INET6, (void *)&(info->ipi6_addr),  str, 50);

      printf ("Addr = %s\n",str);
   }
  }

}
}

:!gcc srx1.c -D_XPG4_2 -D__EXTENSIONS__ -lsocket -lnsl -o rmsg -g && ./rmsg
ret - 1400
chiki...
level = 41,type =11
HURRAY.
Addr = ::

---

From: "Hyunjeong Lee" <[email-masked]>
Date: Fri, 9 Aug 2002 11:30:06 +0900

Dear all,
I have some questions related to SCTP mobility features.

In the SCTP multi-homing feature, it can extended for dynamically adding and deleting IP addresses from the local and remote address lists.

In this case, 
1. What are the primives between ULP and SCTP to add and delete new IP address?
2. What is the chunk type between SCTP peers to apply the new IP address? 

Thanks in advance,

Best Regards,
Hyunjeong Lee.

---

From: Andreas Jungmaier <[email-masked]>
Date: Fri, 9 Aug 2002 10:44:29 +0200

Hyunjeong Lee,

please have a look at 
http://search.ietf.org/internet-drafts/draft-ietf-tsvwg-addip-sctp-05.txt

it's all in there.

Regards,
Andreas

Am Freitag, 9. August 2002 04:30 schrieb Hyunjeong Lee:
> In the SCTP multi-homing feature, it can extended for dynamically adding
> and deleting IP addresses from the local and remote address lists.
>
> In this case,
> 1. What are the primives between ULP and SCTP to add and delete new IP
> address? 2. What is the chunk type between SCTP peers to apply the new IP
> address?
>
> Thanks in advance,
>
> Best Regards,
> Hyunjeong Lee.

- -- 
- ---------------------------------------------------------------------------
Dipl.-Ing. Andreas Jungmaier              |  Stop sending E-POSTCARDS ! 
Computer Networking Technology Group      |  Send E-MAILS --  Use PGP !
University of Essen                       | 
http://www.exp-math.uni-essen.de/~ajung   |   http://www.gnupg.org
My PGP Key-ID: D3824AC0                   |   http://wwwkeys.pgp.net
- ---------------------------------------------------------------------------
My PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0 
- ---------------------------------------------------------------------------