Subject: RE: [rddp] RE: [Tsvwg] Another Possible Argument for IFT over MPA

From: [email-masked]
Date: Fri, 1 Nov 2002 17:47:06 -0700

Jim,

I don't see how you can assume that out of order arrival will be rare. One cause of out of order delivery is TCP's congestion control. Any time congestion control is operating, there is a control loop where a drop causes the window to be decreased, then the window is increased until a drop causes it to be decreased again. Therefore, one can not count on packet drops being rare. When data flows are heavy and congestion causes packet drops, it isn't a good time to react inefficiently. 

Pat

-----Original Message-----
From: Williams, Jim [mailto:[email-masked]]
Sent: Thursday, October 31, 2002 9:55 AM
To: 'Joe Touch'
Cc: [email-masked]; [email-masked]
Subject: [rddp] RE: [Tsvwg] Another Possible Argument for IFT over MPA

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> 
> [...]
>
> A secondary reason is that IP does not guarantee in-order delivery.

True.  But I am assuming that it is quite rare
in practice that IP actually delivers out of order.  Is
this correct?

> [...]
> 
> Down != 0. Even ECN drops packets.

True again.  But if dropped packets are sufficiently
rare, the endpoint can handle them inefficiently
(but correctly) without significantly affecting
overall performance.  Hence my concern about
how rare they will actually be.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Somesh Gupta" <[email-masked]>
Date: Fri, 1 Nov 2002 08:54:09 -0800

It is a very undesirable property and modern routers almost never
get packets out of order. It was more of a property of older
processor based routers. Perhaps people from the major
router companies can comment.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Raghurama 'REDDY'
> Sent: Thursday, October 31, 2002 10:08 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> some of the newer routers with parallel routing engines reorder packets
> quite a lot.
> 
> --rr
> 
> From:	SMTP%"[email-masked]"  "Williams, Jim" 31-OCT-2002 
> 13:02:31.76
> To:	[email-masked]
> CC:	[email-masked], [email-masked]
> Subj:	RE: [Tsvwg] Another Possible Argument for IFT over MPA
>