Subject: RE: [Tsvwg] Spurious RTOs and SCTP

From: [email-masked]
Date: Thu, 20 Mar 2003 19:51:32 +0200

Hi all,

Actually, this brings up a more broad question - as SCTP and TCP
share (basically) the same mechanisms for congestion control, etc.,
is it worthwhile for TCP mechanisms also to discuss their applicability
for SCTP?  My opinion is that they should.

br,
John

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 19 March, 2003 00:14
> To: [email-masked]
> Subject: [Tsvwg] Spurious RTOs and SCTP
> 
> 
> Hi,
> 
> The recent discussions on this list regarding to spurious 
> RTOs have concerned only TCP, but shouldn't SCTP be 
> considered also, since it does RTO-based retransmissions as 
> well? I don't have any hands-on experience with SCTP, but it 
> seems like detecting spurious RTOs by using F-RTO-like logic 
> (see draft-sarolahti-tsvwg-tcp-frto-03.txt) applied to SCTP 
> TSNs and SACKs should work. Or is it a bad idea? I could 
> write a draftlet, but it would be nice to hear what folks 
> think of it before doing that.
> 
> - Pasi
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Thu, 20 Mar 2003 17:18:55 -0500 (EST)

Hi John!

reply inline...

> for SCTP?  My opinion is that they should.

I agree. What would be ideal is for new mechanisms to somehow abstract the
problem and solution so that they can be applied to both protocols. It may
not always be possible though, but at least a discussion of applicability
to both protocols is useful.

~armando

0--                                                  --0
| Armando L. Caro Jr.      |  Protocol Engineering Lab |
| www.cis.udel.edu/~acaro  |    University of Delaware |
0--                                                  --0