Subject: RE: [Tsvwg] SCTP Timestamps

From: [email-masked]
Date: Wed, 16 Jul 2003 22:01:22 +0300

> -----Original Message-----
> From: ext Armando L. Caro Jr. [mailto:[email-masked]]
> Sent: Wednesday, 16 July, 2003 21:55
> 
> On Wed, 16 Jul 2003 [email-masked] wrote:
> 
> > > I guess the only concern left is avoiding too many HB-ACKs on
> > > the wire.
> > > I'm not sure how much Eifel detection will by affected by 
> reducing the
> > > number of bundled HBs.
> >
> > 	Well... You only need one HB per datagram, not per DATA chunk.
> > But they are still 12 bytes you have to be ready to reserve in every
> > packet sent... Or... no, maybe not...
> 
> Althogh packet reservation is an issue, that is not what my 
> concern was
> about. If a HB is included in each packet that contains DATA 
> chunks, then
> the receiver will send HB-ACKs for each of these packets. 
> Thus, the point
> of the delayed sack algorithm is lost.

	Yep, you are right... :-(

	Do you think it would be enough just including the HB when retransmitting?

	BR Iván Arias Rodríguez

> ~armando
> 
> 0--                                                  --0
> | Armando L. Caro Jr.      |  Protocol Engineering Lab |
> | www.cis.udel.edu/~acaro  |    University of Delaware |
> 0--                                                  --0
> 
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Wed, 16 Jul 2003 15:21:54 -0400 (EDT)

> 	Do you think it would be enough just including the HB when

Since there is no guarantee that the HB-ACK will be bundled with a SACK,
it may get ambiguious for the sender. When a SACK arrives without a
HB-ACK, the sender doesn't know if the SACK is (1) for the original
transmission, (2) for a retransmission but the HB-ACK is on the way, or
(3) for a retransmission but the HB-ACK was lost.

~armando

0--                                                  --0