Subject: [Tsvwg] could we translate TCP to SCTP with translation mechanism?

From: "ribb" <[email-masked]>
Date: Mon, 15 Nov 2004 01:29:21 +0800

Dear all:
 
My question is could we  translate TCP to SCTP with  translation mechanism
such as NAT(NAPT) ?
 
thanks a lot.
 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: rick jones <[email-masked]>
Date: Sun, 14 Nov 2004 12:39:27 -0800

> My question is could we  translate TCP to SCTP with  translation 
> mechanism such as NAT(NAPT) ?

Given that NAT is something of an application-level gateway already, 
sure, you could probably do an application-level gateway that had TCP 
enter at one side and SCTP the other.

I'm not sure I would call that a "translation" however.  And while you 
could probably cover most of not all the semantics of TCP with SCTP, 
going the other way with the myriad of SCTP semantics might be 
non-trivial.

rick jones
sometimes life is best with chickens, sheep, pigs and cows separate :)
my thoughts only

---

From: Mark Allman <[email-masked]>
Date: Tue, 16 Nov 2004 14:43:55 -0500

rick-

> sometimes life is best with chickens, sheep, pigs and cows separate :)

in this case ... not so much

allman

---

From: Randall Stewart <[email-masked]>
Date: Thu, 18 Nov 2004 09:59:32 -0500

> My question is could we  translate TCP to SCTP with  translation mechanism

One can do anything.. as my friend Kacheong says.. its only code..

Now.. the bad thing such an approach would do is:

a) Break the end2end model
b) Hide a lot of SCTP features behind TCP
c) possibly cause problems with SCTP's message
    orientation vs tcp's byte stream.. an app
    may not like the way a set of TCP packets
    are "chunk-i-fied".

Now in my mind <a> in itself is a big red flag...

And overall .. what do you gain.. multi-homing maybe.. but
you still would have head of line blocking...

I don't see this approach is worth the effort it would
require.. I would rather see NAT's and FW just plain
learn about SCTP :-D

R

>  
> 
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)