Subject: [Tsvwg] Question regarding draft-baker-diffserv-basic-classes-04.txt

From: Philip Jacobs <[email-masked]>
Date: Sun, 07 Nov 2004 20:06:50 -0500

I have a question regarding draft-baker-diffserv-basic-classes-04.txt

It seems that there are business and unavailability cases when applications would be carried in "non-optimal" Service Classes.

E.g.1. A business decision may be made such that urgent email could be sent in the "Low-latency" rather than the "High Throughput Data" Service Class used for regular email (with appropriately set higher expectations).

E.g.2. During signaling, if there is no available capacity in the "Telephony" services class, a VoIP call may be carried in "Low-latency" Service Class (with appropriately set lower expectations).

My question is "should this draft contain advise regarding into which Service Classes various types of application may be non-optimally placed?"

It might be useful to include advice regarding:
- types of application traffic which may damage Services Classes's ability to deliver as expected. Eg An email may damage the "Telephony" service class.
- types of application traffic which may be carried in "non-optimal" Service Classes without negative impact.

This would answer the question, which service classes a type of application may be "promoted/demoted" into, and which ones it may not.

Phil

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Kwok Ho Chan <[email-masked]>
Date: Wed, 10 Nov 2004 15:15:56 -0500

Philip:
We actually have another draft submitted
   http://www.ietf.org/internet-drafts/draft-chan-tsvwg-diffserv-class-aggr-00.txt
(But not planning to be addressed in this IETF meeting).  We are improving it
currently and would like to discuss this on the mailing list and in future 
IETF meetings

This draft may help answer some of the issue you have below because
in this draft we are aggregating more than one service class into a
traffic treatment.  Doing so may give some service class better treatment
it may need.

That draft will deal with the issues you raised below.
Aggregation will only make sense only if each service within the aggregation
will be upheld/satisfied.
We are currently updating this draft and will more then happy to listen to
any suggestion you have.

-- Kwok --

At 08:06 PM 11/7/2004, Philip Jacobs wrote:

>It seems that there are business and unavailability cases when 
>applications would be carried in "non-optimal" Service Classes.
>
>E.g.1. A business decision may be made such that urgent email could be 
>sent in the "Low-latency" rather than the "High Throughput Data" Service 
>Class used for regular email (with appropriately set higher expectations).
>
>E.g.2. During signaling, if there is no available capacity in the 
>"Telephony" services class, a VoIP call may be carried in "Low-latency" 
>Service Class (with appropriately set lower expectations).
>
>My question is "should this draft contain advise regarding into which 
>Service Classes various types of application may be non-optimally placed?"
>
>- types of application traffic which may damage Services Classes's ability 
>to deliver as expected. Eg An email may damage the "Telephony" service class.
>
>This would answer the question, which service classes a type of 
>application may be "promoted/demoted" into, and which ones it may not.
>
>Phil
>
>
>
><https://www1.ietf.org/mailman/listinfo/tsvwg>https://www1.ietf.org/mailman/listinfo/tsvwg 
>