Subject: RE: [Tsvwg] multiaddressing

From: "Fleischman, Eric" <[email-masked]>
Date: Tue, 30 Nov 2004 10:21:24 -0800

From: Ted Faber [mailto:[email-masked]] wrote:

>Why *not* DNS?  It's a distributed replicated 
>1-to-many database.  It already returns lists of 
>network addresses associated with a string, and 
>there's a well-known API to get at those.  I don't 
>understand the additional dependency created here 
>unless the endpoints were not exchanging DNS names 
>to begin with. 

DNS is good for a great many things. However, it isn't particularly good
for supporting transitory, real-time, and short-lived information.

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Ted Faber <[email-masked]>
Date: Tue, 30 Nov 2004 10:32:39 -0800

> for supporting transitory, real-time, and short-lived information.

None of which was in the problem statement.  The objection to DNS (and
there was one) was that using it "created another dependency," not that
the data was so volitile that it violated the DNS's famously loose
consistency requirements.

I certainly agree with your assessment of DNS's suitabiltly for handling
rapidly changing data.  It's not good for passing out doughnuts, either.

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg