Subject: RE: [Tsvwg] 2 add. with WLAN

From: [email-masked]
Date: Thu, 23 Dec 2004 09:05:25 -0000

It depends if you are running in managed or ad hoc mode. 

In ad hoc mode you can hear everything together with one card and one
mac address per card. In managed mode, you can't.

You might get into terminology debate about what an AP really is in ad
hoc mode ......But certainly, people have run nodes in ad hoc mode which
act as IP routers and provide connectivity to the Internet. One reason
is that it enables a mobile node to chose its own access point based on
signal strength etc and do seamless mobile IP handover. If nodes are in
managed mode, you get fast handover when you have it managed by the
access points, but get big timeouts if you move to a different wireless
domain.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Joe Touch
> Sent: 22 December 2004 18:20
> To: [email-masked]
> Cc: [email-masked]; giuseppe
> Subject: Re: [Tsvwg] 2 add. with WLAN
> 
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> The card would need two MAC addresses; otherwise, advertising 
> a single MAC address on multiple APs would cause problems 
> with bridging (if the two APs were ever bridged elsewhere).
> 
> As to the IETF, IMO we'd care w.r.t. ARP; ARP might not react 
> well to reusing the same MAC address with multiple IP 
> addresses as well.
> 
> Joe
> 
> Brian F. G. Bidulock wrote:
> | giuseppe,
> |
> | IEEE != IETF
> |
> | --brian
> |
> | On Wed, 22 Dec 2004, giuseppe wrote:
> |
> |
> |>I just read a paper where the authors claim that is 
> possible use two 
> |>AP in IEEE802.11b. In a IEEE Transactio I read the 
> contrary. Somebody 
> |>could explain if it is possible or not with IEEE802.11
> |>communicate with two or more APs?
> |>G
> |>
> |>
> |>--
> |>----------------------
> |>----------------------
> |>Giuseppe De Marco, Ph.D.
> |>
> |>Dipartimento di Ingegneria
> |>dell'Informazione e Ingegneria Elettrica
> |>DIIIE, University of Salerno
> |>via ponte don Melillo 1, Fisciano, Salerno
> |>tel: +39 089 964012
> |>email: [email-masked]
> |>
> |>Department of Information and
> |>Communication Engineering
> |>Faculty of Information Engineering
> |>Fukuoka Institute of Technology (FIT)
> |>3-30-1 Wajiro-Higashi, Higashi-ku, Fukuoka 811-0295
> |>Japan
> |>email: [email-masked]
> |>--------------------
> |>
> |>
> |>_______________________________________________
> |>tsvwg mailing list
> |>[email-masked]
> |>https://www1.ietf.org/mailman/listinfo/tsvwg
> |
> |
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (MingW32)
> Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
> 
> iD8DBQFBybrnE5f5cImnZrsRAjWAAJ4yKlSXTqTOObSPPf3QLYTbpNhI/ACcDDZ9
> oQjxo8Q//0NV5ymG9ojuWF4=
> =iV1m
> -----END PGP SIGNATURE-----
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Joe Touch <[email-masked]>
Date: Thu, 23 Dec 2004 10:16:18 -0800

[email-masked] wrote:
| It depends if you are running in managed or ad hoc mode.
|
| In ad hoc mode you can hear everything together with one card and one
| mac address per card. In managed mode, you can't.
|
| You might get into terminology debate about what an AP really is in ad
| hoc mode ......But certainly, people have run nodes in ad hoc mode which
| act as IP routers and provide connectivity to the Internet. One reason
| is that it enables a mobile node to chose its own access point based on
| signal strength etc and do seamless mobile IP handover.

That's one of the cases that concerns me. Having one MAC on two APs
doesn't play well with spanning-tree.

| If nodes are in
| managed mode, you get fast handover when you have it managed by the
| access points, but get big timeouts if you move to a different wireless
| domain.

It takes time for spanning-tree to converge after a move anyway. I'm not
sure 'seamless handover' is a reasonable goal for a bridged 802 network.

Joe

|>-----Original Message-----
|>From: [email-masked] [mailto:[email-masked]]
|>On Behalf Of Joe Touch
|>Sent: 22 December 2004 18:20
|>To: [email-masked]
|>Cc: [email-masked]; giuseppe
|>Subject: Re: [Tsvwg] 2 add. with WLAN
|>
|>
| The card would need two MAC addresses; otherwise, advertising
| a single MAC address on multiple APs would cause problems
| with bridging (if the two APs were ever bridged elsewhere).
|
| As to the IETF, IMO we'd care w.r.t. ARP; ARP might not react
| well to reusing the same MAC address with multiple IP
| addresses as well.
|
| Joe
|
| Brian F. G. Bidulock wrote:
| | giuseppe,
| |
| | IEEE != IETF
| |
| | --brian
| |
| | On Wed, 22 Dec 2004, giuseppe wrote:
| |
| |
| |>I just read a paper where the authors claim that is
| possible use two
| |>AP in IEEE802.11b. In a IEEE Transactio I read the
| contrary. Somebody
| |>could explain if it is possible or not with IEEE802.11
| |>communicate with two or more APs?
| |>G
| |>
| |>
| |>--
| |>----------------------
| |>----------------------
| |>Giuseppe De Marco, Ph.D.
| |>
| |>Dipartimento di Ingegneria
| |>dell'Informazione e Ingegneria Elettrica
| |>DIIIE, University of Salerno
| |>via ponte don Melillo 1, Fisciano, Salerno
| |>tel: +39 089 964012
| |>email: [email-masked]
| |>
| |>Department of Information and
| |>Communication Engineering
| |>Faculty of Information Engineering
| |>Fukuoka Institute of Technology (FIT)
| |>3-30-1 Wajiro-Higashi, Higashi-ku, Fukuoka 811-0295
| |>Japan
| |>email: [email-masked]
| |>--------------------
| |>
| |>
| |>_______________________________________________
| |>tsvwg mailing list
| |>[email-masked]
| |>https://www1.ietf.org/mailman/listinfo/tsvwg
| |
| |