Subject: RE: [Tsvwg] How does multiplexing effect draft-briscoe-tsvwg-cl-p hb-01.txt?

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 1 Jun 2006 15:50:54 +0200

Bob,

I confused things - the PCN egress gateway evaluates 
each packet stream for each PCN ingress gateway 
separately (which is stated also in § 2.3). That's 
what I forgot. Of course the mechanism works with 
this prerequisite.

With "thinning" I referred to the 
diminishing amount of packets marked as congested 
if the congested link is one of the first in a multi 
hop PCN domain with cross traffic. The published 
simulation didn't have to consider separate origins 
for the egress evaluation and when I read § 10.3.1.2 
of the draft I understood: one aggregate evaluation 
per interface only....I'm getting old...

Regards,

Rüdiger

|Aside from the simulations, the /design/ intends to optimise 
|the packing of traffic into a network given multiple 
|bottlenecks. So yes, certainly the /design/ ensures admission 
|control will thin traffic correctly on one link 
|if only (say) link A-D is congested. Indeed, it should also 
|deal optimally with multi-bottleneck scenarios, whereas 
|other algorithms have problems in that respect.
|
|However, you are right to point out that the published 
|simulations haven't (yet) covered anything more than a 
|single bottleneck with fan-in. I hope we made it very 
|clear (in text and presentations) that the simulation was not 
|the last word - it was just the only simulations we had time 
|for prior to publication.
|
|Before coming to the IETF in the first place, we (in BT) simulated a 
|different topology with cross traffic from different traffic 
|matrices,... 
|But since then, we have converged on a new marking algorithm with our 
|co-authors, which is what you see in the draft (also we point 
|out that its not necessarily our last word on algorithms).
|
|In respect of multiplexing, the current marking algorithm is 
|unchanged from the early one we simulated, but, we didn't 
|want to confuse the Internet Draft by including our old 
|simulations, because they weren't a test of the 
|precise marking algorithm we are now describing.
|
|
|Bob
|
|At 08:29 01/06/2006, Geib, Ruediger wrote:
|>Dear Bob,
|>
|>measurement based admission control using PCN based
|>on RED is a simple and effective idea. The
|>simulations published by the draft authors demonstrate
|>the efficency of measurement based admission control.
|>While reading the draft, the following questions
|>related to multiplexing effects came to my mind.
|>Consider the figure of your simulations:
|>
|>        A
|>         \
|>     B  - D - F
|>         /
|>        C
|>
|>You've simulated traffic (A,B,C) to F with congestion on
|>D-F. The PCN mechanism should work also if only one of
|>the feeding links is congested, e.g. A-D. It must do
|>so also if the overall proportion of traffic A-F is
|>small as compared to the total traffic (A,B,C) to F.
|>
|>"Thinning" of marked traffic due to multiplexing or
|>de-multiplexing may arise in many different
|>configurations.
|>
|>I excuse if I have missed a draft where this is
|>discussed already.
|>
|>Regards,
|>
|>Rüdiger
|
|_______________________________________________________________
|_____________
|Bob Briscoe, <[email-masked]>      Networks Research 
|Centre, BT Research
|B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    
|+44 1473 645196 
|
|

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 01 Jun 2006 16:06:24 +0100

Ruediger,

I see. By thinning you meant the marking was being progressively sent off 
in multiple directions. Yes, that is intentional - once you remember that 
each egress is monitoring the proportion of marks in each aggregate.

We're always willing to fix confusing areas of the draft. But it sounds 
like in this case it's OK as it stands.

Cheers

Bob

>per interface only....I'm getting old...

____________________________________________________________________________
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196