Subject: [Tsvwg] sctp

From: devayya <[email-masked]>
Date: Wed, 28 Jun 2006 14:36:01 +0530

Hi,

I have two questions.
1) Suppose the endpoint is multi-homed having two interfaces A and B. 
Configured seperate routers for these interfaces. Is it meaningful to 
have a single gateway for these both interfaces.?

2) Suppose the endpoint is multi-homed with two interfaces A and B. The 
traffic the processor can carry before it goes to congestion is about 
5000 msgs/sec. Now traffic of about 2500 msgs/sec is pumped through A 
interface. The traffic flows smoothly. When the interface A is made down 
the traffic shifts to B interface. But the Upper layer goes into 
congestion state and there is some message loss(of about 50msgs) 
although the congestion is abated after some milliseconds and traffic 
again flows smoothly. Can you tell me is it OK to have this message loss 
when change over happens in multi-homed case.?

regards,
devayya

---

From: Randall Stewart <[email-masked]>
Date: Wed, 28 Jun 2006 09:50:20 -0400

> have a single gateway for these both interfaces.?
What do you mean by "configured seperate routers for these interfaces"?

If you have two interfaces, two routers .. how would you have a
single gateway.. I picture

     +======+       +======+       +=======+
     | R-1  |<----->| host |<----->| R-2   |
     +======+       +======+       +=======+
        |                              |
       ISP-1                        ISP-2

 From your description.. so how would you have a common gateway..

If you are really saying:

     +======+       +======+       +=======+
     | R-1  |<----->| host |<----->| R-2   |
     +======+       +======+       +=======+
        |                              |
       ----------------+----------------
                       |
                   +======+
                   | R-3  |
                   +======+
                       |
                     ISP(s)

The reason I say ISP's because you could have more than
one V6 Router Adv coming from the ISP side...

Now in the above scenario, the two addresses gets you some
redundancy, at least on your network... however big that
is.. but of course if R-3 fails you are out of luck..

> when change over happens in multi-homed case.?

And how would you have a message loss? When you change over
network B would say have about an initial-cwnd.. which would
restrict how much you are sending out... Yes your queues will
build on your host.. while slowstart occurs on B.. but I don't
see loss happening..

R

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 28 Jun 2006 23:07:19 +0200

Dear all,

see my comments in-line.

Best regards
Michael

On Jun 28, 2006, at 3:50 PM, Randall Stewart wrote:

> devayya wrote:
>> Hi,
>> I have two questions.
>> 1) Suppose the endpoint is multi-homed having two interfaces A and  
>> B. Configured seperate routers for these interfaces. Is it  
>> meaningful to have a single gateway for these both interfaces.?
>> 2) Suppose the endpoint is multi-homed with two interfaces A and  
>> B. The traffic the processor can carry before it goes to  
>> congestion is about 5000 msgs/sec. Now traffic of about 2500 msgs/ 
>> sec is pumped through A interface. The traffic flows smoothly.  
>> When the interface A is made down the traffic shifts to B  
>> interface. But the Upper layer goes into congestion state and  
>> there is some message loss(of about 50msgs) although the  
>> congestion is abated after some milliseconds and traffic again  
>> flows smoothly. Can you tell me is it OK to have this message loss  
I assume that you are talking about an application dropping messages  
because the SCTP send buffer
might be full. SCTP should not drop any messages accepted by send()  
calls. If my guess was OK,
your problem is a send buffer dimensioning problem.

---

From: devayya <[email-masked]>
Date: Fri, 30 Jun 2006 14:46:35 +0530

Hai all,

In the below mentioned scenario we have M2PA as upper layer for SCTP.
The transmit congestion level is decided depending upon buffer occupancy 
in m2pa layer. With both the the interfaces A and B up, about 6000 msgs/sec
can be pumped through A interface without any congestion.
When the interface A is made down the traffic shifts to B interface. But 
the m2pa layer goes into congestion state even with a traffic flow of 
3000 msgs/sec. Is this behaviour OK..?

Thanks and regards
Devayya.

Michael Tuexen wrote:

>>> 2) Suppose the endpoint is multi-homed with two interfaces A and  B. 
>>> The traffic the processor can carry before it goes to  congestion is 
>>> about 5000 msgs/sec. Now traffic of about 2500 msgs/ sec is pumped 
>>> through A interface. The traffic flows smoothly.  When the interface 
>>> A is made down the traffic shifts to B  interface. But the Upper 
>>> layer goes into congestion state and  there is some message loss(of 
>>> about 50msgs) although the  congestion is abated after some 
>>> milliseconds and traffic again  flows smoothly. Can you tell me is 
>>> it OK to have this message loss  when change over happens in 
>>> multi-homed case.?
>>
>>

---

From: <[email-masked]>
Date: Fri, 30 Jun 2006 13:03:57 +0300

Hi!

	That's in fact what normally happens. If you haven't been using interface B at all, its CWnd will be set to the minimum. So, when you try to start sending at the rate you used to have in A, it won't be able to do it. You need to wait for several RTTs before the CWnd grows to the needed point.

	Obviously, it also depends on how fast (physically) the B interface is. But I suppose that this doesn't limit you in this example (otherwise the answer is too obvious).

	Thus, you will simply buffer the user messages (depending on your buffer you might lose some packets) and send them at the increasing rate that CWnd will allow you. You have to "train" that new interface so its CWnd grows.

	This will cause a delay that the upper user (M2PA) will understand as congestion (your sending rate has been suddenly limited, so it is not a surprise that the upper user suffers from some delay or even data lost if your SCTP buffer is not big enough). You also have to take into account that the transition from A to B is not immediate, and you will lose some packets in the network that will have to be retransmitted and that will also cause delays.

	By the way, I'm considering that the A and B interface are DESTINATION addresses. It wasn't so clear for me if that's the situation. If they were SOURCE addresses, actually the CWnd shouldn't change (you are still sending to the same destination address) and the only change you will realize would be because physical limitations of the B interface.

	BR Iván Arias Rodríguez

>-----Original Message-----
>From: ext devayya [mailto:[email-masked]] 
>Sent: 30 June, 2006 12:17
>To: Michael Tuexen
>Cc: tsvwg; Randall Stewart
>Subject: Re: [Tsvwg] sctp
>
>Hai all,
>
>The transmit congestion level is decided depending upon buffer 
>occupancy in m2pa layer. With both the the interfaces A and B 
>up, about 6000 msgs/sec can be pumped through A interface 
>without any congestion.
>interface. But the m2pa layer goes into congestion state even 
>with a traffic flow of 3000 msgs/sec. Is this behaviour OK..?
>
>
>Thanks and regards
>Devayya.
>
>
>Michael Tuexen wrote:
>
>> Dear all,
>>
>> see my comments in-line.
>>
>> Best regards
>> Michael
>>
>>> The reason I say ISP's because you could have more than one 
>V6 Router 
>>> Adv coming from the ISP side...
>>>
>is.. but of 
>>> course if R-3 fails you are out of luck..
>>>
>>>
>>>
>>>
>network B 
>>> would say have about an initial-cwnd.. which would restrict 
>how much 
>>> you are sending out... Yes your queues will build on your host.. 
>>> while slowstart occurs on B.. but I don't see loss happening..
>>
>> because the SCTP send buffer might be full. SCTP should not drop any 
>> messages accepted by send() calls. If my guess was OK, your 
>problem is 
>> a send buffer dimensioning problem.
>>
>>>
>>> R
>>>
>>>
>>> -- 
>>> Randall Stewart