Subject: [Tsvwg] SCTP multi-home

From: devayya <[email-masked]>
Date: Mon, 19 Jun 2006 12:19:21 +0530

Hi,

I have two question on multi-homing,

1) Suppose one endpoint has a limitation of accepting only 4 maximum 
paths as destination ip addresses, and the destination endpoint when he 
sends a list of ip addresses through (INIT / INITACK) he sends more than 
4 IP address(paths), then what should be the recieving end be doing?
Should be establishing the association with the first four IP 
addresses(paths)? If in this case, how do we decide which IP addresses 
to accept and which not to? OR should he just send a abort and do not 
allow the association to come up?

2) Suppose the endpoint sends duplicate IP addresses in the INIT / 
INITACK, then what shall the receiving endpoint do with the duplicate IP 
addresses?

Please guide me...

Thanks and regards,
devayya

---

From: ash kat <[email-masked]>
Date: Mon, 19 Jun 2006 00:28:44 -0700 (PDT)

HI Devayya
   
  In response to your first query:
  If an endpoint receives an INIT chunk containing more number of IP addresses then it supports than in my opinion should send an ABORT chunk with error cause as "4 Out of Resource".
   
  Regards,
  Ashwani Kathuria
  
devayya <[email-masked]> wrote:
  Hi,

Please guide me...

Thanks and regards,
devayya

 __________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 19 Jun 2006 10:09:23 +0200

On Jun 19, 2006, at 8:49 AM, devayya wrote:
Hi,

see my comments in-line.

Best regards
Michael
> 1) Suppose one endpoint has a limitation of accepting only 4  
> maximum paths as destination ip addresses, and the destination  
> endpoint when he sends a list of ip addresses through (INIT /  
> INITACK) he sends more than 4 IP address(paths), then what should  
> be the recieving end be doing?
> addresses(paths)? If in this case, how do we decide which IP  
> addresses to accept and which not to? OR should he just send a  
> abort and do not allow the association to come up?
If you receive more different IP-addresses than you can handle, send  
an ABORT.
> INITACK, then what shall the receiving endpoint do with the  
> duplicate IP addresses?
I would just handle them as one. Mathematically I looking at the set  
of IP-addresses.