Subject: Re: [Tsvwg] WGLC for draft-ietf-tsvwg-addip-sctp-17 starts NOW

From: Lars Eggert <[email-masked]>
Date: Thu, 1 Mar 2007 11:10:16 +0200

On 2006-11-29, at 4:41, James M. Polk wrote:
> The WGLC for draft-ietf-tsvwg-addip-sctp-17.txt
> starts today, November 28th, 2006, and ends on or after December  
> 13th, 2006
> - depending on the level of comments to the TSVWG list at that time.

In response to LC comments, the authors have recently updated the draft:
http://tools.ietf.org/html/draft-ietf-tsvwg-addip-sctp-18

The WG should confirm that -18 is ready for publication. Please send  
final comments until March 6.

Lars

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 5 Mar 2007 22:32:28 +0100

Hi Lars,

there is one little thing which did not make it in the 18th version...

If a wildcard address is used in the ASCONF chunks, then the address
which is involved in the operation is not protected by the SCTP-AUTH  
chunk,
because it is the source address of the packet. I think it might be good
to say this in the security considerations, but this can be added  
when other
comments get integrated.

Best regards
Michael

On Mar 1, 2007, at 10:10 AM, Lars Eggert wrote:

> The WG should confirm that -18 is ready for publication. Please  
> send final comments until March 6.
>
> Lars
>
>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 7 Mar 2007 16:53:15 +0200

On 2007-3-5, at 23:32, ext Michael Tuexen wrote:
> which is involved in the operation is not protected by the SCTP- 
> AUTH chunk,

Noted.

I haven't seen any other WG feedback on the latest revision. I'm  
holding off from moving it forward until I see at least a handful of  
comments about it.

Please take a look and let your chairs know whether this is good to go!

Lars

---

From: <[email-masked]>
Date: Tue, 13 Mar 2007 16:08:59 +0200

Hi!

	I have read the draft and I couldn't find anything "weird" to comment about... I simply found a few typos:

	- Section 4.2.6: "MUST specify a an adaptation code point" should say "MUST specify an adaptation code point".

	- Section 4.2.6, next paragraph: "Note: that this parameter is" I think should say "Note: this parameter is".

	- Section 4.2.6, later in the same paragraph: "is for the convience of the upper layer" should say "is for the convenience of the upper layer".

	- Section 5.1.1, page 21: "A ASCONF sender without" should say "An ASCONF sender without".

	- Section 5.1.1, later in the same paragraph: "number of seperate address change" should say "number of separate address change".

	Thanks!

	BR Iván Arias Rodríguez

>-----Original Message-----
>From: ext Lars Eggert [mailto:[email-masked]] 
>Sent: 07 March, 2007 16:53
>To: ext Michael Tuexen
>Cc: KOZUKA Masahiro; Randall Stewart; tsvwg WG; Qiaobing Xie
>Subject: Re: [Tsvwg] WGLC for draft-ietf-tsvwg-addip-sctp-17 starts NOW
>
>> which is involved in the operation is not protected by the 
>SCTP- AUTH 
>> chunk, because it is the source address of the packet. I think it 
>> might be good to say this in the security considerations, 
>but this can 
>> be added when other comments get integrated.
>
>Noted.
>

---

From: Randall Stewart <[email-masked]>
Date: Tue, 13 Mar 2007 13:09:28 -0400

Ivan:

Thanks for the comments..

> "MUST specify an adaptation code point".
got it.

> 
> - Section 4.2.6, next paragraph: "Note: that this parameter is" I
> think should say "Note: this parameter is".
got it
> 
> - Section 4.2.6, later in the same paragraph: "is for the convience
> of the upper layer" should say "is for the convenience of the upper
> layer".
got it
> - Section 5.1.1, page 21: "A ASCONF sender without" should say "An
got it

> 
> - Section 5.1.1, later in the same paragraph: "number of seperate
> address change" should say "number of separate address change".

Got it..

thanks

R

> 
> Thanks!
> 
> BR Iván Arias Rodríguez
> 
>> -----Original Message----- From: ext Lars Eggert
>> [mailto:[email-masked]] Sent: 07 March, 2007 16:53 To: ext
>> Michael Tuexen Cc: KOZUKA Masahiro; Randall Stewart; tsvwg WG;
>> Qiaobing Xie Subject: Re: [Tsvwg] WGLC for
>> draft-ietf-tsvwg-addip-sctp-17 starts NOW
>> 
>>> If a wildcard address is used in the ASCONF chunks, then the
>>> address which is involved in the operation is not protected by
>>> the
>> SCTP- AUTH
>> holding off from moving it forward until I see at least a handful
>> of comments about it.
>> 
>>>>> The WGLC for draft-ietf-tsvwg-addip-sctp-17.txt starts today,
>>>>> November 28th, 2006, and ends on or after December 13th, 2006

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)

---

From: Lars Eggert <[email-masked]>
Date: Wed, 14 Mar 2007 13:44:18 +0200

> Thanks for the comments..

Yes, thanks!

Authors: are you planning on a final revision that fixes these nits?

WG: I urge you once again to please review this document.

Lars

PS: Please also rename Section 9 from "References" to "Normative  
References" for clarification.

---

From: Randall Stewart <[email-masked]>
Date: Wed, 14 Mar 2007 08:00:37 -0400

> Authors: are you planning on a final revision that fixes these nits?

Yep.. as soon as the last call completes :-D
> References" for clarification.

Done

R

---

From: Janardhan Iyengar <[email-masked]>
Date: Wed, 14 Mar 2007 10:33:44 -0400

(I'm assuming we're LC'ing on -18, and not -17, as the subject suggests)

Some nits, but otherwise, looks fine.

Section 3:
    "ASCONF Sequence Numbers wrap around when they reach 2**32 - 1.  That
    is, the next ASCONF Sequence Number an ASCONF chunk MUST use after
    transmitting ASCONF Sequence Number = 2*32 - 1 is TSN = 0."

The last part should be: "ASCONF Sequence Number = 2*32 - 1 is 0." (Not 
TSN = 0)

Section 4.1.1: "Note: that the upper two bits in the ASCONF Chunk are 
set to one."
Should be "Note that the upper two bits in the ASCONF Chunk are set to one."

Section 4.2: "Table 2, 3 and 4 describes" should be "Tables 2, 3 and 4 
describe"

Section 4.2.6: "... but is for the convience of the upper layer." should 
be "... convenience..."

Thanks!
- jana

-- 
Janardhan R. Iyengar
Visiting Assistant Professor
Connecticut College
http://cs.conncoll.edu/iyengar/

---

From: Lars Eggert <[email-masked]>
Date: Wed, 14 Mar 2007 16:50:31 +0200

> (I'm assuming we're LC'ing on -18, and not -17, as the subject  

Right. There was an interim revision to address some issues.

Thanks for the review!

It looks as if we have consensus to request publication, and will do  
so once -19 becomes available, which should address the issues people  
have raised during the LC.

Lars

---

From: Randall Stewart <[email-masked]>
Date: Wed, 14 Mar 2007 11:15:23 -0400

Jana:

Thanks for the comments...

Got it..

> Should be "Note that the upper two bits in the ASCONF Chunk are set to 
Got it.

Got it..

> Section 4.2.6: "... but is for the convience of the upper layer." should 

Ivan beat you to that one.. so its done too :-D

R