Subject: Re: [Tsvwg] Does anyone have a defence in favour of flow ratefairness?

From: Zack Best <[email-masked]>
Date: Tue, 17 Jul 2007 09:03:00 -0700 (PDT)

>From draft-floyd-tsvwg-besteffort-00b.txt

> One of the obvious dangers of simple
> implementations of QoS mechanisms or
> of cost-based fairness, in the absence of the
> protection of simple best-effort traffic,
> would be that the users with more money
> *could* end up completely shutting out users with
> less money in times of congestion.  There
> seems to be fairly widespread agreement that
> this would not be a desirable goal.

I am curious why this is not a desirable goal let
alone why there is widespread agreement of this.

If people are paying a monthly fee to their ISP
and if uninterrupted connectivity at relatively
low bandwidth is important to them (which in most
cases it is) wouldn't market forces work to make
this happen?  I.e. ISPs would spend their money
to insure to insure customers got what they wanted,
lest they lose business.

On the other hand, may people (perhaps most of the 
world) are excluded from the internet because
they can't afford the basic monthly fee to connect.
A cost based system would theoretically lower the
cost of entry for those who did not want to compete
for bandwidth at contested times, and actually make
limited connectivity available to a group previous
excluded.

There is certainly a recurring argument in the
political arena between the free market advocates,
and those who claim the free market would result
in unfairness that is best addressed by enforced
equality at the expense of choice and flexibility.

I won't attempt to resolve that argument here, but
my sympathies are certainly the the free market 
folks.  Experience has shown over and over that
market forces do a better job at scarce resource
allocation than detractors predict and a better
job than the proposed alternatives.

This is not meant as a comment on the practicality
of implementing cost based fairness, just as a
defense of the goal.

____________________________________________________________________________________
Pinpoint customers who are looking for what you sell. 
http://searchmarketing.yahoo.com/

---

From: <[email-masked]>
Date: Fri, 20 Jul 2007 10:02:05 +0100

I think that we should focus on technical wherever possible and leave the system open to be used in different ways in different parts of the world - I don't think technology should force any particular social or political opinion. I think cost fairness does allow different approaches to co-exist within a single network - so the goal of avoiding the rich shutting out the poor can be achieved in one network or country, and a goal of pure free market could also be achieved elsewhere.

At the moment I think we do have a technical problem that we should address - in times of congestion users with more technical knowledge can completely shut out naïve users. 

-----Original Message-----
From: Zack Best [mailto:[email-masked]] 
Sent: 17 July 2007 17:03
To: [email-masked]
Subject: Re: [Tsvwg] Does anyone have a defence in favour of flow ratefairness?

> of cost-based fairness, in the absence of the protection of simple 
> best-effort traffic, would be that the users with more money
> *could* end up completely shutting out users with less money in times 
> of congestion.  There seems to be fairly widespread agreement that 

I am curious why this is not a desirable goal let alone why there is widespread agreement of this.

If people are paying a monthly fee to their ISP and if uninterrupted connectivity at relatively low bandwidth is important to them (which in most cases it is) wouldn't market forces work to make this happen?  I.e. ISPs would spend their money to insure to insure customers got what they wanted, lest they lose business.

On the other hand, may people (perhaps most of the
world) are excluded from the internet because they can't afford the basic monthly fee to connect.
A cost based system would theoretically lower the cost of entry for those who did not want to compete for bandwidth at contested times, and actually make limited connectivity available to a group previous excluded.

There is certainly a recurring argument in the political arena between the free market advocates, and those who claim the free market would result in unfairness that is best addressed by enforced equality at the expense of choice and flexibility.

I won't attempt to resolve that argument here, but my sympathies are certainly the the free market folks.  Experience has shown over and over that market forces do a better job at scarce resource allocation than detractors predict and a better job than the proposed alternatives.

This is not meant as a comment on the practicality of implementing cost based fairness, just as a defense of the goal.