Subject: [Tsvwg] Stupid question about multihoming in SCTP

From: "Michael Welzl" <[email-masked]>
Date: Thu, 11 Oct 2007 00:23:22 +0200

Hi,

Please forgive me if this is a stupid question
(which it probably is)... but that one really
confuses me:

Suppose I'm using host A, with which I want
to connect to host B via SCTP. In order to make
the transfer more robust, if I know that B
is multihomed, I can create an association
that connects A to B *and* C.

Now I wonder: where do I get the address of C from?
How do I learn that host B / C is multihomed?

By calling the provider of B / C? Via DNS?

It seems to me that the most appropriate place
to store this information would be at host B
(whose administrator knows about host C), and
the most appropriate way to obtain it would
be via SCTP itself - but SCTP doesn't seem to
include any mechanism for A to get that information.
It seems that the whoever uses SCTP at host A
would have to know that information in advance
somehow.

So ... what am I missing here?

Thanks a lot in advance,

cheers,
Michael

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Oct 2007 19:22:44 -0600

Michael,

When host A sends an INIT to host B, host B may reply
with both address B and C in the INIT-ACK to inform
host A that it is multihomed and form a multihomed
association.

If you want host A to know that it can send an INIT to
host C if host B is inaccessible, DNS is probably the
best way for this unless you wish to provision the fact
that host B and C are the same in host A's tables.

--brian

Michael Welzl wrote:          (Thu, 11 Oct 2007 00:23:22)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Welzl <[email-masked]>
Date: Thu, 11 Oct 2007 08:22:00 +0200

> host A that it is multihomed and form a multihomed

Can it?? Oops, sorry then - I must have overlooked that.
But I warned you, I knew it would be a stupid question  :(

> that host B and C are the same in host A's tables.

Ok, got that.

Thanks a lot!

Cheers,
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 11 Oct 2007 08:51:59 +0200

Brian,

comments in-line.

Best regards
Michael

> host A that it is multihomed and form a multihomed
Both the INIT and INIT-ACK can contain a list of addresses
to tell the peer that it is multi-homed. But this will not
be used for retransmitting the INITs or INIT-ACKs... But
after the initial phase you have redundancy...
> that host B and C are the same in host A's tables.
DNS has a problem: It is common that multiple addresses
a listed for one DNS name in the DNS. But the resolver
does *NOT* know whether these addresses belong to the
same host (then they could be used to send an INIT to
them, sctp_connectx() call in the socket API) or
to different hosts (then using them while association
setup would break the SCTP association). So I do
not see how to use DNS here...

Reliable server pooling however, can be used. But that
is a different story.