Subject: [Tsvwg] doubt regarding the notification in lk sctp

From: "Padmalochan Moharana" <[email-masked]>
Date: Thu, 11 Oct 2007 13:40:46 +0530

Hi,
 
I have some doubt regaring the notification procedure
in lk_sctp. 
case 1 : supose there is an association in ESTABLISHED
state and the server receive another INIT from the
Same established peer with Vtag 0 then how could
we know that the server receive another INIT from
 <http://peer.is> peer.is kernel provide any notification for this
situation.
 
case 2 : is there in procedure to know or any
notification from kernel after receive shoutdown
complete if server receive INIT from the peer and it
establish another association.

Thanks & Regards,
Padman

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 11 Oct 2007 14:39:42 +0200

Hi Padman,

you might want to ask Linux specific questions in the lksctp mailing
list.

But in general when an end-point receives an INIT it just sends out
an INIT-ACK (or ABORT), but does not change any state in the kernel
and does not send a notification to the user.

If due to reception of a COOKIE-ECHO an association is established or
restarted, a notification is send to the user if requested.

Best regards
Michael

On Oct 11, 2007, at 10:10 AM, Padmalochan Moharana wrote:

> Hi, I have some doubt regaring the notification procedurein  
> lk_sctp. case 1 : supose there is an association in  
> ESTABLISHEDstate and the server receive another INIT from theSame  
> established peer with Vtag 0 then how couldwe know that the server  
> receive another INIT frompeer.is kernel provide any notification  
> for thissituation. case 2 : is there in procedure to know or  
> anynotification from kernel after receive shoutdowncomplete if  
> server receive INIT from the peer and itestablish another association.
>
>
> Thanks & Regards,
> Padman
>
>
>
>