Subject: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

From: FERNANDO PASCUAL BLANCO <[email-masked]>
Date: Fri, 13 Jul 2012 09:22:54 +0000

Hello all,

I think that a potential application scenario could be M2M networks, for example, Wireless Sensor Networks (WSNs). WSNs are local wireless networks composed by small devices acquiring environment information and sometimes acting over the environment (fire detection, air pollution monitoring, smart metering, care for gardens, security, structure monitoring, agriculture, ecology, greenhouses...). Sometimes, those devices has a local connectivity using ZigBee or 802.15.4 (there is a IETF WG named 6loWPAN, using IPv6 over that networks) and they have a gateway with fixed (xDSL) or mobile (3G/HSPA) networks towards (for example over the Internet) the servers storing and processing the information.

http://en.wikipedia.org/wiki/Wireless_sensor_network

As you can imagine, in many cases the size of the packets is very small, and in some scenarios you could have a lot of devices sending information over the same gateway, generating a lot of inefficient data packets (with low payload).

The question is: Could that scenario be considered as a candidate to apply TCMTF?

Best Regards,

Fernando

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra pol?tica de env?o y recepci?n de correo electr?nico en el enlace situado m?s abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Jose Saldana" <[email-masked]>
Date: Thu, 19 Jul 2012 16:16:46 +0200

Tomaso,

One more thing: if you are interested on traffic classification (as you said
in your mail), perhaps you may follow the discussion about RFC 4594 update
in [email-masked]. There is a draft
https://datatracker.ietf.org/doc/draft-polk-tsvwg-rfc4594-update/ that is
being discussed just now.

I think that this draft can also be interesting for TCMTF, since a network
operator will be able to easily identify flows with the same real-time
requirements, in order to multiplex them.

Regards,

Jose

De: [email-masked] [mailto:[email-masked]] 
Enviado el: martes, 17 de julio de 2012 15:16
Para: [email-masked]
CC: [email-masked]
Asunto: RE: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

Dear Fernando, dear all,

I also see the case of M2M networks as an appealing scenario where TCMTF
could be used profitably. In addition to Fernando’s consideration I would
also add the case of WSN connected via satellite to data/monitoring centres.
Since satellite capacity is not uniquely assigned to a specific applications
or service providers, an efficient multiplexing (e.g., compression and
tunneling) would be more than welcome to accommodate properly the WSN data
flows. In this context, traffic classification could also play an important
role to perform multiplexing and apply the appropriate compression algorithm
in the most efficient way.

Best Regards,

Tomaso

———————————————————————— 
Deutsches Zentrum für Luft- und Raumfahrt (DLR) 
German Aerospace Center 
Institute of Communications und Navigation | Satellite Networks |
Oberpfaffenhofen | 82234 Wessling | Germany 

Tomaso de Cola, Ph.D. 
Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 |
<mailto:[email-masked]> [email-masked] 
 <http://www.dlr.de/kn/institut/abteilungen/san>
http://www.dlr.de/kn/institut/abteilungen/san 

De: [email-masked] [mailto:[email-masked]] En nombre de
FERNANDO PASCUAL BLANCO
Enviado el: viernes, 13 de julio de 2012 11:23
Para: [email-masked]; [email-masked]
Asunto: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

Hello all,

I think that a potential application scenario could be M2M networks, for
example, Wireless Sensor Networks (WSNs). WSNs are local wireless networks
composed by small devices acquiring environment information and sometimes
acting over the environment (fire detection, air pollution monitoring, smart
metering, care for gardens, security, structure monitoring, agriculture,
ecology, greenhouses…). Sometimes, those devices has a local connectivity
using ZigBee or 802.15.4 (there is a IETF WG named 6loWPAN, using IPv6 over
that networks) and they have a gateway with fixed (xDSL) or mobile (3G/HSPA)
networks towards (for example over the Internet) the servers storing and
processing the information. 

 <http://en.wikipedia.org/wiki/Wireless_sensor_network>
http://en.wikipedia.org/wiki/Wireless_sensor_network

As you can imagine, in many cases the size of the packets is very small, and
in some scenarios you could have a lot of devices sending information over
the same gateway, generating a lot of inefficient data packets (with low
payload).

The question is: Could that scenario be considered as a candidate to apply
TCMTF?

Best Regards,

Fernando

  _____  

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar
nuestra política de envío y recepción de correo electrónico en el enlace
situado más abajo.
This message is intended exclusively for its addressee. We only send and
receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Shitanshu Shah (svshah)" <[email-masked]>
Date: Thu, 19 Jul 2012 20:45:50 +0000

Not sure Jose if your response was to indicate Diffserv classification for WSN traffic.
Assuming that being the case. fyi, there is a proposal for the same recently published in an I-D: http://tools.ietf.org/html/draft-svshah-lln-diffserv-recommendations-00

Shitanshu

From: Jose Saldana <[email-masked]<mailto:[email-masked]>>
Organization: Universidad de Zaragoza
Reply-To: <[email-masked]<mailto:[email-masked]>>
Date: Thu, 19 Jul 2012 16:16:46 +0200
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

Tomaso,

One more thing: if you are interested on traffic classification (as you said in your mail), perhaps you may follow the discussion about RFC 4594 update in [email-masked]<mailto:[email-masked]>. There is a draft https://datatracker.ietf.org/doc/draft-polk-tsvwg-rfc4594-update/ that is being discussed just now.

I think that this draft can also be interesting for TCMTF, since a network operator will be able to easily identify flows with the same real-time requirements, in order to multiplex them.

Regards,

Jose

De: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Enviado el: martes, 17 de julio de 2012 15:16
Para: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Asunto: RE: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

Dear Fernando, dear all,

I also see the case of M2M networks as an appealing scenario where TCMTF could be used profitably. In addition to Fernando’s consideration I would also add the case of WSN connected via satellite to data/monitoring centres. Since satellite capacity is not uniquely assigned to a specific applications or service providers, an efficient multiplexing (e.g., compression and tunneling) would be more than welcome to accommodate properly the WSN data flows. In this context, traffic classification could also play an important role to perform multiplexing and apply the appropriate compression algorithm in the most efficient way.

Best Regards,

Tomaso

————————————————————————
Deutsches Zentrum für Luft- und Raumfahrt (DLR)
German Aerospace Center
Institute of Communications und Navigation | Satellite Networks | Oberpfaffenhofen | 82234 Wessling | Germany
Tomaso de Cola, Ph.D.
Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked]<mailto:[email-masked]>
http://www.dlr.de/kn/institut/abteilungen/san

De: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> En nombre de FERNANDO PASCUAL BLANCO
Enviado el: viernes, 13 de julio de 2012 11:23
Para: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Asunto: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf

Hello all,

I think that a potential application scenario could be M2M networks, for example, Wireless Sensor Networks (WSNs). WSNs are local wireless networks composed by small devices acquiring environment information and sometimes acting over the environment (fire detection, air pollution monitoring, smart metering, care for gardens, security, structure monitoring, agriculture, ecology, greenhouses…). Sometimes, those devices has a local connectivity using ZigBee or 802.15.4 (there is a IETF WG named 6loWPAN, using IPv6 over that networks) and they have a gateway with fixed (xDSL) or mobile (3G/HSPA) networks towards (for example over the Internet) the servers storing and processing the information.

Best Regards,

Fernando

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 23 Jul 2012 10:25:24 +0100

It seems like there are many things to discuss concerning the use of 
tunnel protocols with compression! Can I remind people that there is now 
a dedicated mailing list for this topic. This draft is an individual 
submission, linked to TSVWG and it is hoped that this list may 
discussion of the draft and what the next steps (if any) should be.

I'd like to encourage you to subscribe if you are interested in this 
topic, and continue discussions using the new list below:

https://www.ietf.org/mailman/listinfo/tcmtf

Best wishes,

Gorry Fairhurst
(TSVWG Co-Chair).

On 19/07/2012 21:45, Shitanshu Shah (svshah) wrote:
> Assuming that being the case. fyi, there is a proposal for the same
> recently published in an I-D:
> http://tools.ietf.org/html/draft-svshah-lln-diffserv-recommendations-00
>
> Shitanshu
>
> From: Jose Saldana <[email-masked] <mailto:[email-masked]>>
> Reply-To: <[email-masked] <mailto:[email-masked]>>
> To: <[email-masked] <mailto:[email-masked]>>
> Cc: <[email-masked] <mailto:[email-masked]>>
> One more thing: if you are interested on traffic classification (as you
> said in your mail), perhaps you may follow the discussion about RFC 4594
> update [email-masked] <mailto:[email-masked]>. There is a
> drafthttps://datatracker.ietf.org/doc/draft-polk-tsvwg-rfc4594-update/
> that is being discussed just now.
>
> I think that this draft can also be interesting for TCMTF, since a
> network operator will be able to easily identify flows with the same
> real-time requirements, in order to multiplex them.
>
> Regards,
>
> Jose
>
> *De:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]]
> *Enviado el:* martes, 17 de julio de 2012 15:16
> *Para:* [email-masked] <mailto:[email-masked]>
> *CC:* [email-masked] <mailto:[email-masked]>
> *Asunto:* RE: [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf
>
> Dear Fernando, dear all,
>
> could be used profitably. In addition to Fernando’s consideration I
> would also add the case of WSN connected via satellite to
> data/monitoring centres. Since satellite capacity is not uniquely
> assigned to a specific applications or service providers, an efficient
> multiplexing (e.g., compression and tunneling) would be more than
> welcome to accommodate properly the WSN data flows. In this context,
> traffic classification could also play an important role to perform
> multiplexing and apply the appropriate compression algorithm in the most
> efficient way.
>
> Best Regards,
>
> Tomaso
>
> ————————————————————————
> *Deutsches Zentrum für Luft- und Raumfahrt*(DLR)
> German Aerospace Center
> *Tomaso de Cola, Ph.D.*
> Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844
> [email-masked] <mailto:[email-masked]>
> *De:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] <mailto:[mailto:[email-masked]]>
> *En nombre de *FERNANDO PASCUAL BLANCO
> *Enviado el:* viernes, 13 de julio de 2012 11:23
> *Para:* [email-masked] <mailto:[email-masked]>; [email-masked]
> <mailto:[email-masked]>
> *Asunto:* [tsvwg] M2M, WSNs and draft-saldana-tsvwg-tcmtf
>
> Hello all,
>
> example, Wireless Sensor Networks (WSNs). WSNs are local wireless
> networks composed by small devices acquiring environment information and
> sometimes acting over the environment (fire detection, air pollution
> monitoring, smart metering, care for gardens, security, structure
> monitoring, agriculture, ecology, greenhouses…). Sometimes, those
> devices has a local connectivity using ZigBee or 802.15.4 (there is a
> IETF WG named 6loWPAN, using IPv6 over that networks) and they have a
> gateway with fixed (xDSL) or mobile (3G/HSPA) networks towards (for
> example over the Internet) the servers storing and processing the
> information.
>
> As you can imagine, in many cases the size of the packets is very small,
> and in some scenarios you could have a lot of devices sending
> information over the same gateway, generating a lot of inefficient data
> packets (with low payload).
>
> ------------------------------------------------------------------------
>
>