Subject: [tsvwg] SCTP NAPT/NAT Support

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 24 Jun 2014 13:10:24 +0100

Last IETF tsvwg discussed the possibility of merging two milestones in 
TSVWG relating to SCTP and NAPT/NAT, to result in a single document on 
this topic.

The current milestones are:
* Nov 2014 - Submit 'SCTP NAT Support' to IESG for consideration as PS
* Nov 2014 - Submit 'SCTP NAT Specification' as a BCP

I hope that whatever way this proceeds, we suggest the document(s) 
clearly identify the parts that relate to:
     (1) implementing a NAT/NAPT
and (2) the support needed for SCTP implementors/users use a NAPT

As I recall, there was little opposition to this restructuring of the 
work, and this email is to make the list aware of this proposal.
Please send comments if any to the list, this will help the Chairs make 
a decision on how best to proceed.

Best wishes,

Gorry, David and James
(tsvwg Co-Chairs)

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 24 Jun 2014 16:16:54 +0200

On 24 Jun 2014, at 14:10, Gorry Fairhurst <[email-masked]> wrote:

> 
> Last IETF tsvwg discussed the possibility of merging two milestones in TSVWG relating to SCTP and NAPT/NAT, to result in a single document on this topic.
> 
> I hope that whatever way this proceeds, we suggest the document(s) clearly identify the parts that relate to:
> As I recall, there was little opposition to this restructuring of the work, and this email is to make the list aware of this proposal.
> Please send comments if any to the list, this will help the Chairs make a decision on how best to proceed.
I think it really makes sense to combine them into a single document.

Best regards
Michael

---

From: "Becke, Martin" <[email-masked]>
Date: Tue, 24 Jun 2014 15:23:11 +0000

IMPOV it is the best to have it in one document but I am not aware of any drawbacks.
Are there any arguments to have it in two? 

Best,
Martin

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 24 Jun 2014 18:45:25 +0200

> Are there any arguments to have it in two? 
No. Except that it is some work to merge them, but it will be much easier to read in
the end...

Best regards
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 24 Jun 2014 18:47:44 +0200

On 24 Jun 2014, at 18:05, Randall Stewart <[email-masked]> wrote:

> Gorry:
> 
> I really do agree that this makes complete sense. The document was
> originally one and for some unknown reason (I don’t remember) we split
I think the reason was that the NAT stuff was requested to be handled
in BEHAVE as an informational document, but we needed to protocol
mechanisms in a standards track document which was thought to be
better handled in TSVWG.
Since we deal now with the documents in a single WG, we can merge them.

Best regards
Michael
> it into two. This makes reading it very difficult, if you start reading one
> often you must get the other out and read that in combination if you want
> it to make much sense..
> 
> Putting them together makes things *much* easier and more clear :-)
> 
> R
> On Jun 24, 2014, at 8:10 AM, Gorry Fairhurst <[email-masked]> wrote:
> 
>> 
> -----
> Randall R. Stewart
> [email-masked]
> 
> 
> 
>

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 25 Jun 2014 05:40:17 +0000

combining them in one document it make perfect sense 

br
Sal

---

From: "Karen E. Egede Nielsen" <[email-masked]>
Date: Wed, 25 Jun 2014 10:32:52 +0200

Hi,

I fully support to merge the two documents.
The split has always been very problematic and I believe that we
all are served best by merging the documents. I would go so far as to say
that
even if one split them now one would eventually want to join them later
on.

NAT Traversal of SCTP is an important issue for SCTP deployment.
The  complexity of the solutions differs substantially as to whether
SCTP is SH or MH. I believe that a join of the documents serve best to
specify the functions in a consistent and comprehensive manner.
I would hope that such clear specification could help progress NAT
traversal support
in the network. Possibly with the more simple SH SCTPNAT functions support
being provided more rapidly
than MH SCTP support.

BR, Karen

> -----Original Message-----
> From: tsvwg [mailto:[email-masked]] On Behalf Of Michael Tuexen
> Sent: 24. juni 2014 18:48
> To: Randall Stewart
> Cc: Gorry Fairhurst; tsvwg WG
> Subject: Re: [tsvwg] SCTP NAPT/NAT Support
>
>
> > originally one and for some unknown reason (I don't remember) we split
> I think the reason was that the NAT stuff was requested to be handled in
> BEHAVE as an informational document, but we needed to protocol
> mechanisms in a standards track document which was thought to be better
> handled in TSVWG.
> > it into two. This makes reading it very difficult, if you start
> > reading one often you must get the other out and read that in
> > combination if you want it to make much sense..
> >
this
> topic.
work, and
> this email is to make the list aware of this proposal.
> >> Please send comments if any to the list, this will help the Chairs
make a
> decision on how best to proceed.
> >>
> >> Best wishes,
> >>
> >> Gorry, David and James
> >> (tsvwg Co-Chairs)
> >>
> >>
> >
> > -----
> > Randall R. Stewart