Subject: [tsvwg] tsvwg slot for pres on advances on SCTP Tail Loss Recovery ?

From: "Karen E. Egede Nielsen" <[email-masked]>
Date: Wed, 25 Jun 2014 11:02:27 +0200

Hi,

We are working with some advances on SCTP Loss Recovery in order to more
efficiently support

loss recovery. We are wondering if there would be a 5-10 minutes slot
available at the IETF 90 tsvwg session to present

our work.

The advances consist of the advancement of SCTP Fast Recovery with some
“SCTP-equivalent” additions from RFC6675 (TCP)

plus the addition of a timer driven state machine for proactive entering of
Fast Recovery, not identical to, but very significantly

inspired by the ideas from the TLP approach presented for TCP by Google at
IETF87.

We are in the early phase of the work (spec, implementation, tests) and
have not yet prepared a draft.

Such would be available only for IETF91.

BR, Karen

*******************************************************************************************

*Karen Egede Nielsen*

Software Architect, Ph.D.

*Ericsson, *

Kistavägen 25,

164 80 Stockholm, SWEDEN

Direct Phone / Mobile +45 25134336

E-mail: [email-masked]

www.ericsson.com

*****************************************************************************************

---

From: [email-masked]
Date: Wed, 25 Jun 2014 10:08:15 +0100

Hi,

The topic appears to fall within tsvwg: To answer the agenda question, I'd
like to know more:

What sort of presentation are you thinking about? - will you have a draft
(even just outline of scope) published by then? Will you be presenting
data or mechanism proposals?

Gorry

---

From: "Karen E. Egede Nielsen" <[email-masked]>
Date: Wed, 25 Jun 2014 11:31:56 +0200

Hi,

We will not have a draft available nor published for IETF90.

We would present the algorithm extensions worked with and some limited
functional tests results only.
The functional test results would not be qualified by traffic tests but
would relate only
to the functional operation of the algorithm and the achieved benefits in
terms of the latency of
an individual loss recovery episode.

The work clearly is work in progress and work on this will continue still
for some time in all aspects;
refinement of algorithm (CC issues in particular), implementation and
collection of data from traffic tests experiments.

The purpose of the presentation would be to collect input and guidance from
the working group - both
in terms of the interest of the working group in this work as well as in
terms of technical guidance on the validity of the
approach. There also is synergy (or lack of) with tcmp work to consider.

BR, Karen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 25. juni 2014 11:08
> To: Karen E. Egede Nielsen
> Cc: [email-masked]; James Polk; [email-masked]
> Subject: Re: tsvwg slot for pres on advances on SCTP Tail Loss Recovery ?
>
> Hi,
>
> like
> to know more:
> > We are working with some advances on SCTP Loss Recovery in order to
> > more efficiently support
> >
> > The advances consist of the advancement of SCTP Fast Recovery with
> > some â€œSCTP-equivalentâ€ additions from RFC6675 (TCP)
> >
> > plus the addition of a timer driven state machine for proactive
> > entering of Fast Recovery, not identical to, but very significantly
> >
> > inspired by the ideas from the TLP approach presented for TCP by
> > Google at IETF87.
> >
> >
> >
> > We are in the early phase of the work (spec, implementation, tests)
> > and have not yet prepared a draft.
> >
> **********************************************************
> ************
> > *********************
> >
> > *Karen Egede Nielsen*
> >
> > KistavÃ¤gen 25,
> **********************************************************
> ************
> > *******************
> >
>