Subject: [tsvwg] Upload acceleration transport network for upstream traffics generated by end users

From: "[email-masked]" <[email-masked]>
Date: Tue, 12 May 2015 09:36:00 +0800

Hi folks，
   
Many popular cloud computing services, such as YouTube, Facebook, etc., are proliferating rapidly these days. Photos, videos and other upstream traffics generated by end users grow drastically. Existing CDNs are frequently used to deliver large-scale content from NSPs to end users while content generated by end users cannot be accelerated by them. 
IMO, upload acceleration transport network for upstream traffics may be need for improving user experiences , namely a content item generated by end user can be actual delivered to a NSP by caches (e.g., lower latency, bottlenecks avoided). Perhaps, the data upload throughput similarly to the CDN approach, but applying it to the opposite direction.

I am wondering whether this issue is covered in the scope of tsvwg WG?

Xiaowei Qin

---

From: Joe Touch <[email-masked]>
Date: Mon, 18 May 2015 10:17:04 -0700

On 5/11/2015 6:36 PM, [email-masked] wrote:
> Hi folks，
>    
> Many popular cloud computing services, such as YouTube, Facebook, etc.,
> are proliferating rapidly these days. Photos, videos and other upstream
> traffics generated by end users grow drastically. Existing CDNs are
> frequently used to deliver large-scale content from NSPs to end users
> while content generated by end users cannot be accelerated by them. 
> IMO, upload acceleration transport network for upstream traffics may be
> need for improving user experiences , namely a content item generated by
> end user can be actual delivered to a NSP by caches (e.g., lower
> latency, bottlenecks avoided). Perhaps, the data upload throughput
> similarly to the CDN approach, but applying it to the opposite direction.
> 

The key question is how the acceleration is accomplished. If by
transport protocol modifications (or, *gasp*, hijacking), then it would
be in-scope.

I.e., the protocol changed or affected defines scope, not the goal. I
can't tell from above whether you're using "transport" as in "layer 4"
or "transfer of information".

Joe