Subject: Re: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt

From: "Black, David" <[email-masked]>
Date: Wed, 17 Feb 2016 23:15:11 +0000

While silence is golden on this draft (a strong indication that it's close to done), we do need
to resolve this remaining open issue on UDP source port configuration wrt middleboxes.
Here's the text involved (from Section 4.2):

   Hence, use UDP src port for entropy may impact middlebox behavior.
   If a GRE-in-UDP tunnel is expected to pass a middlebox, to avoid the
   impact, the operator either disable UDP source port for entropy or
   configure the middlebox to deal with the UDP source port variation.

Lucy asks:

>> This operation can be done easily for a well-managed operator network. Maybe
>> hard in general Internet. Like to get the community feedback if this will be a
>> concern or not. If yes, what is the better alternative?

<WG chair hat OFF>

I agree that this is a concern.  Lucy's question suggests that the text on this topic
be separated into separate provisions for General Internet and Well Managed Operator
Network scenarios - I agree that this is a good approach and would suggest that
the default configuration for the General Internet usage scenario be no source port
entropy.  In contrast, the default configuration for Well Managed Operator Network
usage could be entropy or no-entropy depending on the motivation for use of GRE/UDP
- no-entropy could be a fine default configuration when GRE/UDP is used for connectivity
purposes and taking advantage of ECMP [or LAG] is not a goal.

</WG chair hat OFF>

Thanks, --David

> -----Original Message-----
> From: Lucy yong [mailto:[email-masked]]
> Sent: Thursday, January 28, 2016 6:42 PM
> To: [email-masked]; [email-masked]
> Cc: Black, David; [email-masked]
> Subject: FW: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt
> 
> Hi All,
> 
> This version has quite editing changes which were suggested by the chair (David
> Black) and better aligns with 5405bis. The draft specifies gre/udp tunnel usage in
> two environments: general Internet and well-managed operator network
> (WMON), and names the two applications as Default GRE-in-UDP Tunnel and
> WMON GRE-in-UDP Tunnel, respectively. It specifies the requirements for each
> type of tunnels.
> 
> The draft further defines a well-managed operator network as of an IP network
> that is traffic-engineered and/or otherwise
> managed (e.g., via use of traffic rate limiters) to avoid congestion. Under a well-
> managed operator network, a gre/udp tunnel is less restrictive comparing to be
> used in general Internet.
> 
> The draft has addressed all comments from the meetings and mails. One caviar is:
> 
> Use of UDP src port for entropy may impact with middlebox behavior (see draft).
> To address this conflict, the draft recommends:
> 
>    If a GRE-in-UDP tunnel is expected to pass a middlebox, to avoid the
>    impact, the operator either disable UDP source port for entropy or
>    configure the middlebox to deal with the UDP source port variation.
> 
> This operation can be done easily for a well-managed operator network. Maybe
> hard in general Internet. Like to get the community feedback if this will be a
> concern or not. If yes, what is the better alternative?
> 
> We like to thank David Black a lot for the detail review and suggestions.
> 
> Thanks,
> Lucy
> 
> 
> 
> 
> 
> 
> 
> 
> -----Original Message-----
> From: tsvwg [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, January 26, 2016 7:49 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>  This draft is a work item of the Transport Area Working Group Working Group of
> the IETF.
> 
>         Title           : GRE-in-UDP Encapsulation
>         Authors         : Edward Crabbe
>                           Lucy Yong
>                           Xiaohu Xu
>                           Tom Herbert
> 	Filename        : draft-ietf-tsvwg-gre-in-udp-encap-09.txt
> 	Pages           : 24
> 	Date            : 2016-01-26
> 
> Abstract:
>    This document describes a method of encapsulating network protocol
>    packets within GRE and UDP headers. In this encapsulation, the
>    source UDP port can be used as an entropy field for purposes of load
>    balancing, while the protocol of the encapsulated packet in the GRE
>    payload is identified by the GRE Protocol Type. This document
>    specifies requirements for two applicability scenarios for this
>    encapsulation: (1) General Internet and (2) well-managed operator
>    networks; less restrictive requirements apply to the latter scenario
>    by comparison to the former.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-gre-in-udp-encap/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-tsvwg-gre-in-udp-encap-09
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-gre-in-udp-encap-09
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/

---

From: "Black, David" <[email-masked]>
Date: Thu, 25 Feb 2016 00:44:40 +0000

> purposes and taking advantage of ECMP [or LAG] is not a goal.

<WG chair hat ON>

Having seen no subsequent objection or comment, that approach appears to be the rough
consensus of the tsvwg WG (at least for now).

The draft authors should write text for the next version of the draft accordingly.   There
will be an opportunity to comment (even object) further during Working Group Last Call.

</WG chair hat ON>

Thanks, --David

> From: Black, David
> Sent: Wednesday, February 17, 2016 6:15 PM
> To: Lucy yong; [email-masked]; [email-masked]
> Cc: [email-masked]; Black, David
> Subject: RE: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt
>