Subject: Re: [tsvwg] New draft on Lower Effort PHB draft-bless-tsvwg-le-phb-00.txt

From: Tim Chown <[email-masked]>
Date: Mon, 1 Aug 2016 10:07:52 +0000

> On 28 Jul 2016, at 22:59, Roland Bless <[email-masked]> wrote:
> 
> Hi,
> 
> On 28.07.2016 at 09:56 Tim Chown wrote:
>> An LBE service ran on GEANT and many European NRENs a few years ago,
>> having been introduced I think around the time of 6NET, using the
>> same code point as Scavenger for interoperability (DSCP 8), but I
>> understand that it had minimal use and was retired a while ago.
> 
> That's probably correct. The questions is, however, who determined
> to run which traffic as lower effort. If applications don't mark
> mark their traffic as LE, then one will not see much use of it.
> A unique DSCP for LE will help here.

The DSCP (8) agreed for LBE around 15 years ago in the academic networking community had common meaning across pretty much all European and US research networks at the time, and that lasted at least a few years, but uptake was minimal. Not all routers honoured it, but those that did not passed the DSCP unaltered, so you could benefit from configuring LBE at just points of congestion (typically the edges).

In the UK on Janet there was some use by the bigger content mirrors (marking traffic coming from those), but even that was probably not even necessary.

> Moreover, I heard several times at IETF meetings that especially
> rollouts of major Operating System Updates can cause
> serious congestion. If such updates get marked as LE traffic
> then the performance of other best-effort traffic will not be
> adversely affected. So I think there are several interesting use
> cases for LE.

Having a commonly understood DSCP value for LBE is no bad thing. Whether such use cases need it, or can use alternative CDN approaches, I guess remains to be seen.

Tim

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 1 Aug 2016 15:48:19 +0000

> On Aug 1, 2016, at 3:07 AM, Tim Chown <[email-masked]> wrote:
> 

Were they configured to? I don't know what routers you tried, but any router I'm familiar with has to be configured for any PHB apart from Default.

---

From: Tim Chown <[email-masked]>
Date: Tue, 2 Aug 2016 09:56:20 +0000

> On 1 Aug 2016, at 16:48, Fred Baker (fred) <[email-masked]> wrote:
> 

Here is some (old) GEANT service information:
http://geant1.archive.geant.net/server/show/conWebDoc.500.html

I believe the GEANT network was configured for those three DSCP values, and it was up to each NREN to choose to do so. It included the transatlantic links to Internet 2, where LBE was more commonly called Scavenger. So at the time we had the potential to use ‘Premium IP’ or LBE/Scavenger across the US/European academic networks.

In terms of DSCP transparency, if routers didn’t implement the differential queueing, it was agreed that they should also not for any reason rewrite LBE (DSCP 8) to BE (DSCP 0), so that LBE could be deployed incrementally at congestion points.

Tim