Subject: [tsvwg] draft-fairhurst-tsvwg-transport-encrypt: MSS adjustment / clamping

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Mon, 13 Nov 2017 09:20:47 +0000

Just a small node while I parse draft-fairhurst-tsvwg-transport-encrypt:

I think that a discussion of the TCP MSS "clamping" or TCP MSS "adjustment" is missing in this (useful) document.

As far as I know that functionality is widely supported in sub-TCP devices and well documented (check the Web).
Michael

---

From: "Gorry (erg)" <[email-masked]>
Date: Mon, 13 Nov 2017 22:20:41 +0800

I think it is fine that we add some text about this. 

I would like, But I don’t have, measurement data that would tell me whether plpmtud or mss-clamping is actually the main way that TCP finds the pmtu.

However, I think this method may only work for TCP, where the receiver MSS is known in the header, and not for a range of other transports. 

Gorry

> On 13 Nov 2017, at 17:20, Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]> wrote:
> 
> I think that a discussion of the TCP MSS “clamping” or TCP MSS “adjustment” is missing in this (useful) document.
>