Subject: [tsvwg] Mirja Kühlewind's Discuss on draft-ietf-tsvwg-rlc-fec-scheme-09: (with DISCUSS)

From: Mirja Kühlewind <[email-masked]>
Date: Wed, 10 Oct 2018 08:39:58 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-tsvwg-rlc-fec-scheme-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I'm really not an expert on legal questions and get easily confused myself but
I think just copying in the code including the copyright into the draft
appendix leads to conflicting copyright statements, as the all content of the
draft has the following copyright:

   Copyright (c) 2018 IETF Trust and the persons identified as the
   document authors.  All rights reserved.

And the code says this:

  * Copyright (c) 2011, 2013 Mutsuo Saito, Makoto Matsumoto,
  * Hiroshima University and The University of Tokyo.
  * All rights reserved.

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Oct 2018 13:08:15 -0500

>    * Hiroshima University and The University of Tokyo.

I had a similar concern, and was very close to making a related comment. 
Here's what I uncovered in trying to figure it out.

BCP 78 §6 [1] indicates:

>     It is also important to note that additional copyright notices are
>     not permitted in IETF Documents except in the case where such
>     document is the product of a joint development effort between the
>     IETF and another standards development organization or is a
>     republication of the work of another standards development
>     organization.  Such exceptions must be approved on an individual
>     basis by the IAB.

The TLP [2] §4, however, provides for the notion of code explicitly 
opting in to a BSD license for code components:

> If a licensee elects to apply the BSD License to a Code Component, 
> then the additional licenses and restrictions set forth in Section 3 
> and elsewhere in these Legal Provisions shall not apply thereto 
...and the traditional way to opt into a BSD license is to include it 
with the code in question as a comment block.

I also note that the IESG has issued guidance [3] subsequent to the 
publication of BCP 78 that appears to be an attempt to clarify the 
situation:

> The TLP requires copyright notice in IETF Documents, but not 
> necessarily in each code component within an IETF Document. Authors 
> may choose to include a copyright notice as a comment when a 
> significant amount of code is collected together.

The license on the code in this document is a simplified BSD license, 
which appears to contain the exact provisions indicated in the TLP. The 
one thing that remains muddy for me is whether the phrasing in the TLP 
is meant to explicitly indicate the literal text to appear on the 
copyright line, or if the variation in this document is allowable. Given 
that the nature of the BSD license is such that it provides rights to 
everyone (including the Trust) that would allow its use as envisioned by 
the TLP, I decided that it was unlikely to be an issue.

But, after giving it additional thought, it's probably worth at least 
making a request of the IETF's legal counsel to review the situation and 
provide input.

____
[1] https://tools.ietf.org/html/rfc5378#section-6
[2] https://trustee.ietf.org/license-info/IETF-TLP-5.htm
[3] https://www.ietf.org/blog/iesg-statement-copyright/

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 11 Oct 2018 13:40:34 +0200

I agree, it would be nice to have some review from a legal counsel on this. I was aware that BSD license for code was meant to be compatible with the IETF license (also I didn’t manage to quickly find all the references you provided below; thanks for that!). However, it seems still incorrect to me to have two different copyright statements that apply. I guess the other approach would be to see the code in the appendix as a literal citation and therefore the IETF copyright would not apply to that part. But not sure if that works that way…?

> Am 10.10.2018 um 20:08 schrieb Adam Roach <[email-masked]>:
> 
> I had a similar concern, and was very close to making a related comment. Here's what I uncovered in trying to figure it out.
> 
> BCP 78 §6 [1] indicates:
> 
> 
> The TLP [2] §4, however, provides for the notion of code explicitly opting in to a BSD license for code components:
> 
>> If a licensee elects to apply the BSD License to a Code Component, then the additional licenses and restrictions set forth in Section 3 and elsewhere in these Legal Provisions shall not apply thereto
> ...and the traditional way to opt into a BSD license is to include it with the code in question as a comment block.
> 
> 
> I also note that the IESG has issued guidance [3] subsequent to the publication of BCP 78 that appears to be an attempt to clarify the situation: 
> 
>> The TLP requires copyright notice in IETF Documents, but not necessarily in each code component within an IETF Document. Authors may choose to include a copyright notice as a comment when a significant amount of code is collected together.
> 
> 
> The license on the code in this document is a simplified BSD license, which appears to contain the exact provisions indicated in the TLP. The one thing that remains muddy for me is whether the phrasing in the TLP is meant to explicitly indicate the literal text to appear on the copyright line, or if the variation in this document is allowable. Given that the nature of the BSD license is such that it provides rights to everyone (including the Trust) that would allow its use as envisioned by the TLP, I decided that it was unlikely to be an issue.
> 
> But, after giving it additional thought, it's probably worth at least making a request of the IETF's legal counsel to review the situation and provide input.
> ____