Subject: [tsvwg] Technical discussion 1 of draft-ietf-tsvwg-aqm-dualq-coupled-08

From: David Pullen <[email-masked]>
Date: Mon, 17 Dec 2018 09:43:10 -0500

Hi Bob,

As promised, this is the first of a small number of emails regarding draft
08 of this document.

In section 2.5.1:

The AQM algorithm for the low latency (L) queue MUST apply ECN marking.

Of course, ECN marking is only applied to ECT-capable traffic. Is it worth
noting the desired behavior when a non-ECT-capable packet would have been
marked in the L queue?

Thanks,
  - Dave

David Pullen
Distinguished Engineer  |  Wired Networking, Cable Modems
Broadcom

office: 678.475.3143  |  mobile: 678.477.4108  |  fax: 770.232.0211
4385 River Green Parkway  |  Duluth, GA 30096
[email-masked]   |   broadcom.com

---

From: Bob Briscoe <[email-masked]>
Date: Mon, 17 Dec 2018 17:08:38 +0000

David,

Good catch - one of those situations where we added the section on 
classifying non-ECN traffic into the L queue later. I've changed "MUST 
apply" to "MUST be able to apply" to side-step having to discuss all the 
exceptional cases like overload, as well as the one you mention, which I 
have mentioned explicitly. Sentence now reads:

     The AQM algorithm for the low latency (L) queue MUST be able to 
apply ECN marking to ECN-capable packets.

OK?

Bob

On 17/12/2018 14:43, David Pullen wrote:
> Hi Bob,
>
> As promised, this is the first of a small number of emails regarding 
> draft 08 of this document.
>
> In section 2.5.1:
>
> Of course, ECN marking is only applied to ECT-capable traffic. Is it 
> worth noting the desired behavior when a non-ECT-capable packet would 
> have been marked in the L queue?
>
> Thanks,
>   - Dave
>
> David PullenDistinguished Engineer  |  Wired Networking, Cable 
> ModemsBroadcomoffice:678.475.3143  | mobile:678.477.4108  | 
> fax:770.232.02114385 River Green Parkway  |  Duluth, GA 
> [email-masked] <mailto:[email-masked]>   | 
> broadcom.com <http://broadcom.com>
>

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: David Pullen <[email-masked]>
Date: Mon, 17 Dec 2018 12:40:30 -0500

Hi Bob,

Yes, this seems good to me.

Thanks,
  - Dave

(Sent from my cell phone, please excuse typos and brevity)

On Mon, Dec 17, 2018, 12:08 PM Bob Briscoe <[email-masked] wrote:

>     The AQM algorithm for the low latency (L) queue MUST be able to apply
> ECN marking to ECN-capable packets.
>
> OK?
>
>
> Bob
>
> David Pullen Distinguished Engineer  |  Wired Networking, Cable Modems
> Broadcom office: 678.475.3143  |  mobile: 678.477.4108  |  fax:
> 770.232.0211 4385 River Green Parkway  |  Duluth, GA 30096