Subject: [GNAP] Some remaining issues about the core-protocol

From: Denis <[email-masked]>
Date: Thu, 6 May 2021 16:29:51 +0200

Hello,

The mailing list has been pretty silent these last days.

Hereafter is a quick overview about some of the remaining issues 
classified by order of  importance (from my point of view).

  1. User choice and consent, and user notice #215

smartopain wote:

To draw a parallel: Since the publication of the EU GDPR (General Data 
Protection Regulation) the use of the cookies has changed.
An end-user is allowed to accept them all, to deny them all (except 
functional cookies) and even to make some choices.
The end-users can know which legal entity will collect the cookies and 
what for.

The same kind of screens should be proposed to the end-user.
*From a technical perspective, specific end-points should be defined and 
used, since this kind of dialog is done using APIs.*

  I agree with smartopain.

*2. Trust relationships **#214*

There are still left undefined. AS-RS trust relationships are important. 
RO relationships with both ASs and RSs are veryimportant
but unfortunately are discussed nowhere in the current draft (except in 
text proposals about this issue)

*3. **Interaction (1) between the Client Instance and the RS as 
described in the first figure **#252*

Still on the table but not progressing.

  4. The first figure in section 1.4 should be split and revisited #192

This is still not done.

  5. Unlinkability #241

Still on the table but not progressing.

  6. Requesting User Information #197

This is still a hazy topic.

  Denis

---

From: Denis <[email-masked]>
Date: Thu, 6 May 2021 16:43:34 +0200

Quite strange, between the time I prepared my message and now, the 
following issue has disappeared:

  5. Unlinkability #241

Is there a way to have a look at missing or closed issues ?

Denis

> *From a technical perspective, specific end-points should be defined 
> and used, since this kind of dialog is done using APIs.*
>
>  I agree with smartopain.
>
> There are still left undefined. AS-RS trust relationships are 
> important. RO relationships with both ASs and RSs are veryimportant
> but unfortunately are discussed nowhere in the current draft (except 
> in text proposals about this issue)
>

---

From: Fabien Imbault <[email-masked]>
Date: Thu, 6 May 2021 16:47:18 +0200

Hi Denis
This specific issue was pending close 22 days ago and then closed 15 days
ago (which follows the editorial process).
Best
Fabien

On Thu, May 6, 2021 at 4:43 PM Denis <[email-masked]> wrote:

> RO relationships with both ASs and RSs are very important
> *3. **Interaction (1) between the Client Instance and the RS as described
> in the first figure **#252*
>
> --
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

---

From: Aaron Parecki <[email-masked]>
Date: Thu, 6 May 2021 07:48:30 -0700

This issue?

https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/241

---

From: Denis <[email-masked]>
Date: Thu, 6 May 2021 16:53:38 +0200

Thank you Aaron,

The issue was pending closed but has been reopened by Justin.

However, when I list all issues, this is what I can see:

Issue 241 does not appear.

This is still strange.

Denis

> <https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/241>
>
>
> On Thu, May 6, 2021 at 7:43 AM Denis <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>>     To draw a parallel: Since the publication of the EU GDPR (General
>>     Data Protection Regulation) the use of the cookies has changed.
>>     An end-user is allowed to accept them all, to deny them all
>>     (except functional cookies) and even to make some choices.
>>     The end-users can know which legal entity will collect the
>>     cookies and what for.
>>
>>     *From a technical perspective, specific end-points should be
>>     defined and used, since this kind of dialog is done using APIs.*
>>
>>      I agree with smartopain.
>>
>>     but unfortunately are discussed nowhere in the current draft
>>     (except in text proposals about this issue)
>>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/txauth>
>

---

From: Justin Richer <[email-masked]>
Date: Thu, 6 May 2021 10:58:13 -0400

Hi Denis,

That issue was closed and was not re-opened by me (or anyone), and so it remains closed.

 — Justin

> On May 6, 2021, at 10:53 AM, Denis <[email-masked]> wrote:
> 
> Thank you Aaron,
> 
>> https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/241 <https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/241>
>> 
>> 
>> On Thu, May 6, 2021 at 7:43 AM Denis <[email-masked] <mailto:[email-masked]>> wrote:
>> Quite strange, between the time I prepared my message and now, the following issue has disappeared:
>> 5. Unlinkability #241
>> 
>>> Hereafter is a quick overview about some of the remaining issues classified by order of  importance (from my point of view).
>>> 
>>> 
>>> To draw a parallel: Since the publication of the EU GDPR (General Data Protection Regulation) the use of the cookies has changed. 
>>> An end-user is allowed to accept them all, to deny them all (except functional cookies) and even to make some choices. 
>>> The end-users can know which legal entity will collect the cookies and what for.
>>> 
>>> From a technical perspective, specific end-points should be defined and used, since this kind of dialog is done using APIs.
>>> 
>>>  I agree with smartopain.
>>> 
>>> 2. Trust relationships #214
>>> 
>>> There are still left undefined. AS-RS trust relationships are important. RO relationships with both ASs and RSs are very important 
>>> but unfortunately are discussed nowhere in the current draft (except in text proposals about this issue)
>>> 
>>> 3. Interaction (1) between the Client Instance and the RS as described in the first figure #252
>>> 
>> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> 
> -- 
> TXAuth mailing list
> [email-masked]