Subject: [GNAP] IETF 113 Hackathon

From: Justin Richer <[email-masked]>
Date: Sat, 19 Mar 2022 10:21:00 +0100

The IETF 113 Hackathon is underway. Aaron and I are camped out at a table working on things, if you’re in town come join us! If you’re remote, there’s a space in the IETF Gather where we’ll be hanging out as well.

More info on the hackathon wiki:

https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon <https://trac.ietf.org/trac/ietf/meeting/wiki/113hackathon>

 — Justin

---

From: Justin Richer <[email-masked]>
Date: Sun, 20 Mar 2022 15:01:11 +0100

Aaron and I just finished presenting our results from the Hackathon. We made some pretty great progress this weekend across a variety of platforms. Our presentation is available here, and we’ll be giving this as part of the GNAP meeting editors’ update on Friday as well.

https://github.com/IETF-Hackathon/ietf113-project-presentations/blob/main/GNAP%20IETF%20113%20Hackathon.pdf <https://github.com/IETF-Hackathon/ietf113-project-presentations/blob/main/GNAP%20IETF%20113%20Hackathon.pdf>

If you’re feeling adventurous, we’ve also got two GNAP clients and a GNAP AS online for you to play with. The Java web client is here, and you can configure this to start a fairly arbitrary GNAP Request against an arbitrary AS:

https://gnap-c.herokuapp.com/ <https://gnap-c.herokuapp.com/>

And there’s a browser-only SPA published here:

https://gnap-c.herokuapp.com/spa <https://gnap-c.herokuapp.com/spa>

And the AS is here, and you should be able to point your clients at it:

https://gnap-as.herokuapp.com/ <https://gnap-as.herokuapp.com/>

All of these are hackathon-quality, so they’re pretty breakable and the failures are not graceful when they do happen. :)

Hopefully we’ll see many of you on Friday,
 — Justin

> On Mar 19, 2022, at 10:21 AM, Justin Richer <[email-masked]> wrote:
> 
> -- 
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth