Subject: [Unbearable] wrt merges of PRs #83 & #84

From: =JeffH <[email-masked]>
Date: Thu, 15 Dec 2016 09:48:08 -0800

Andrei wrote:
 > [#83] Merged on GitHub. Will look at PR #84 tomorrow.
 > ...
 > Also merged PR #84.

thanks for merging those in, Andrei.

Unfortunately, in examining the resultant commits in the github repo 
made to both draft-ietf-tokbind-https-08.xml and 
draft-ietf-tokbind-protocol-12.xml, it seems at least some of the 
commits I had made were undone by these commits of yours when ostensibly 
merging the pull requests..

   Merging PR #83
 
<https://github.com/TokenBinding/Internet-Drafts/commit/43e6d1f78f1452b1193ebc02ddc33da314f60d99>

   Merging PR #84
 
<https://github.com/TokenBinding/Internet-Drafts/commit/4a9ca7c5262380f6048a78712e14b53dc5101411>

It seems that what might've happened with the 43e6d1f #83 commit above 
is that you updated the README.md (which I'd neglected to do, sorry) and 
also edited -tokbind-https on your local repo clone and but had not 
pulled in all the changes from the PR before pushing back to the remote 
(I've seen this happen before).

And perhaps something similar happened for the 4a9ca7c #84 commit.

thanks, hth,

=JeffH

---

From: Andrei Popov <[email-masked]>
Date: Thu, 15 Dec 2016 18:53:19 +0000

While merging the changes, I edited them for technical correctness, etc. Some of the changes in the PRs didn't make sense to me. If there's something particularly important to you that I undid, let's discuss.

Cheers,

Andrei

-----Original Message-----
From: =JeffH [mailto:[email-masked]] 
Sent: Thursday, December 15, 2016 9:48 AM
To: Andrei Popov <[email-masked]>
Cc: IETF TokBind WG <[email-masked]>
Subject: wrt merges of PRs #83 & #84

Unfortunately, in examining the resultant commits in the github repo made to both draft-ietf-tokbind-https-08.xml and draft-ietf-tokbind-protocol-12.xml, it seems at least some of the commits I had made were undone by these commits of yours when ostensibly merging the pull requests..

   Merging PR #83

   Merging PR #84

It seems that what might've happened with the 43e6d1f #83 commit above is that you updated the README.md (which I'd neglected to do, sorry) and also edited -tokbind-https on your local repo clone and but had not pulled in all the changes from the PR before pushing back to the remote (I've seen this happen before).

thanks, hth,

=JeffH