Subject: [Unbearable] WG adoption of draft-campbell-tokbind-ttrp-00

From: Leif Johansson <[email-masked]>
Date: Mon, 17 Jul 2017 17:50:20 +0200

In the f2f meeting in Prague there was clear consensus to adopt
draft-campbell-tokbind-ttrp-00 as draft-ietf-tokbind-ttrp-00
making this a WG document.

If anyone on the list disagrees, now is the time to speak up.

	Cheers Leif & John

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 17 Jul 2017 20:35:02 +0000

So I'm not sure of the value of this as we and the their companies have already implemented solutions that are different than what is being proposed. This also does not work for a lot of our use cases where there is an untrusted proxy. Most of our cases are also within our own infrastructure so no question the need for standardization.

________________________________
From: Unbearable <[email-masked]> on behalf of Leif Johansson <[email-masked]>
Sent: Monday, July 17, 2017 5:50:20 PM
To: IETF Tokbind WG
Subject: [Unbearable] WG adoption of draft-campbell-tokbind-ttrp-00

        Cheers Leif & John

_______________________________________________
Unbearable mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%7Ctonynad%40microsoft.com%7C06e4b840a7a94372b5e008d4cd2b8f26%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636359034357583877&sdata=hW8BlMQm1Sf%2BjDXeAQ9%2BeHIxXMroROFSuegdWpdX8DA%3D&reserved=0

---

From: Brian Campbell <[email-masked]>
Date: Wed, 19 Jul 2017 19:15:33 +0200

The intent of the draft is to help facilitate interoperability between
independently developed and/or deployed components. And there is value in
standardization for that. But of course conformance to the draft isn't
required in cases, like perhaps those that you mention where everything is
within your own infrastructure, where that kind of interoperability isn't
important.

On Mon, Jul 17, 2017 at 10:35 PM, Anthony Nadalin <[email-masked]>
wrote:

> So I'm not sure of the value of this as we and the their companies have
> already implemented solutions that are different than what is being
> proposed. This also does not work for a lot of our use cases where there is
> an untrusted proxy. Most of our cases are also within our own
> infrastructure so no question the need for standardization.
>
> ------------------------------
> *From:* Unbearable <[email-masked]> on behalf of Leif
> Johansson <[email-masked]>
> *Sent:* Monday, July 17, 2017 5:50:20 PM
> *To:* IETF Tokbind WG
> *Subject:* [Unbearable] WG adoption of draft-campbell-tokbind-ttrp-00
>
>
> https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%
> 7Ctonynad%40microsoft.com%7C06e4b840a7a94372b5e008d4cd2b8f26%
> 7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636359034357583877&sdata=
> hW8BlMQm1Sf%2BjDXeAQ9%2BeHIxXMroROFSuegdWpdX8DA%3D&reserved=0
>
> https://www.ietf.org/mailman/listinfo/unbearable
>
>

-- 
*CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you.*

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 20 Jul 2017 08:03:31 +0000

Maybe this should just be an Informational and not standards track

From: Brian Campbell [mailto:[email-masked]]
Sent: Wednesday, July 19, 2017 10:16 AM
To: Anthony Nadalin <[email-masked]>
Cc: Leif Johansson <[email-masked]>; IETF Tokbind WG <[email-masked]>
Subject: Re: [Unbearable] WG adoption of draft-campbell-tokbind-ttrp-00

The intent of the draft is to help facilitate interoperability between independently developed and/or deployed components. And there is value in standardization for that. But of course conformance to the draft isn't required in cases, like perhaps those that you mention where everything is within your own infrastructure, where that kind of interoperability isn't important.

On Mon, Jul 17, 2017 at 10:35 PM, Anthony Nadalin <[email-masked]<mailto:[email-masked]>> wrote:
So I'm not sure of the value of this as we and the their companies have already implemented solutions that are different than what is being proposed. This also does not work for a lot of our use cases where there is an untrusted proxy. Most of our cases are also within our own infrastructure so no question the need for standardization.

________________________________
From: Unbearable <[email-masked]<mailto:[email-masked]>> on behalf of Leif Johansson <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 17, 2017 5:50:20 PM
To: IETF Tokbind WG
Subject: [Unbearable] WG adoption of draft-campbell-tokbind-ttrp-00

        Cheers Leif & John

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%7Ctonynad%40microsoft.com%7C06e4b840a7a94372b5e008d4cd2b8f26%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636359034357583877&sdata=hW8BlMQm1Sf%2BjDXeAQ9%2BeHIxXMroROFSuegdWpdX8DA%3D&reserved=0

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%7Ctonynad%40microsoft.com%7Cb1355580db1045ba7b0f08d4cec9d6ff%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636360813668753933&sdata=B5U72oWWIP%2B5XDET3rFupu4Q5mvpQlOk6LmdPlDQM4M%3D&reserved=0>

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Leif Johansson <[email-masked]>
Date: Fri, 21 Jul 2017 09:28:46 +0200

> If anyone on the list disagrees, now is the time to speak up.

I think we can deal with Tonys concerns in the WG and given the
strong support for adopting the document in the WG meeting I'm
calling rough consensus on this.

Brian: go ahead and publish draft-ietf-tokbind-ttrp-00 at your
convenience.

	Cheers Leif

---

From: Brian Campbell <[email-masked]>
Date: Sat, 22 Jul 2017 11:34:14 +0200

Thanks Leif,

The draft has been published:
https://tools.ietf.org/html/draft-ietf-tokbind-ttrp-00

On Jul 21, 2017 9:28 AM, "Leif Johansson" <[email-masked]> wrote:

        Cheers Leif