Subject: [Unbearable] Token binding for Oauth2.0

From: tharmakulasingham inthirakumaaran <[email-masked]>
Date: Mon, 30 Oct 2017 10:45:34 +0530

Hi all,

I am a university student and trying to implement token binding for
oauth2.0 in one of my projects. Currently, I am using nginx as proxy to do
the token binding but hope to write a token binding implementation in java.

I want to know how we can send referred token binding ID(RID) without
redirection or  Include-referred-ID header. Especially in the point where
client application send access token request with including referred token
binding ID (ID between the client app and resource server).Although spec
says we can use other methods, I cannot find what are those.

Please clarify me on this matter and open to any suggestion on how to do
this project.If you can suggest any example implementations that would be
helpful too.

Thank you,
kumaaran

---

From: Mike Jones <[email-masked]>
Date: Mon, 30 Oct 2017 06:37:53 +0000

Please see https://tools.ietf.org/html/draft-ietf-oauth-token-binding-05 for the answers.

                                                       Best wishes,
                                                       -- Mike

From: Unbearable [mailto:[email-masked]] On Behalf Of tharmakulasingham inthirakumaaran
Sent: Sunday, October 29, 2017 10:16 PM
To: [email-masked]
Subject: [Unbearable] Token binding for Oauth2.0

Hi all,

I am a university student and trying to implement token binding for oauth2.0 in one of my projects. Currently, I am using nginx as proxy to do the token binding but hope to write a token binding implementation in java.

I want to know how we can send referred token binding ID(RID) without redirection or  Include-referred-ID header. Especially in the point where client application send access token request with including referred token binding ID (ID between the client app and resource server).Although spec says we can use other methods, I cannot find what are those.

Please clarify me on this matter and open to any suggestion on how to do this project.If you can suggest any example implementations that would be helpful too.

Thank you,
kumaaran