Subject: RE: IPP> Implementation question re.: chunking

From: Paul Moore <[email-masked]>
Date: Fri, 24 Jul 1998 10:24:54 -0700

You might find that some implementations dont support chunking.

> -----Original Message-----
> From:	Randy Turner [SMTP:[email-masked]]
> Sent:	Friday, July 24, 1998 10:05 AM
> To:	Carl Kugler
> Cc:	[email-masked]
> Subject:	Re: IPP> Implementation question re.:  chunking
> 
> At 04:51 PM 7/24/98 +0000, you wrote:
> >draft-ietf-ipp-protocol-06.txt says the client and server MUST support
> the
> "chunked" transfer encoding when receiving.  My question is:  Can we count
> on this?  I.e., if our client always transmits requests using the
> "chunked"
> transfer encoding, will we be able to interoperate with the vast majority
> of IPP server implementations?
> >
> >    -Carl
> 
> 
> There are no vast majority of IPP server implementations (yet). I think
> the
> only worry is if someone plans to deploy IPP behind a generic web server
> that doesn't support chunking. However, Apache and most other of the more
> popular HTTP/1.1 servers will support this. It should definitely be a
> bullet item (checkoff item) at the upcoming bake-off, however.
> 
> Randy
> 
> >

---

From: Paul Moore <[email-masked]>
Date: Fri, 24 Jul 1998 11:33:19 -0700

I dont see where it says that a server must support chunking. It says I must
support 1.1. Maybe I am reading it wrong (I guess thats why we have
bake-offs)

> From:	Turner, Randy [SMTP:[email-masked]]
> Sent:	Friday, July 24, 1998 10:48 AM
> To:	[email-masked]'
> Subject:	RE: IPP> Implementation question re.:  chunking
> 
> 
> Well, I'm assuming since we "last-call'd" these documents in the WG,
> that everybody is in agreement that an implementation that doesn't
> support chunking isn't compliant.
> 
> Randy
> 
> 
> 		From:	Paul Moore [mailto:[email-masked]]
> 		Sent:	Friday, July 24, 1998 10:25 AM
> 		To:	'Randy Turner'; Carl Kugler
> 		Cc:	[email-masked]
> 		Subject:	RE: IPP> Implementation question re.:
> chunking
>