Subject: Re: IPP> New IPP Model Document

From: Jay Martin <[email-masked]>
Date: Fri, 29 May 1998 17:51:09 -0400

Randy,

> This may be a difficult requirement to meet if an IPP implementation is
> built as an extension to a generic web server (like Apache).

Are you sure about this?  I mean, I can see you point to
a certain extent, but wouldn't it be advantageous for an
IPP server implemented as a front-end on a generic platform
to be used as a multiplexor to several Printers and Jobs?

On the other hand, if the HTTP request header takes precedent,
then why are we specifying printer-uri/job-uri at all at the
IPP protocol level?  Aren't we asking for trouble when the
HTTP request header and the corresponding IPP attributes don't
match (with regard to interoperability)?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

Turner, Randy wrote:
> 
> This may be a difficult requirement to meet if an IPP implementation is
> built as an extension to a generic web server (like Apache).
> 
> Randy
> 
>         -----Original Message-----
>         From:   Jay Martin [SMTP:[email-masked]]
>         Sent:   Friday, May 29, 1998 2:34 PM
>         To:     [email-masked]
>         Cc:     Puru Bish
>         Subject:        Re: IPP> New IPP Model Document
> 
>         After thinking about this, I tend to agree with Puru's
>         statement:
> 
>         >From "Tom Hastings"
>         >
>         > :: In fact, the HTTP request header URI, if persent, takes
> precedence"
>         > (over printer-uri/job-uri operation attributes).
>         >
>         > I think it should  be the other way around. I feel the
>         > printer-uri/job-uri, supplied by IPP client, should have
> higher
>         > precedence to an IPP server than the HTTP header URI.
> 
>                 ...jay
> 
> 
> ----------------------------------------------------------------------
>         --  JK Martin               |  Email:   [email-masked]
> --
>         --  Underscore, Inc.        |  Voice:   (603) 889-7000
> --
>         --  41C Sagamore Park Road  |  Fax:     (603) 889-2699
> --
>         --  Hudson, NH 03051-4915   |  Web:
> http://www.underscore.com   --
> 
> ----------------------------------------------------------------------

---

From: "Scott Isaacson" <[email-masked]>
Date: Fri, 29 May 1998 16:19:56 -0600

As I recall, 
the only reason that the printer-uri/job-uri attributes are in
protocol at the IPP layer, is because we wanted to be
consistent with possibly future mappings of IPP onto 
protocols other than HTTP where we didn't have
equivalent routing info.  These attributes in the IPP
payload are totally redundant and they are not needed
in the HTTP mapping.

Maybe it was a bad idea to add them, since many
server implementations behind a generic web server
(as Randy points out) will work fine even if it never
even validates the values of these attributes that are
internal to the application/ipp blob.

Scott

>>> Jay Martin <[email-masked]> 05/29 3:51 PM >>>
> snip...

	...jay

---

From: Jay Martin <[email-masked]>
Date: Fri, 29 May 1998 21:28:36 -0400

Randy,

> It is becoming clear to me that the two URI(URLs) actually mean
> different things, and that each URI should be handled by different
> pieces of the system; the HTTP header should be handled by the outer
> HTTP processing code, while the inner URI should be handled by the core
> IPP code. Its almost like the HTTP URI is really the transport URI, and
> the IPP URI really points to the IPP object to which we are
> communicating (the application layer object).

Ok, then I guess we're back to Puru's basic inquiry
revolving around precedence between the two URLs.

Based on your above statement, it sounds like we must
have NO precedence whatsoever, right?

	...jay

---

From: "Turner, Randy" <[email-masked]>
Date: Fri, 29 May 1998 21:43:08 -0700

I think in the case of IPP behind a generic web server, the two headers
are entirely different, and precedence does not apply. I'm pretty sure
it applies in all cases, even a dedicated IPP/HTTP server, but give me
the weekend to mull it over ;)

Randy

-----Original Message-----
From: Jay Martin
To: Turner, Randy
Cc: [email-masked]
Sent: 5/29/98 6:28 PM
Subject: Re: IPP> New IPP Model Document

Randy,

	...jay