Subject: re needed refinements

From: Terry Allen <[email-masked]>
Date: Fri, 8 Sep 2000 14:21:46 -0700

[reply-to is being munged ...]

Leslie wrote:
| In the process of reviewing recent URN formal NID proposals, the
| IESG has expressed some concerns over whether the URN
| working group had adequately described constraints that would
| maximize the likelihood of public use and overall interoperability
| of these namespaces.
|
| Specifically, the current process (RFC2611) does indicate that a
| formal NID RFC will be published subject to IESG review, but
| the suggestion is that there should be more concretely stated
| guidelines so that new formal NIDs are considered when there
| is adequate justification that:
|
|         . there is no existing namespace that would serve the
|           functional purposes of the proposer
|
|         . the proposed namespace is of sufficient community
|           value that it merits the distinction of a formal NID
|
| Terry, I think this speaks to your concern about getting _all_ the
| criteria out on the table.

It does, although the criticisms we've heard recently (except
about the NBN proposal) were along different lines.  I have to
say I don't agree that we should consider the first point (aside
from informing an applicant about a name space that he may have
overlooked), because functional purpose is only part of the
story:  reliability and trust in the name space administrator
may be far more importnat to the user.

And the second point is impossibly vague:  what community?
what kind of value?  what IS the "distinction of a formal
NID" such that a name space must merit it?  and what is
"sufficient"?

In the meantime, does anyone have any notion of what to do
about formal-looking NIDs that haven't been approved, such
as those Microsoft is using?

best regards, Terry

---

From: Leslie Daigle <[email-masked]>
Date: Fri, 8 Sep 2000 17:41:30 -0400

A quick clarification:

Terry Allen wrote:
> because functional purpose is only part of the

I think the larger point was to justify the need for a new
namespace; so these issues could potentially equally constitute
acceptable reasons.

> as those Microsoft is using?

Part of a rather general problem with Microsoft, I'm afraid.

Leslie.

--

-------------------------------------------------------------------
"Reality with a delicate splash of the imaginary...
    ... or was that the other way around?"
   -- ThinkingCat

Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Yves Arrouye <[email-masked]>
Date: Fri, 8 Sep 2000 22:17:12 -0700

> Part of a rather general problem with Microsoft, I'm afraid.

Part of a general problem with XML people who thought that one can use
urn:whatever:some-id to have some sort of unique identifier for their
documents' schemas.

YA