Subject: [urn] Are ISO 3166 country codes stable enough for URN use?

From: Sean Leonard <[email-masked]>
Date: Sun, 21 Feb 2016 11:45:57 -0800

In reviewing the latest draft-ietf-urnbis-ns-reg-transition, I noticed 
the dependency on NBN [RFC3188], which in turn depends on ISO 3166.

An example is <URN:NBN:fi-fe19981001>.

URNs are supposed to be stable and durable over time...

but are ISO 3166 country codes stable enough for URN?

I have not actually read all of the details of ISO 3166. But ISO 3166 
grapples with an intensely political question: how to name countries. I 
read this PDF:
http://unstats.un.org/unsd/tradekb/Attachment194.aspx

And it says that "withdrawn [codes] may not be reused for five years". 
That means that they can be reused in five years. I think that violates 
some URN principles.

NBN isn't the first time we have seen ISO 3166 country codes in URNs. 
There is the urn:lex proposal (not really sure where that is now).

There are also my proposals for urn:xmlns and urn:rdf. However in my 
proposals, the entire NSS is assigned on a first-come, first-served 
basis: the relationship between two- and three-character ISO 3166 
country codes being part of the NSS is purely a coincidence and 
therefore reassignment of a country code does not affect the durability 
and immutability of the assigned string.

Sean

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Feb 2016 15:35:25 -0500

Sean,

Very briefly and having spend far too much time immersed in a
well-known use of 3166 and it implications, two observations:

(1) The "we can, and probably will, reassign a code after five
years" rule have been dead for some years.  You should be
careful about what you treat as an authoritative reference.
Because of (2), I may regret even mentioning that.

(2) The definition of "persistent enough" or "stable enough"
inevitably has to be per-namespace.  One of the earliest
examples in the discussions that led to URNs was "the weather
in..." which can be as stable as location names are as a
reference but whose object is typically entirely unstable.  

This isn't a WG topic.  When the NDN spec is revised, you can
certainly have the discussion in the context of that revision
(assuming they don't simply decide to register something based
on a document published elsewhere which, fwiw, is certainly what
I would be inclined to do if I were in their position).

   john

--On Sunday, February 21, 2016 11:45 AM -0800 Sean Leonard
<[email-masked]> wrote:

> In reviewing the latest draft-ietf-urnbis-ns-reg-transition, I
> noticed the dependency on NBN [RFC3188], which in turn depends
> on ISO 3166.
> 
> I have not actually read all of the details of ISO 3166. But
> ISO 3166 grapples with an intensely political question: how to
> name countries. I read this PDF:
> And it says that "withdrawn [codes] may not be reused for five
> years". That means that they can be reused in five years. I
> think that violates some URN principles.
> 
> NBN isn't the first time we have seen ISO 3166 country codes
> in URNs. There is the urn:lex proposal (not really sure where
> that is now).
> 
> There are also my proposals for urn:xmlns and urn:rdf. However
> in my proposals, the entire NSS is assigned on a first-come,
> first-served basis: the relationship between two- and
> three-character ISO 3166 country codes being part of the NSS
> is purely a coincidence and therefore reassignment of a
> country code does not affect the durability and immutability
> of the assigned string.
> 
> Sean
> 
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

---

From: Sean Leonard <[email-masked]>
Date: Sun, 21 Feb 2016 12:37:38 -0800

Ok.

It sounds like the durability and persistence requirements for URNs are 
being relaxed somewhat, compared to the old days.

I'm fine with that, carry on.

Sean

---

From: "Phillips, Addison" <[email-masked]>
Date: Sun, 21 Feb 2016 20:56:36 +0000

If you were still concerned about 3166 stability, note the the language subtag registry (BCP 47) maintains a stabilized version for the region set of subtags. Because it still isn't okay to reuse the codes, even over periods longer than five years.

(Sent from my Fire tablet)

On February 22, 2016, at 12:39 AM, Sean Leonard <[email-masked]> wrote:

Ok.

Sean