Subject: [urn] ReL draft-ietf-urnbis-rfc2141bis-urn-15

From: John C Klensin <[email-masked]>
Date: Sat, 13 Feb 2016 09:49:45 -0500

Hi.

Writing primarily as the pen-holding editor for -15 and the
likely one for -16....

It has now been over a week since -15 was posted and there have
been absolutely no comments.  I am fairly sure the mailing list
is working because there have been postings about two URN NID
registration proposals --proposals that would presumably be
handled quite differently under the new, 2141bis rules.

I hope, although I'm afraid to assume, that the silence means
that -15 reflects agreement on the basic technical, protocol,
and procedural issues and how to handle them and an acceptable
and reasonably balanced way of dealing with the issues we
clearly are not ready to handle and reach consensus about.
There is a lot of new text (compared to -13 and -14) in the
document but I believe we've discussed enough of the issues
on-list that none of it should be a surprise.

Whether the text correctly and optimally reflects the WG's views
is a separate question, so I'd really appreciate comments on
that question, preferably soon enough that we don't lose
momentum again.   In particular, I would hope that people would
pay careful attention to, and comment on:

(1) Do the registration template and supporting information
still reflect what we want there?  They have not been carefully
reviewed, much less revised, in the last few drafts, and we need
to think about other changes and whether they should be
reflected in the NID/ Namespace registration specifications.

(2) We've seen two proposals for NID registrations in the last
week or two.  Would the registration template and new procedure
adequately reflect whatever we've learned from them?  Would we
be happy having them go through under the new procedure?

(3) Is the ABNF consistent with everyone's expectations,
especially noting the the change in introducers for r-component
and q-component eliminates several problems (including the
controversy about ordering) but may introduce a few others.  In
particular, is everyone ok with q-component and r-component
appearing in either order (as the text and ABNF now say) or is
there some reason to require a specific order)?  Similarly, the
text contains some words about the implications of "?" followed
by neither (new) delimiter but the ABNF doesn't call the issue
out.   Is that ok with everyone?  If it is not, please propose
ABNF changes and/or text.

(4) Is the spec now clear enough?  Are there places that need
work?  If so, please at least identify the places and the issues
and, if possible, propose text.

Possibly others have other issues, but it would be good to
identify them soon.   Speaking personally, I'd be very pleased
if we could get far enough that I could spin up and post a new
draft on the weekend of the 20th and then go into WG Last Call
the following week.   Especially given the silence of the last
week, I think that ought to be possible.   IMO, the best parting
present we could give Barry before he formally steps down as AD
would be to let him get an IETF LC wrapped up and the WG either
shut down or concluded except for RFC Editor review.

     john

---

From: Sean Leonard <[email-masked]>
Date: Sat, 20 Feb 2016 20:45:33 -0800

> Writing primarily as the pen-holding editor for -15 and the

John and Peter (and other editors/contributors), thank you for your service.

Okay so I finally combed through the new documents, and have feedback 
that you are requesting. I believe it is best to send a few concise 
e-mails rather than a big long one, so that is what I will do.

Sean

---

From: Sean Leonard <[email-masked]>
Date: Sun, 21 Feb 2016 10:23:49 -0800

Let me respond to John's specific questions...

> reflected in the NID/ Namespace registration specifications.

They are okay. (See prior e-mail.)

> be happy having them go through under the new procedure?

I am fine with them going through under the new procedure. I believe 
that the registration template and procedure are good enough.

> ABNF changes and/or text.

This is a big problem, to the point of being unimplementable. Already 
covered per prior e-mail.

> and, if possible, propose text.

Hopefully my prior e-mail covered the places that need work. Three areas 
to highlight (here--covered extensively in prior e-mail) are:
1. whether r-component is namespace-dependent or namespace-independent,
2. UTF-8 encoding enforcement, and
3. whether f-component ought to be passed to resolvers.

My summary:
1. draft-15 is dependent but it should be independent.
2. draft-15 has it right technically on UTF-8 but is not concise enough 
in saying how it is.
3. draft-15 says f-component SHOULD NOT be passed to resolvers, but it 
should say that f-component MUST NOT be passed to resolvers. "Resolver" 
needs to be more carefully defined so that this axiomatically pops out 
of the definition.

Sean

---

From: Martin J. Dürst <[email-masked]>
Date: Mon, 22 Feb 2016 14:28:47 +0900

Hello John, others,

> handled quite differently under the new, 2141bis rules.

On my side, the main reason is extreme business in my day job up and 
including yesterday. It's not that I suddenly am on vacation, but as you 
already may have seen from my first email on the subject, I should be 
able to use a bit of time on IETF matters, including URNs, in the next 
days/weeks. I definitely plan to have a close look at what's said on 
I18N/UTF-8.

Regards,   Martin.

---

From: "Svensson, Lars" <[email-masked]>
Date: Wed, 24 Feb 2016 15:44:55 +0000

John, all,

On Saturday, February 13, 2016 3:50 PM, urn wrote:
[...]

> on-list that none of it should be a surprise.

This is a brief comment on -15, not really a thorough review... For answers to John's specific questions, see below.

§5 URN Namespaces, paragraph 3 ("With regard to ...").
The example of a publication having both an ISBN and an ISSN is not quite correct, since the ISSN is not identifying a single publication but a series of publications. It might be better to use ISBN and NBN instead. Suggested text:

[[
For example, if a publisher assigns an ISBN to an electronic publication and that publication is later ingested into a digital long term archive operated by a national library, the library might assign the publication a NBN, resulting in two URNs referring to the same book.
]]

> reflected in the NID/ Namespace registration specifications.

I find the template accurate.

> be happy having them go through under the new procedure?

I think so.

> ABNF changes and/or text.

Looking at it from the outside, I'd say yes. I should add, however, that I haven't tried to actually write software to handle those so I cannot say if the syntax allows ambiguities.

> and, if possible, propose text.

I think the spec is clear enough. But as said, I haven't tried to write software to handle 2141bis URNs...

Thanks for all the hard work!

Best,

Lars

---

From: John C Klensin <[email-masked]>
Date: Wed, 24 Feb 2016 15:56:36 -0500

--On Wednesday, February 24, 2016 15:44 +0000 "Svensson, Lars"
<[email-masked]> wrote:

>...
> This is a brief comment on -15, not really a thorough
> review... For answers to John's specific questions, see below.
> 
> The example of a publication having both an ISBN and an ISSN
> is not quite correct, since the ISSN is not identifying a
> single publication but a series of publications. It might be
> better to use ISBN and NBN instead. Suggested text:
> 
> [[
> For example, if a publisher assigns an ISBN to an electronic
> publication and that publication is later ingested into a
> digital long term archive operated by a national library, the
> library might assign the publication a NBN, resulting in two
> URNs referring to the same book. ]]

I think, given "monograph series" and "referring to", the draft
is strictly correct, but your suggestion is probably an
improvement and definitely less confusing.  Changed in working
copy.

Thanks for checking on the other questions and for the
read-through in general.

   john