Subject: Re: [urn] URN:META namespace registration request

From: [email-masked] (Dale R. Worley)
Date: Thu, 05 Mar 2020 23:06:55 -0500

I probably ought to give some motivation for writing so much about
resolution mechanisms in my recent review.  My impression, upon reading
the second version, was that the resolution mechanism was truly an
important part of this proposal, as that's the real value-added for
using URN's to identify metadata fields.  And the long series of
examples at the end seems to be about resolving URNs.

And in that regard, all the words I added about resolver base URLs is
enunciating the infrastructure that the examples seem to be
presupposing.

It is an extension to state that resolver base URLs need to be
registered with the National Library of Finland.  But really, you can't
make the resolution services work unless there's a central point for
distributing what the resolvers are.  And the National Library is
already handling the bookkeeping for these URNs.

There's one further point.  I have a sense I've seen some discussion of
it, but I can't remember the details.  So you may have already sent a
response to this.  The point is that the grammar for URN:META is

    meta-nss    = prefix "-" meta-string

    prefix      = format-code *( ":" subspc )

However, the general usage in URNs is that colons are "higher-level"
separators than hyphens.  So the more expected grammar is

    meta-nss    = prefix ":" meta-string

    prefix      = format-code *( "-" subspc )

which gives examples like "urn:meta:dc-new:title".

And indeed, the examples written in the second version have the latter
format, not the format documented in the draft.

Dale

---

From: "Hakala, Juha E" <[email-masked]>
Date: Tue, 10 Mar 2020 11:43:50 +0000

Hello Dale; all, 

sorry for being late; last two weeks have been hectic. 

Please find attached a heavily revised version of the URN:META namespace registration request. 

Your comments have been very useful. Almost all of them have been taken into account. The exception is the registration database for format codes. I believe establishing a database for this purpose may be overkill since many (or perhaps even most) relevant metadata formats are already included in the registration request. If and when new ones are included, they can be added into this document. However, if this is not a sufficient solution my library may establish a web page of format codes, linked to the registration.

I added some guidance on when metadata format application profiles may request their own codes. Such guidance applies mainly to Dublin Core which has a large number profiles, some well established and known, some less so. 

The process of resolution has been revised according to the guidelines you gave. I have also provided more information about additional resolution services which may be provided, and benefits which may be achieved via implementing these URNs. 

 All the best, 

Juha

-----Alkuperäinen viesti-----
Lähettäjä: Dale R. Worley <[email-masked]> 
Lähetetty: perjantai 6. maaliskuuta 2020 6.07
Vastaanottaja: Hakala, Juha E <[email-masked]>; [email-masked]; Suominen, Osma I <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Aihe: Re: [urn] URN:META namespace registration request

I probably ought to give some motivation for writing so much about resolution mechanisms in my recent review.  My impression, upon reading the second version, was that the resolution mechanism was truly an important part of this proposal, as that's the real value-added for using URN's to identify metadata fields.  And the long series of examples at the end seems to be about resolving URNs.

And in that regard, all the words I added about resolver base URLs is enunciating the infrastructure that the examples seem to be presupposing.

It is an extension to state that resolver base URLs need to be registered with the National Library of Finland.  But really, you can't make the resolution services work unless there's a central point for distributing what the resolvers are.  And the National Library is already handling the bookkeeping for these URNs.

There's one further point.  I have a sense I've seen some discussion of it, but I can't remember the details.  So you may have already sent a response to this.  The point is that the grammar for URN:META is

And indeed, the examples written in the second version have the latter format, not the format documented in the draft.

Dale