Subject: Re: [urn] Namespace application v2: reso

From: [email-masked]
Date: Tue, 21 Apr 2020 11:13:13 +0200

Hi Sam,

looking at your resubmission and the comments by Dale and Juha, I think this registration still needs some work.

1) I agree with Dale that saying that the syntax of the reso-URNs is the same as specified by RFC 8141 is not of much help when someone tries to understand what the different segments of the URN actually mean. From the "examples of proposed use" it seems that you intend to have different branches underneath the NID (you mention "ulid", "recorder" etc.) that would correspond with the "resource classes" mentioned under "assignment". That means that the syntax would be "urn:reso:<resourceClass>:<resourceClassSpecificString>" or something along those lines. And if you intend to publish a registry of those subdivisions somewhere, an explanation and a reference to that registry would be great (I understand that this already applies to the RESO Data Dicstionay Items).

2) I also stumbled over the use of experimental URNs in the RESO namespace. Here you refer to RFC 6963 where it says that

it is NOT RECOMMENDED for implementers to use example URNs
for any purposes other than documentation, private testing, and truly
experimental contexts

[1]. If the use is supposed to be trule experimental, I'd discourage to use URNs from the reso namespace in favour of using urn:example. That would keep confusion at a minimum.

[1] https://tools.ietf.org/html/rfc6963#section-3.6

Best,

Lars

Gesendet: Sonntag, 08. März 2020 um 17:58 Uhr

Von: "Sam DeBord" <[email-masked]>

An: [email-masked]

Cc: "Joshua Darnell" <[email-masked]>

Betreff: [urn] Namespace application v2: reso

Please see resubmission of namespace application below.

Sam DeBord

CEO | RESO - Real Estate Standards Organization

[email-masked] | 206.658.3225

--

Namespace Identifier:

reso

Version:

0.1

Date:

2020-03-08

Registrant:

Real Estate Standards Organization

Sam DeBord, CEO

[email-masked] – 919.504.9898

Purpose:

The Namespace Identifier (NID) "reso" for Uniform Resource Names

(URNs) will be used to identify resources published by Real Estate Standards Organization: RESO <https://reso.org>.

These might include published standards or protocols that RESO

defines and that make use of URNs.  These namespaces are globally unique.  The URN namespace will be used in public networks by clients to configure and manage resources in the network.  Servers will enforce the uniqueness of the namespaces by using the namespace and the XPath associated with the managed node in the network when accessing a resource.

Examples of proposed uses:

Representation of Unique Licensee IDs: These will have the form of urn:reso:ulid:x, where x is a specific licensee identifier. Licensees can be people like Agents, photographers, appraisers, and others involved in the transaction.

Recorder IDs: These are part of an event model proposal, in which the URN will take a form of urn:reso:recorder:org:x, where org is an organization id well-known to RESO and x is identifier of the recording entity in that organization.

References to RESO Data Dictionary items: These are already established in our ecosystem. This link shows the "Property" resource, which consists of fields and enumerations. Each field has a RESO-generated RecordID associated with it (or LookupID in the case of enumerated values). For example, the PropertySubType field has a RecordID of 100222, and one of the allowed values for that field is Apartment, which is part of Lookup Field ID 302000 and has LookupID 302001. These would have URNs of the form: urn:reso:rid:100222, urn:reso:lfid:302000, and urn:reso:lid:302001, respectively.

Syntax:

The syntax of Namespace Specific Strings for the "reso" namespace

is <NSS> in Uniform Resource Names (URNs) [RFC8141].

The entire URN is case-insensitive.

Assignment:

RESO will maintain the list of registered resources that use the

"reso" NID in the "RESO URN Namespace" standards at

<https://www.reso.org/>.

The RESO workgroups describe the <NSS>, how namespaces will be allocated, and how experimental namespaces can

be used within the allocated URN.

RESO will manage resource classes using the "reso" NID and will be

the authority for managing resources and associated subsequent

strings.  RESO will guarantee the uniqueness of the strings by

validating them against the existing content of the standards.

RESO may also permit secondary responsibility for certain defined

resources.  Once a subtree assignment is made, it cannot be

deleted or reassigned.

RESO may allow use of experimental type values in specific

subtrees for testing purposes only.  Note that using experimental

types may create collision as multiple users may use the same

values for different resources and specific strings.  All

experimentation must follow the guidance set forth in "A Uniform

Resource Name (URN) Namespace for Examples" [RFC6963].

Security and Privacy:

There are no additional security considerations other than those

normally associated with the use and resolution of URNs in general.

Interoperability:

There are no known interoperability issues at this time.

Resolution:

It is not foreseen that URNs within this namespace will undergo

resolution.

Documentation:

Documentation can be found at

<https://www.reso.org>

_______________________________________________ urn mailing list [email-masked] https://www.ietf.org/mailman/listinfo/urn

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 23 Apr 2020 22:03:55 -0400

Sorry about not responding to this sooner.

>    Documentation can be found at

I went to this URL, and didn't find any documentation about URNs,
although I didn't spend much time on searching.  If you intend to have a
URN system, it would help to fix a URL that goes directly to where you
record comprehensive information about the URNs.  This might be a
natural extension of your existing Data Dictionary Wiki.

I can see a way forward by taking your examples and writing them up as
specifications in the wiki:  What is the overall structure of reso URNs?
What categories do they come in?  How are licensee IDs constructed?  How
are recorder organization and entity IDs constructed?  What is the
system for constructing URNs for Data Dictionary items?

Dale