Subject: Re: [urn] Namespace Identifier: UPDATE Request

From: Elena Nikitina <[email-masked]>
Date: Mon, 14 Mar 2022 09:57:24 +0000

Dear Dale,

Following your explanation below, I filled in the form and submitted it to [email-masked] but unfortunately there was still no reply or confirmation of the update. I attached the e-mail as evidence.

Could you please advise me further at this stage in case some additional input is required from my side in order to avoid any blocking points for this process.

Thank you in advance for your time and support!

KR
Elena

-----Original Message-----
From: Dale R. Worley <[email-masked]>
Sent: 19 February 2022 22:33
To: Elena Nikitina <[email-masked]>
Cc: [email-masked]; Dr. Chavdar Ivanov <[email-masked]>; Kristjan Vilgo <[email-masked]>
Subject: Re: [urn] Namespace Identifier: UPDATE Request

Elena Nikitina <[email-masked]> writes:
> Please find attached the completed update request for EIC. There was
> an update on ENTSO-E side regarding the documentation we were
> referring to in the description of the registration for Energy
> Identification Coding Scheme (EIC). EIC_Reference_Manual_Release was
> updated to version 5.5 and it has to be also updated in the below
> mentioned link. In the attachment you will find our updated request.

Given that the EIC namespace has been officially registered (see its entry in https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Furn-namespaces%2Furn-namespaces.xhtml%23urn-namespaces-1&amp;data=04%7C01%7Celena.nikitina%40ext.entsoe.eu%7Cd213e2e6d60a47c7a12308d9f3ef76d4%7C7ffbeccf0c1b496c897889209c2d375d%7C0%7C0%7C637809032113000569%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=rCYI22gJUfwERdypfWqZKnWCngaGaLheQc%2FWIMIT3JI%3D&amp;reserved=0),
and this template has differences from the registered template, the proper action is to (1) update eic-template_UPDATE 17.02.2022.txt to have "Version: 2" and the appropriate Date, then (2) submit it [email-masked] for approval.  (3) Approval should be immediately forthcoming and then (4) it will be passed to IANA to update the registration.

Dale
This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden. ENTSO-E processes your personal data in accordance with the ENTSO-E privacy policies which are available
here<https://www.entsoe.eu/website/privacy-policy/>

Subject: Namespace Identifier: Formal Update Request for EIC
From: Elena Nikitina <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Fri, 25 Feb 2022 06:30:25 +0000

Dear Sir or Madam,

Please find attached the completed registration request for EIC.

Thank you in advance for your time and consideration!

Best Regards,

Elena

Elena Nikitina

ENTSO-E - IT PMO

ENTSO-E

1000 Brussels, Belgium

Mobile +32 473 82 07 94

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Mar 2022 09:47:37 -0600

Hi Elena,

After converting your .docx file to a text file matching the format of 
the existing registration, I see that the only differences relate to the 
publication of version 5.5 of the reference manual.

Has the actual syntax changed or have you simply published a new version 
of the documentation?

If there are no syntax changes, I suggest that you and I work with IANA 
to modify the existing registration, because it is both inefficient and 
unnecessary to modify the registration every time EIC updates its 
reference manual.

Kind Regards,

Peter

On 3/14/22 3:57 AM, Elena Nikitina wrote:
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Mar 2022 09:50:21 -0600

Sorry, the last paragraph is not fully clear. It should have said:

"If there are no syntax changes, I suggest that you and I work with IANA 
to modify the existing registration, because it is both inefficient and 
unnecessary to increment the version of the namespace identifier every 
time EIC updates its reference manual."

My apologies for the confusion.

Peter

On 3/15/22 9:47 AM, Peter Saint-Andre wrote:
>> Following your explanation below, I filled in the form and submitted 
>> it to [email-masked] but unfortunately there was still no reply or 
>> confirmation of the update. I attached the e-mail as evidence.
>>
>> Could you please advise me further at this stage in case some 
>> additional input is required from my side in order to avoid any 
>> blocking points for this process.
>>
>> Cc: [email-masked]; Dr. Chavdar Ivanov <[email-masked]>; 
>> Kristjan Vilgo <[email-masked]>
>> Given that the EIC namespace has been officially registered (see its 
>> entry in 
>> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Furn-namespaces%2Furn-namespaces.xhtml%23urn-namespaces-1&amp;data=04%7C01%7Celena.nikitina%40ext.entsoe.eu%7Cd213e2e6d60a47c7a12308d9f3ef76d4%7C7ffbeccf0c1b496c897889209c2d375d%7C0%7C0%7C637809032113000569%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=rCYI22gJUfwERdypfWqZKnWCngaGaLheQc%2FWIMIT3JI%3D&amp;reserved=0), 
>>
>> and this template has differences from the registered template, the 
>> proper action is to (1) update eic-template_UPDATE 17.02.2022.txt to 
>> have "Version: 2" and the appropriate Date, then (2) submit it 
>> [email-masked] for approval.  (3) Approval should be immediately 
>> forthcoming and then (4) it will be passed to IANA to update the 
>> registration.
>>
>> Dale
>> This e-mail may contain confidential and/or privileged information. If 
>> you are not the intended recipient (or have received this e-mail in 
>> error) please notify the sender immediately and destroy this e-mail. 
>> Any unauthorized copying, disclosure or distribution of the material 
>> in this e-mail is strictly forbidden. ENTSO-E processes your personal 
>> data in accordance with the ENTSO-E privacy policies which are available

---

From: Elena Nikitina <[email-masked]>
Date: Tue, 15 Mar 2022 15:51:24 +0000

Dear Peter,

My first request for the update was just a simple request to change the version of the document but Dale replied to me that I need to follow the process in the exact same way as before with the according form and change the form version from 1 to 2 and put my updates inside.

KR
Elena

-----Original Message-----
From: Peter Saint-Andre <[email-masked]>
Sent: 15 March 2022 16:48
To: Elena Nikitina <[email-masked]>; Dale R. Worley <[email-masked]>
Cc: Dr. Chavdar Ivanov <[email-masked]>; [email-masked]; Kristjan Vilgo <[email-masked]>; svein Harald Olsen <[email-masked]>
Subject: Re: [urn] Namespace Identifier: UPDATE Request

Hi Elena,

After converting your .docx file to a text file matching the format of the existing registration, I see that the only differences relate to the publication of version 5.5 of the reference manual.

Has the actual syntax changed or have you simply published a new version of the documentation?

If there are no syntax changes, I suggest that you and I work with IANA to modify the existing registration, because it is both inefficient and unnecessary to modify the registration every time EIC updates its reference manual.

Kind Regards,

Peter

On 3/14/22 3:57 AM, Elena Nikitina wrote:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> iana.org%2Fassignments%2Furn-namespaces%2Furn-namespaces.xhtml%23urn-n
> amespaces-1&amp;data=04%7C01%7Celena.nikitina%40ext.entsoe.eu%7Cbc4ddb
> ee00cd4aad50cc08da069b269e%7C7ffbeccf0c1b496c897889209c2d375d%7C0%7C0%
> 7C637829560691648235%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQI
> joiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=RUKIgqAnDw6
> ZH8YjNwwzcDkY288PYolzdA8sVIUpYDU%3D&amp;reserved=0),
> here<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2
> Fwww.entsoe.eu%2Fwebsite%2Fprivacy-policy%2F&amp;data=04%7C01%7Celena.
> nikitina%40ext.entsoe.eu%7Cbc4ddbee00cd4aad50cc08da069b269e%7C7ffbeccf
> 0c1b496c897889209c2d375d%7C0%7C0%7C637829560691648235%7CUnknown%7CTWFp
> bGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn
> 0%3D%7C3000&amp;sdata=kjV1gqeeBfR2LXMM0G7J39fQRn%2BWC6WDPMBYqhTz9AA%3D
> &amp;reserved=0>
>
>
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Furn&amp;data=04%7C01%7Celena.nikitina%
> 40ext.entsoe.eu%7Cbc4ddbee00cd4aad50cc08da069b269e%7C7ffbeccf0c1b496c8
> 97889209c2d375d%7C0%7C0%7C637829560691648235%7CUnknown%7CTWFpbGZsb3d8e
> yJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C30
> 00&amp;sdata=2M%2B2ksXO3H4RYMJTanEfa8NKYxBrrBeihqZ%2B2jrs1pw%3D&amp;re
> served=0

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Mar 2022 09:53:05 -0600

Yes, I understand. Dale might have been speaking as a matter of general 
policy and I'm not sure if if had a chance to look at the detailed diff, 
which is minimal and might be immaterial. Let me check with IANA and see 
how they would like to proceed.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 16 Mar 2022 18:05:07 -0600

Hi Elena,

I've checked with IANA and they do not think that we need to increment 
the version number. I've provided to them a modified text file for the 
registration and I expect that they will update it soon.

Peter

On 3/15/22 9:53 AM, Peter Saint-Andre wrote:
>> My first request for the update was just a simple request to change 
>> the version of the document but Dale replied to me that I need to 
>> follow the process in the exact same way as before with the according 
>> form and change the form version from 1 to 2 and put my updates inside.
>>
>> KR
>> Elena
>>
>> Cc: Dr. Chavdar Ivanov <[email-masked]>; [email-masked]; 
>> Kristjan Vilgo <[email-masked]>; svein Harald Olsen 
>> <[email-masked]>
>> the existing registration, I see that the only differences relate to 
>> the publication of version 5.5 of the reference manual.
>>
>> If there are no syntax changes, I suggest that you and I work with 
>> IANA to modify the existing registration, because it is both 
>> inefficient and unnecessary to modify the registration every time EIC 
>> updates its reference manual.
>>
>> Kind Regards,
>>
>> Peter
>>

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 16 Mar 2022 21:54:11 -0400

> form and change the form version from 1 to 2 and put my updates

My apologies for not looking at the update request more closely before
answering.  I agree with Peter et al. that if the only change is to
references in the registration, there is no need to change the formal
version number of the registration.

Dale

---

From: "Hakala, Juha E" <[email-masked]>
Date: Thu, 17 Mar 2022 06:54:21 +0000

Hello,

I agree with Peter and Dale; there is no need to increment the URN namespace registration version number.

ENTSOE seems to have a rigorous system for maintaining the version and release of the EIC Reference Manual, and documentation of the changes made is exhaustive. The change made this year is small, but in the past changes have been substantial (in e.g. version 4, which extended the EIC coverage to new objects).

However, EIC URN namespace registration is quite generic; for instance, the list of objects that can be  identified is not exhaustive. Therefore even major updates such as version 3 -> version 4 of the Reference Manual may not require modification of the actual content of the URN namespace registration. Only the version number has to be changed, every time the Reference Manual is updated. And even this task can be eliminated if you drop the version number from syntax and assignment specifications and delete the URI of the Reference Manual (it is accessible also via the link https://www.entsoe.eu/data/energy-identification-codes-eic/.

All the best,

Juha

BTW, you still need to change the version number from 5.4 to 5.5 on the top of the EIC Reference Manual pages 😊.

-----Alkuperäinen viesti-----

Lähettäjä: urn <[email-masked]<mailto:[email-masked]>> Puolesta Dale R. Worley

Lähetetty: torstai 17. maaliskuuta 2022 3.54

Vastaanottaja: Elena Nikitina <[email-masked]<mailto:[email-masked]>>

Kopio: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Aihe: Re: [urn] Namespace Identifier: UPDATE Request

> form and change the form version from 1 to 2 and put my updates

> inside.

My apologies for not looking at the update request more closely before answering.  I agree with Peter et al. that if the only change is to references in the registration, there is no need to change the formal version number of the registration.

Dale

urn mailing list

[email-masked]<mailto:[email-masked]>