Subject: Re: [Uta] Proposed list of deliverables

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Feb 2014 10:35:35 -0700

On 1/20/14, 4:51 AM, Alexey Melnikov wrote:
> Hi,
> This looks sensible, but I am trying to figure out how existing drafts
> fit into this plan.
>
> On 18/01/2014 06:24, Orit Levin (LCA) wrote:
>> Below is the list of deliverables for your consideration:
>>
>> 1. A threat analysis document containing a collection of known
>> security breaches to application protocols due to poor use of TLS
>> (Likely an Informational RFC)
>> 2. Applications' independent document recommending best existing and
>> future practices for using TLS (Likely a BCP or a Proposed Standard RFC)
>> 3. A set of documents, each describing best existing and future
>> practices for using TLS with a specific application protocol, i.e.,
>> SMTP, POP, IMAP, XMPP, HTTP 1.1, etc. (Case-by-case likely a BCP or a
>> Proposed Standard RFC)
> It sounds like the following 2 would cover this for SMTP/POP/IMAP:
>
> http://datatracker.ietf.org/doc/draft-melnikov-email-tls-certs/
> http://datatracker.ietf.org/doc/draft-moore-email-tls/
>
> (Some pieces of draft-newman-email-deep might apply here as well).

Alexey, I'm curious about the status of those documents. Have the 
authors had a chance to discuss approaches to merging or harmonizing 
them to some extent?

Thanks!

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Feb 2014 10:42:25 -0700

On 1/20/14, 5:58 AM, Paul Hoffman wrote:

> This needs to be defined more. The phase "using TLS" can mean one or more of:

Hi Paul, thanks for the complete list. :-)

> - TLS with server authentication, with encryption

What many people currently think of as using TLS, I'd imagine.

> - TLS with server authentication, without encryption

Given the perpass world we live in, is that a goal here?

> - TLS without server authentication, with encryption

Can we agree to call that "unauthenticated encryption"?

> - TLS with server authentication, with client authentication, with encryption
> - TLS with server authentication, with client authentication, without encryption
> - TLS without server authentication, with client authentication, with encryption

Given the infrequency of client authentication, personally I don't think 
about those scenarios very much.

So IMHO #1 and #3 are of great interest, whereas #2 and #4-#6 are of 
less interest at this time.

Just my centigram of silver...

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Feb 2014 10:49:08 -0700

> (Likely an Informational RFC)

I think this would be something like an expanded version of Section 2 
from draft-sheffer-tls-bcp.

> future practices for using TLS (Likely a BCP or a Proposed Standard

I think draft-sheffer-tls-bcp is a good starting point for this deliverable.

> SMTP, POP, IMAP, XMPP, HTTP 1.1, etc. (Case-by-case likely a BCP or a

I think we have some starting point documents toward documents about 
SMTP, POP/IMAP, and XMPP. It's not clear to me what we have for HTTP.

> 4. A document discussing (and potentially defining) how to apply the
> opportunistic encryption approach (preliminary outlined in
> draft-farrelll-mpls-opportunistic-encrypt-00.txt) to TLS. (Category
> TBD)

Personally I'm agnostic about the need for this one.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Mon, 3 Feb 2014 18:41:51 +0000

Peter,
This fits well with the spirit of the proposed deliverables (plus a few notes inline).
Orit.

> -----Original Message-----
> From: Uta [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
> Sent: Monday, February 03, 2014 9:49 AM
> To: Orit Levin (LCA); [email-masked]
> Cc: Pete Resnick; Barry Leiba
> Subject: Re: [Uta] Proposed list of deliverables
> 
Yes.

> I think draft-sheffer-tls-bcp is a good starting point for this deliverable.

More specifically, section 4 of this draft "enriched" with the recent discussion points and recommendations from the list.

> SMTP, POP/IMAP, and XMPP. It's not clear to me what we have for HTTP.

A question to explore would be how HTTP considerations differ from the generic considerations in #2.

> Personally I'm agnostic about the need for this one.

Broader discussion and agreement is needed before we know how to scope this in UTA.

> 
> Peter
> 
> --
> Peter Saint-Andre
> https://stpeter.im/
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Feb 2014 11:53:08 -0700

On 2/3/14, 11:41 AM, Orit Levin (LCA) wrote:

>>> 2. Applications' independent document recommending best existing
>>> and future practices for using TLS (Likely a BCP or a Proposed
>>> Standard RFC)
>>
> More specifically, section 4 of this draft "enriched" with the recent
> discussion points and recommendations from the list.

IMHO we might want to address a slightly wider range of topics, or at 
least organized the current information so it's a bit easier to find 
particular recommendations about things like certificate validation, key 
length, unauthenticated encryption, SNI, compression, session 
resumption, etc. Actually it would be good to have a list of the topics 
about which we want to have recommendations, too

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Mon, 3 Feb 2014 18:57:35 +0000

Agreed 100%. 
The question now is, would Yaron and/or you take the lead and come up with a specific proposal (or better a new version) in the next few days?
Orit.

> From: Peter Saint-Andre [mailto:[email-masked]]
> Sent: Monday, February 03, 2014 10:53 AM

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Feb 2014 12:27:02 -0700

> The question now is, would Yaron and/or you take the lead and come up with a specific proposal (or better a new version) in the next few days?

Yes, we'll chat about that during our call tonight.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Mon, 3 Feb 2014 19:31:37 +0000

Great!!!
We all are looking forward to the conclusions from this discussion! :-)
Orit.

> Sent: Monday, February 03, 2014 11:27 AM
> > The question now is, would Yaron and/or you take the lead and come up with
> a specific proposal (or better a new version) in the next few days?
>

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 03 Feb 2014 17:59:09 -0800

Peter, I agree with the scope you propose. Let's discuss it in our talk.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 04 Feb 2014 10:18:58 -0700

Here is a brief summary of what we agreed to:

1. Yaron and Peter will work together on a revised version of 
draft-sheffer-tls-bcp for consideration by the group. The focus will be 
on describing the recommendations so that they can be easily understood 
both by those who implement software and by those who deploy services.

2. Yaron will move Section 2 of draft-sheffer-tls-bcp-01 to a new I-D 
describing threats and attacks against TLS.

2. Peter will update draft-saintandre-xmpp-tls to mostly reference 
draft-sheffer-tls-bcp and, hopefully, serve as something of a template 
for I-Ds covering other application protocols.

Our goal is to come to agreement among the authors on these documents by 
the end of the week, and to publish revised I-Ds soon thereafter.

Peter

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Tue, 4 Feb 2014 17:26:13 +0000

Sounds like a very good progress.
Thank you for keeping us all in the picture,
Orit.

> Sent: Tuesday, February 04, 2014 9:19 AM