Subject: [Uta] UTA in HTTP

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 24 Feb 2014 17:30:55 -0700

We haven't discussed HTTP much if at all. A few Internet-Drafts seem 
relevant since they touch on some UTA-related topics such as mandatory 
to implement crypto algorithms. See especially:

* Minimal Unauthenticated Encryption (MUE) for HTTP/2
 
https://datatracker.ietf.org/doc/draft-hoffman-httpbis-minimal-unauth-enc/

* Applying Unauthenticated Transport Layer Security (TLS) to Hypertext 
Transport Protocol (HTTP) Connections
   https://datatracker.ietf.org/doc/draft-miller-http-unauth-tls/

I'm sure the authors would appreciate feedback from folks active in the 
UTA WG. I'd be especially curious to know if any of the issues raised in 
those documents might need to be addressed in the tls-bcp document 
(e.g., draft-miller-http-unauth-tls talks about caching the results of 
attempting a TLS connection at a given web origin).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 24 Feb 2014 16:58:50 -0800

On Feb 24, 2014, at 4:30 PM, Peter Saint-Andre <[email-masked]> wrote:

> We haven't discussed HTTP much if at all. A few Internet-Drafts seem relevant since they touch on some UTA-related topics such as mandatory to implement crypto algorithms. See especially:
> 

No, don't. This is *not* TLS at all. I put it out there when some people were complaining about the round-trip overhead of TLS to show people what could be done without TLS. People said they would rather have TLS

> * Applying Unauthenticated Transport Layer Security (TLS) to Hypertext Transport Protocol (HTTP) Connections

In this document, Matt looks specifically at "unauthenticated" in light of HTTP. In draft-hoffman-uta-opportunistic-tls, I discuss both opportunistic and unauthenticated TLS without tying them to specific application protocols.

--Paul Hoffman