Subject: Re: [Uta] Comments on draft-ietf-uta-mta-sts-03

From: Daniel Margolis <[email-masked]>
Date: Wed, 1 Mar 2017 12:47:43 +0100

Sounds like we go back to underscore-prefixed. Thanks for the feedback
John.

On Wed, Mar 1, 2017 at 5:55 AM, John Levine <[email-masked]> wrote:

> In article <[email-masked]> you
> write:
> >3.1. MTA-STS TXT records
> >
> >There is no IANA registry for reserved hostnames, which is why protocols
> >like SPF store their policies at the domain itself.
>
> Urrgh.  SPF is as far as I know the only protocol published by the
> IETF that stores policies at the unprefixed hostname, and that is
> widely agreed to be a mistake.  DKIM and DMARC use prefixes.
>
> There's the somewhat separate issue that if the prefixed name has to
> be a hostname so it can be used in a URI, it can't contain an
> underscore.
>
> R's,
> John
>
> PS: Dave Crocker and I have been working on a prefix registry, but
> it's a thankless task.
>
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta
>

---

From: [email-masked]
Date: Wed, 01 Mar 2017 11:57:47 -0800 (PST)

Please post a revised draft with these changes sooner rather than later.
Thanks.

				Ned