Subject: [Uta] Wrapping up draft-ietf-uta-smtp-require-tls-05

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 4 Dec 2018 18:00:27 +0300

Hi,

while preparing shepherd write-up for the draft I came across 
one issue. IANA Considerations section contains the following text:

   If published as an RFC, this draft requests the addition of an entry
   to the Permanent Message Header Field Names Registry
   [PermMessageHeaderFields]:

   Header field name:          RequireTLS
   Applicable protocol:        mail
   Status:                     provisional
   Author/change controller:   IETF UTA Working Group
   Specification document:     (this document)

I'm not familiar with Message Header Field Names Registry,
but it seems to me that this request is wrong. In particular, 
according to RFC 3864 the status for the Permanent Fields must be one of 
"standard", "experimental", "informational", "historic", "obsoleted", etc.,
but not "provisional", which is only appropriate for the 
Provisional Message Header Fields. I think that in this case 
it must be "standard", since the draft is Standards Track document.

In addition, the Change controller must be just "IETF"
(again, according to RFC 3864).

Am I missing something?

And note also a small typo in Section 2:
s/succesfully/successfully

Regards,
Valery.

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 4 Dec 2018 15:11:20 +0000

Hi Valery,

> it must be "standard", since the draft is Standards Track document.
I agree.
> (again, according to RFC 3864).
Yes.
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta

---

From: Jim Fenton <[email-masked]>
Date: Tue, 4 Dec 2018 08:31:45 -0800

OK; shall I do an update or wait for more comments?

-Jim

---

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 4 Dec 2018 19:52:40 +0300

Hi Jim,

please, publish an updated version of the draft. I found no more issues.

Regards,
Valery.

-----Original Message----- 
From: Jim Fenton
Date: 4 декабря 2018 г. 19:31
To: Alexey Melnikov ; Valery Smyslov ; [email-masked]
Subject: Re: [Uta] Wrapping up draft-ietf-uta-smtp-require-tls-05

-Jim