Subject: [Uta] High level comments on draft-ietf-uta-use-san

From: John Mattsson <[email-masked]>
Date: Thu, 27 May 2021 10:51:36 +0000

Hi,

Some sections mention "server" while other sections does not state anything, therefor applying to both client and server. I think the draft needs to be very clear on this point.

I saw that there was a discussion on client certs and that some client certs are built with CN and cannot be easily changed. Other uses of RFC 6125 like the Service Based Architecture in 3GPP 5G makes little or no difference between server and client when it comes to certificates.

Cheers,
John

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 27 May 2021 14:57:03 +0000

*   Some sections mention "server" while other sections does not state anything, therefor applying to both client and server. I think the draft needs to be very clear on this point.

  *   I saw that there was a discussion on client certs and that some client certs are built with CN and cannot be easily changed. Other uses of RFC 6125 like the Service Based Architecture in 3GPP 5G makes little or no difference between server and client when it comes to certificates.

Thanks for reading it!  The current plan is to produce a stand-alone 6125bis, rather than the current diff/patch document. I’ll try to make sure these issues are cleared up.