Subject: [v4tov6transition] two questions about address allocation while designing

From: Tina TSOU <[email-masked]>
Date: Mon, 23 Aug 2010 12:31:38 +0800

Hi all,

Two questions about address allocation while designing come to my mind.

1. Allocation of IPv6 unicast Global-Unique-Address (GUA)

At BBF it is suggested that HGW should be assigned with a /56 IPv6 prefix, and a host should be assigned with a /64 IPv6 prefix.

Is there any standard discussing this at IETF?

2. Allocation of IPv6 multicast address

 Would IPv6 multicast address be used as a link-local-address/private address, just as IPv4 private address (defined in RFC1918), or should there be an origination, like IANA, to manage IPv6 multicast address space and keep it in a hierarchical structure, same as what we do for IPv6 GUA?

Maybe it is not so reasonable if IPv6 multicast address is not managed, after all it is such a huge address space which covers 112bits.  

B. R.
Tina
http://tinatsou.weebly.com/index.html

---

From: Fred Baker <[email-masked]>
Date: Mon, 23 Aug 2010 00:43:35 -0700

> Is there any standard discussing this at IETF?

A host shouldn't be assign a prefix; a host should be assigned an address per interface - /128. /64's are intended for LAN Subnets. RFC 4291.

---

From: Tina TSOU <[email-masked]>
Date: Mon, 23 Aug 2010 18:41:07 +0800

Oops, I was typing too rashly. I meant the HWG would advertise /64 IPv6 prefix to the hosts.

B. R.
Tina
  ----- Original Message ----- 
  From: Fred Baker 
  To: Tina TSOU 
  Cc: [email-masked] 
  Sent: Monday, August 23, 2010 3:43 PM
  Subject: Re: [v4tov6transition] two questions about address allocation while designing

    Hi all,

---

From: Fred Baker <[email-masked]>
Date: Mon, 23 Aug 2010 08:16:59 -0700

What is an HWG?

---

From: Tina TSOU <[email-masked]>
Date: Mon, 23 Aug 2010 23:19:53 +0800

Typo.
HWG --> HGW (Home GateWay)

B. R.
Tina

On Aug 23, 2010, at 11:16 PM, Fred Baker wrote:

>>> At BBF it is suggested that HGW should be assigned with a /56 IPv6  
>>> prefix, and a host should be assigned with a /64 IPv6 prefix.
>> A host shouldn't be assign a prefix; a host should be assigned an  
>> address per interface - /128. /64's are intended for LAN Subnets.  
>> RFC 4291.
>>
>>
>>
>>
>

---

From: Victor Kuarsingh <[email-masked]>
Date: Mon, 23 Aug 2010 11:21:10 -0400

Fred,

I think she meant  HGW (Home Gateway).  Letters appear misplaced.

Victor

On 23/08/10 11:16 AM, "Fred Baker" <[email-masked]> wrote:

>>> From: Fred Baker <mailto:[email-masked]>
>>> To: Tina TSOU <mailto:[email-masked]>
>>>> At BBF it is suggested that HGW should be assigned with a /56 IPv6 prefix,
>>>> and a host should be assigned with a /64 IPv6 prefix.
>>> A host shouldn't be assign a prefix; a host should be assigned an address
>>> per interface - /128. /64's are intended for LAN Subnets. RFC 4291.
>>>  
>>>  
>>> 
>> 
> 
> 
> 
> _______________________________________________
> v4tov6transition mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v4tov6transition

 ---------------------------------------------------------------------------
   Victor Kuarsingh
   IP Architect, Network Technology
   Rogers Communications Inc
   Business: 647-747-1785
   Mobile: 647-338-1533
   [email-masked]
 ---------------------------------------------------------------------------
-

This e-mail (and attachment(s)) is confidential, proprietary, may be subject to copyright and legal privilege and no related rights are waived. If you are not the intended recipient or its agent, any review, dissemination, distribution or copying of this e-mail or any of its content is strictly prohibited and may be unlawful. All messages may be monitored as permitted by applicable law and regulations and our policies to protect our business. E-mails are not secure and you are deemed to have accepted any risk if you communicate with us by e-mail. If received in error, please notify us immediately and delete the e-mail (and any attachments) from any computer or any storage medium without printing a copy.

Ce courriel (ainsi que ses pièces jointes) est confidentiel, exclusif, et peut faire l’objet de droit d’auteur et de privilège juridique; aucun droit connexe n’est exclu. Si vous n’êtes pas le destinataire visé ou son représentant, toute étude, diffusion, transmission ou copie de ce courriel en tout ou en partie, est strictement interdite et peut être illégale. Tous les messages peuvent être surveillés, selon les lois et règlements applicables et les politiques de protection de notre entreprise. Les courriels ne sont pas sécurisés et vous êtes réputés avoir accepté tous les risques qui y sont liés si vous choisissez de communiquer avec nous par ce moyen. Si vous avez reçu ce message par erreur, veuillez nous en aviser immédiatement et supprimer ce courriel (ainsi que toutes ses pièces jointes) de tout ordinateur ou support de données sans en imprimer une copie.

---

From: Fred Baker <[email-masked]>
Date: Mon, 23 Aug 2010 08:32:53 -0700

we have too many names for these things... :-) in v6ops, it's being called a CPE Router, and in other venues its being called a residential gateway. I prefer calling it a "CPE Router" because the same router and the same infrastructure is often used for things that aren't homes - what are often called Small Office/Home Office (SOHO) networks (http://searchmobilecomputing.techtarget.com/definition/Small-Office-Home-Office). The next step up is often called Small/Medium Business or SMB (http://searchcio-midmarket.techtarget.com/sDefinition/0,,sid183_gci1005201,00.html), and would have a higher throughput and often higher cost version of the same CPE. 

I probably would have worked it out modulo the transposition. Thanks.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Aug 2010 13:07:08 +1200

So, if the CPE (HGW) is given a /56, surely it should be a local decision
what it advertises inside the home network? Today's reasonable default might
be to advertise a single /64, but the spec needs to be future-proof for people
who want to run multiple subnets and/or additional routers. Also, if the CPE has
several interfaces, it would need to advertise a /64 on each one.

Also of course it should probably advertise /64s out of a ULA prefix as well,
generated at the first power-on.

Regards
   Brian Carpenter

---

From: Fred Baker <[email-masked]>
Date: Mon, 23 Aug 2010 18:13:47 -0700

I would expect that each LAN is a /64 subnet. If you have a /56, you have options for up to 256 subnets. how they are laid out is up to you.