Subject: RE: draft-cmetz-v6ops-v4mapped-api-harmful-00.txt and draft-itojun-v6ops-v4mapped-harmful-01.txt

From: "Bound, Jim" <[email-masked]>
Date: Fri, 12 Sep 2003 16:44:28 -0400

We cannot deprecate usage of IPv4 Mapped Addresses for the API (not
speaking of the wire) they are deployed and part of RFC 3493 and IEEE
standard, and the API is widely deployed on all product platforms that
require APIs.  There are many uses for IPv4 Mapped Addresses and this
has been documented in the Netscape Mozilla code base and now in many
code bases.  An application may want to treat all addresses as IPv6
including IPv4 and how to do this is documented in RFC 3493.  The
product and most research implementors will not deprecate IPv4 Mapped
addresses because they have an important use in the industry and for
specific customers and research.  This has all been discussed before and
in the spirit of not raising this to insanity mail list responses I will
not respond further on this topic this week or maybe even next week
unless I hear something new and I did not.  Unless the Chairs
specifically ask me to respond.

Please do try to limit your messages on this mail list to 10-15 per
week.  Thank You.

/jim

> -----Original Message-----
> From: Mauro Tortonesi [mailto:[email-masked]] 
> Sent: Friday, September 12, 2003 8:12 AM
> To: Iljitsch van Beijnum
> Cc: [email-masked]
> Subject: Re: draft-cmetz-v6ops-v4mapped-api-harmful-00.txt 
> and draft-itojun-v6ops-v4mapped-harmful-01.txt 
> 
> 
> On Fri, 12 Sep 2003, Iljitsch van Beijnum wrote:
> 
> > On vrijdag, sep 12, 2003, at 11:33 Europe/Amsterdam, Mauro Tortonesi
> > wrote:
> >
> > > then my credo as a developer is "ipv6 is a brand new protocol", 
> > > because AF_INET6 sockets have many options that are not 
> applicable 
> > > to ipv4 connections, and writing applications that make 
> use of the 
> > > ipv4-mapped catch-all approach will be a great problem for 
> > > developers (that will find themselves writing __a lot__ of 
> > > checks/workarounds for special cases and
> > > will become crazy during the testing/debugging process).
> >
> > So what's the alternative? Ripping mapped addresses out of current 
> > implementations doesn't make sense for many reasons.
> 
> sure, but we could deprecate usage of ipv4-mapped addresses.
> 
> 
> > The only question is whether you should/want to use them. 
> If you want 
> > to do stuff with IPv6 that you can't do with IPv4, you'll 
> have to do a 
> > lot of checking regardless of how you do it.
> 
> yes, but they're always less than the checks you would do if 
> you were also supporting ipv4-mapped addresses.
> 
> 
> > If you feel using the IPv6 socket API for IPv6 and the IPv4 
> socket API 
> > for IPv4 makes more sense, then by all means, do it that 
> way. But for 
> > simple applications I think it's a huge plus to be able to 
> talk to the 
> > network in a unified way without having to spend time and effort on 
> > making the IPv4/IPv6 distinction. Obviously this means you can't do 
> > any IPv6-specific stuff.
> 
> this could be a plus only for for very simple apps where the 
> developers don't care for portability or robustness.
> 
> 
> > > moreover, i think that the ipv4-mapped catch-all approach in the 
> > > development of ipv6-enabled apps may eventually become an 
> obstacle 
> > > for widespread adoption of production quality 
> ipv6-enabled software 
> > > (since it makes more difficult the use of the advanced ipv6 
> > > capabilities)
> >
> > I don't agree. Just tell the stack you don't want to talk IPv4.
> 
> not all the stacks support IPv6_V6ONLY, yet.
> 
> 
> > Also, in the document I read it seems half or more of the trouble 
> > comes from mixing IPv4 and IPv6 calls. So don't do that.
> 
> actually, this is not true. in fact, half or more of the 
> trouble comes from the fact that nearly every stack has a 
> different bind(2) behaviour.
> 
> 
> -- 
> Aequam memento rebus in arduis servare mentem...
> 
> Mauro Tortonesi                 [email-masked]
>                                 [email-masked]
>                                 [email-masked]
> Deep Space 6 - IPv6 with Linux  http://www.deepspace6.net
> Ferrara Linux User Group        http://www.ferrara.linux.it
> 
> 
>

---

From: "Robson Oliveira" <[email-masked]>
Date: Fri, 12 Sep 2003 19:51:10 -0300

Mauro,

If does not have transistion, does not have ipv6 ;-|

Some tasks is hard and to send some messages to IETF too.

--robson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Bound, Jim
Sent: Friday, September 12, 2003 5:44 PM
To: Mauro Tortonesi; Iljitsch van Beijnum
Cc: [email-masked]
Subject: RE: draft-cmetz-v6ops-v4mapped-api-harmful-00.txt and
draft-itojun-v6ops-v4mapped-harmful-01.txt 

/jim

---

From: Mauro Tortonesi <[email-masked]>
Date: Mon, 15 Sep 2003 11:02:21 +0200 (CEST)

On Fri, 12 Sep 2003, Bound, Jim wrote:

> This has all been discussed before and in the spirit of not raising this
> to insanity mail list responses I will not respond further on this topic
> this week or maybe even next week unless I hear something new and I did
> not.  Unless the Chairs specifically ask me to respond.

you are free to do what you want.

> Please do try to limit your messages on this mail list to 10-15 per

<mode="very polite">
i am afraid you are not in the condition to ask me or any other person to
stop posting on this list. you are not my employer, you are not one of the
chairs and you are not even my father or my mother. and i am not jim
fleming, after all. i am only trying to give my contribute to the
discussion on this list by reporting my experience as an ipv6-enabled app
developer and by supporting itojun's and craig metz's point of view.
so what makes you think you have the right to shut me up?
</mode="very polite">

---

From: Mauro Tortonesi <[email-masked]>
Date: Mon, 15 Sep 2003 11:03:54 +0200 (CEST)

> If does not have transistion, does not have ipv6 ;-|

believe it or not, this is clear to me.

> Some tasks is hard and to send some messages to IETF too.

i am afraid i don't understand what you want to say here.

---

From: Pekka Savola <[email-masked]>
Date: Mon, 15 Sep 2003 13:28:47 +0300 (EEST)

Hello all,

Excuse me for trying to keep the discussion from getting out of hand..

Please keep in mind that we should not re-open the old "deprecate mapped
addresses or not" -discussion here _especially_ unless we have some
significant new information, or specific proposals.

Otherwise, it's likely that the mailing list would just be swamped for a
couple of weeks, nothing would get written up, everybody who preferred one
solution would still prefer that, and everybody else who would want
otherwise would be equally unmoved -- and no one would be wiser as the
end result.

For example, discussion on how to make the mapped addresses work well is
OK, but please change the subject title accordingly.  This subject title 
sound be discontinued for now.

Writing as WG co-chair,
 Pekka

> This has all been discussed before and

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings