Subject: RE: Numbers of NAT-s in IPv4/IPv6 Network? One or more?

From: <[email-masked]>
Date: Tue, 16 Sep 2003 08:36:36 +0200

> > (Then, you get into questions as to whether the multiple NATs are 
> > there for something simple like load balancing/fault 
> tolerance, or for 
> > something more complex like site multi-homing.)
> 
> marketed as load balancing / fault tolerance.
> 
> Besides the case of multiple NATs working "parallel", I have 
> also seen cases where multiple NATs where daisy-chained 
> (wireless network being NATted to the fixed in-house network, 
> which in turn was NATted to one outside IP).  Ugly, but real.

Dual NATs are also widely used in the home. If somebody buys first a
DSL/Cable modem/router (first NAT) and then adds a WLAN router (second
NAT) and doesn't change the default configuration then there are already
2 NATs. I guess that a lot of home users don't have the knowledge to
change default configurations and therefore have such a configuration.

Andreas

---

From: Bilajbegovic Damir <[email-masked]>
Date: Tue, 16 Sep 2003 09:32:23 +0200

There must be more than one NAT-PT (for my optimal case.)
Network is IMS (IMS is ipv6 only but there is some considering about
supporting IPv4 elements)

                     +---------------+      Public     
+-------+            |               |-----Internet IPv6
| IPv4  |     1)     |IPv6 IMS core  |
| User  |---NAT-PT---|    Network    |     3)
|equipm.|            |               |--NAT-PT--- Internet IPv4  
+-------+    ________|               |
+-------+   /        +---------------+ 
| IPv6  |  /             |         |
| User  |_/        2)  NAT-PT       \
|equipm.|                |           \
+-------+                |            \
                 +-------------+  +-------------+ 
                 |    IPv4     |  |    IPv6     |
                 | Application |  | Application |
                 |   Servers   |  |   Servers   |
                 +-------------+  +-------------+
                        \              /
                         \            /
                          \          /
                   They could also be on public internet

As you can se from the picture there are three groups of NAT-PT (every group
has number 1, 2 and 3). In every group NAT-PT should be redundant and with
some load balancing (in worst case it could be only one). 

But I am more concerned about having more places of putting such NAT-PT.
How will interact different groups of NAT-PT, 
1) NAT-PT will serve IPv4 users 
2) NAT-PT old application servers 
3) NAT-PT for users on the public internet
I know that it can be solved when we put only one NAT-PT in network, but it
won't be such nice solution.    

This scenario is not only restricted to IMS. There could be networks like
this in many solutions. All network which have more than one way to go to
public internet, and there is difference in IP protocols between networks.
Eg. Private corporate network is attached to the internet via two network
links, each from different ISP.
    
    Just to make question clear. 
             Damir Bilajbegovic

--- Fred Templin <[email-masked]> wrote:
> This is an interesting question, and I'm certainly no expert on
> the subject. But, in theory, couldn't there be more than one NAT
> if, e.g., the (multiple) NAT boxes communicated out-of-band
> to keep a consistent view of the aggregate state information?
> (Then, you get into questions as to whether the multiple NATs
> are there for something simple like load balancing/fault tolerance,
> or for something more complex like site multi-homing.)
> 
You might want to take a look at draft-park-scalable-multi-natpt--00.txt
that
proposes to do precisely that.

> I guess I don't have anything conclusive for you on this, but just
> to note that the "must" in your statement: "there must be only
> one NAT" may be a bit too strong.

I think so, as well.

> Bilajbegovic Damir wrote:
> >Case: local network connected to the public IP network
> >If I understood right, in normally network translation (local IPv4 to
public
> >IPv4), there must be only one NAT (simplest solution) at the border of
> >network. (NAT-PT and all necessarily ALG)
> >If there is translation between IPv4 intranet and IPv6 public network can
> >then be more than NAT-PT? (all intranet is IPv4, and all public is IPv6)
> >If you know the answer or you can direct me to some document I would be
> >grateful.
> >         Damir Bilajbegovic
> >P.S: In translation IPv4/IPv6 there is always translation, and nor IPv4
> >user, nor IPv6 server do not see directly each other, they see IPv4
address
> >which NAT gives to server, and IPv6 server sees IPv6 address of user by
> >which NAT represents user. Every packet will go directly to specific NAT
> >(the one who knows translation parameters of connection). So, I do not 
> > see any problem in translation. I'm I wrong.

---

From: Bilajbegovic Damir <[email-masked]>
Date: Tue, 16 Sep 2003 10:13:58 +0200

-----------------------------------------------
I say that picture did not appear as I think it would be do here it is again
in GIF format.

                     +---------------+      Public     

    

I think so, as well.

public
address

---

From: <[email-masked]>
Date: Tue, 16 Sep 2003 12:09:08 +0300

Hi,

there also seems to be cases where the ISP nats the internet access and the home user has multiple computers behind a NAT. In this case it is not only an accident, but done in purpose. Though, it as ugly if it is done on purpose or not.

Cheers,

Jonne.

> -----Original Message-----
> From: ext [mailto:[email-masked]]
> Sent: 16 September, 2003 09:37
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: Numbers of NAT-s in IPv4/IPv6 Network? One or more?
> 
>

---

From: <[email-masked]>
Date: Tue, 16 Sep 2003 13:48:38 +0300

Hi, Damir!

[commenting from the 3GPP IMS point of view...]

Your picture looks a bit peculiar to me, because this kind of "general" usage of NAT-PT has not been discussed, not especially in the 3GPP. I don't understand the usage of NAT-PT between the UE and the IMS (1); the correct solution here is to support IPv6 in the UE (that is accessing the (Rel5 or Rel6) IMS network). And what are those IPv4 application servers (2) that need to be contacted from the IMS?

In 3GPP Analysis document (IMS scenario 1), we talk about a special case: using a translator and SIP ALG to communicate with a small number of legacy IPv4 SIP equipment. The translator can be based on NAT-PT, put the point is that pure NAT-PT is not sufficient and we don't use NAT-PT as a general / generic solution for IPv4 interworking. NAT-PT applicability document is also being written by a design team, I suppose they will publish their first draft by Minneapolis meeting.

Best Regards,
	           -Juha W.-

-----Original Message-----
From: ext Bilajbegovic Damir [mailto:[email-masked]]
Sent: 16 September, 2003 11:14
To: Pyda Srisuresh
Cc: [email-masked]; Fred Templin
Subject: RE: Numbers of NAT-s in IPv4/IPv6 Network? One or more?

                     +---------------+      Public     

    

I think so, as well.

public
address