Subject: IPV6_V6ONLY

From: Mauro Tortonesi <[email-masked]>
Date: Fri, 19 Sep 2003 17:36:45 +0200 (CEST)

do you know of any OS that sets the IPV6_V6ONLY socket option on by
default?

IIRC a few months ago itojun said this was the behaviour of openbsd.

-- 
Aequam memento rebus in arduis servare mentem...

Mauro Tortonesi                 [email-masked]
                                [email-masked]
                                [email-masked]
Deep Space 6 - IPv6 with Linux  http://www.deepspace6.net
Ferrara Linux User Group        http://www.ferrara.linux.it

---

From: [email-masked] (Jun-ichiro itojun Hagino)
Date: Sat, 20 Sep 2003 14:20:38 +0900 (JST)

> do you know of any OS that sets the IPV6_V6ONLY socket option on by

	and WinXP uses separate TCP code (IIRC) so effectively behavior is the
	same as IPV6_V6ONLY = 1.

itojun

---

From: [email-masked] (Jun-ichiro itojun Hagino)
Date: Sat, 20 Sep 2003 14:19:30 +0900 (JST)

> do you know of any OS that sets the IPV6_V6ONLY socket option on by

	netbsd, freebsd (version >= 5), openbsd

itojun