Subject: RE: 3gpp-analysis-05: miscellaneous non-critical issues

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Mon, 22 Sep 2003 16:43:20 +0200

>  2.1 Dual Stack
 > 
 >     The dual IPv4/IPv6 stack is specified in [RFC2893]. If 
 > we consider
 >     the 3GPP GPRS core network, dual stack implementation in the GGSN
 >     enables support for IPv4 and IPv6 PDP contexts. UEs with 
 > dual stack
 >     and public (global) IP addresses can often access both IPv4 and
 >     IPv6 services without additional translators in the network.
 > 
 > ==> I fail to see why public (global) IP addresses are a 
 > requirement here? 
 > Can't one with a private address also access IPv4 services, 
 > possibly with
 > some difficulties, yes, but still in principle..
 > 
 >  JW: Maybe public/global addresses need not be mentioned here. I just
 > wrote it because the ideal case would be to have 
 > public/global addresses.
 > I could add a sentence clarifying that if UEs need to be 
 > contacted (e.g. 
 > thinking peer-to-peer services), public/global addresses 
 > would be needed /
 > preferred.

The meaning I infer is that if the v4 address is not public
and you need to talk v4 hosts outside your private domain
then you go through one or more NATs. NAT is considered an
"additional translator" above.

 >     As a general guideline, IPv6 communication (native or 
 > tunneled from
 >     the UE) is preferred to IPv4 communication going through 
 > IPv4 NATs
 >     to the same dual stack peer node.
 > 
 > ==> I think this is in conflict with the text already 
 > written earlier in
 > this section.  I suggest:
 > 
 >     As a general guideline, native IPv6 communication
 >     is preferred to IPv4 communication going through IPv4 NATs
 >     to the same dual stack peer node.
 > 
 >  JW: I don't have any complaints.

This changes the meaning of the text so I don't agree.
It is meant to say that using IPv6 is preferred (to IPv4
through NATs), be it native connectivity or tunneled.
/Karim

---

From: Pekka Savola <[email-masked]>
Date: Mon, 22 Sep 2003 18:54:54 +0300 (EEST)

On Mon, 22 Sep 2003, Karim El-Malki (HF/EAB) wrote:
> The meaning I infer is that if the v4 address is not public and you need
> to talk v4 hosts outside your private domain then you go through one or
> more NATs. NAT is considered an "additional translator" above.

Right.. I didn't think of NAT as an additional translator.  In any case, a 
clarification will be needed.

> through NATs), be it native connectivity or tunneled.

Yep, that's intentional.  However, the only change of substance here is 
that the "tunneled IPv6 from the UE" has been pretty much killed from the 
document already.

So, I think my text is better.  One could of course just say "As a general 
guideline, IPv6 communication ....", i.e., kill "native" by making it a 
bit more general while not pointing out the not-so-relevant details.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings