Subject: RE: 3gpp-analysis-05: Automatic tunneling inside 3GPP operator's network

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Mon, 22 Sep 2003 16:30:18 +0200

I have some comments:
1) Why change "IGP/EGP" to "routing protocols"?
   It's clear enough with IGP/EGP
2) Proposed rewrite of second parag.
   "Routing protocols over IPv6 links"
   We've already discussed this thoroughly
   and there was no agreement that this
   would be an appropriate choice to
   solve the redundancy problem. This would
   mean recommending that an operator runs
   an IPv4 routing protocol and in addition
   an IPv6 routing protocol inside each tunnel.
/Karim

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]
 > Sent: den 22 september 2003 14:02
 > To: [email-masked]; [email-masked]
 > Subject: RE: 3gpp-analysis-05: Automatic tunneling inside 3GPP
 > operator's network
 > 
 > 
 > 
 >  Hi!
 > 
 > I don't personally have big problems with that suggested 
 > text. If the other people
 > on the list do not object the text change, we could move 
 > forward with this issue.
 > 
 > Cheers,
 > 	 -Juha-
 > 
 > -----Original Message-----
 > From: ext Pekka Savola [mailto:[email-masked]]
 > Sent: 18 September, 2003 12:13
 > To: [email-masked]
 > Subject: 3gpp-analysis-05: Automatic tunneling inside 3GPP operator's
 > network
 > 
 > 
 > Hi,
 > 
 > This is the previously-opened "Automatic tunneling inside 
 > 3GPP operator's 
 > network" case again.
 > 
 > substantial
 > -----------
 > 
 > The issues I'm still not very confortable with:
 > 
 > [note: sending the second one first, because the first requires some 
 > editing yet..]
 > 
 > 2) tunneling inside the 3GPP operator's network, in 
 > particular, the last two
 > paragraphs of section 3.2.1:
 > 
 >     Even a dynamic tunneling mechanism or an IGP/EGP routing protocol
 >     based tunneling mechanism can be considered if other methods are
 >     not suitable.
 > 
 >     Connection redundancy should also be noted as an important
 >     requirement in 3GPP networks. Static tunnels on their own don't
 >     provide a routing recovery solution for all scenarios 
 > where an IPv6
 >     route goes down. However, they may provide an adequate solution
 >     depending on the design of the network and in presence of other
 >     router redundancy mechanisms. On the other hand, IGP/EGP based
 >     mechanisms can provide redundancy.
 > 
 > ==> at least, remove "IGP/EGP" (it's enough to say a routing 
 > protocol), and
 > rewrite the last paragraph like:
 > 
 >     Connection redundancy should also be noted as an important
 >     requirement in 3GPP networks. Static tunnels on their own don't
 >     provide a routing recovery solution for all scenarios 
 > where an IPv6
 >     route goes down. However, they may provide an adequate solution
 >     depending on the design of the network and in presence of other
 >     router redundancy mechanisms, such as routing protocols 
 > run over IPv6 
 >     links.
 > 
 > .. because "router redundancy mechanisms" is too vague, and 
 > IGP/EGP based
 > mechanisms are routing protocols themselves and already 
 > included in that 
 > context.
 > 
 > I'm not sure if these two edits would fix all my concerns with the 
 > document, but with these two, it would be much better already.
 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > 
 >

---

From: Pekka Savola <[email-masked]>
Date: Mon, 22 Sep 2003 18:05:39 +0300 (EEST)

>    It's clear enough with IGP/EGP

Note it was "IGP/EGP routing protocols" AFAIR.

Routing protocols are all either IGP or EGP.  There is no need to spell 
out the difference.

>    solve the redundancy problem. 

One could also characterize this that there was no agreement that this is 
needed for redundancy.

> This would

Which is operationally Just Fine! :-)