Subject: draft-palet-v6ops-proto41-nat-03 as WG item

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 13 Nov 2003 12:20:15 -0600

Hi all,

In the yesterday meeting, I've presented the latest version of http://www.ietf.org/internet-drafts/draft-palet-v6ops-proto41-nat-03, the slides are available at http://www.euro6ix.org/standardization/v6ops-proto41-nat_ietf58.zip (previous slides from Vienna also at http://www.euro6ix.org/standardization/v6ops-proto41-nat_ietf57.zip).

As nobody provided any new suggestions or objections to this document, during the meeting, my feeling is that it could be accepted as WG item.

In addition to the comment from Mariana, I got a couple of suggestions off-line that we will like to address in the next few days, so will like to take the opportunity publish the review already as WG item version 00 and keep going with the work.

Please, let me know if you feel this is acceptable or do you have any objections.

Regards,
Jordi

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Pekka Savola <[email-masked]>
Date: Thu, 13 Nov 2003 20:53:37 +0200 (EET)

On Thu, 13 Nov 2003, JORDI PALET MARTINEZ wrote:
[...]
> Please, let me know if you feel this is acceptable or do you have any

I do not think it clearly falls within the charter of the WG.  The only
clear possibility I see is charter item (6), but that would not be
acceptable until the analysis/scenarios work is complete and a clear need
has been identified.

In Vienna, there was some discussions about usefulness of documenting the
existing techniques and practice, but I don't find that as our goal in the 
charter.

We're loaded enough already.  The analysis work must be finished before 
jumping to the mechanisms.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 13 Nov 2003 13:23:10 -0600

Hi Pekka,

In the charter (http://www.ietf.org/html.charters/v6ops-charter.html), I can read as number 1:
"Solicit input from network operators and users to identify 
  operational or security issues with the IPv4/IPv6 Internet, and 
  determine solutions or workarounds to those issues.  This includes
  identifying standards work that is needed in other IETF WGs or
  areas and working with those groups/areas to begin appropriate
  work.  These issues will be documented in Informational or BCP
  RFCs, or in Internet-Drafts."

In my opinion, as already explained, proto-41 is nothing new. What is new is the operational/security issues of its usage (as described in this paragraph from the charter), and this is what the document does. In addition, the document determine solutions/workarounds for the operation, so again, falls within this paragraph in the charter.

Also, as you said, it can fall under 6 (I feel more under 5, but both are closely related). But in this case it suggest to me a new transition mechanism, and as said, proto-41 is not one.

In any case, if we are talking about 5/6, you indicate that should not be acceptable until the analysis/scenarios work is complete. I will like to know where in the charter is stated that we can't document an operational situation until the scenarios are done.

Finally, in my opinion, this is not related to the workload of the WG. Getting the document as a WG chapter will not change that. The discussions about this document have already happened in the mailing list, and I guess should continue there. So what is the difference ? The alternative is we move to a personal submission, and my feeling is that will imply more workload.

Regards,
Jordi

---

From: Tim Chown <[email-masked]>
Date: Thu, 13 Nov 2003 20:00:37 +0000

> acceptable until the analysis/scenarios work is complete and a clear need

I think it fits charter item 1.  It does not involve new work.

> jumping to the mechanisms.

I would hope the unman eval work will be finished before Christmas,
and the Proto-41 issue will/could address one recommended development
path there (at least based on what Christian presented yesterday).
So it is not long to wait.

The flip side of the coin is that we are already in the position of 
deployment leading standardisation by some way in v6ops.
 
Tim

---

From: Pekka Savola <[email-masked]>
Date: Fri, 14 Nov 2003 03:14:00 +0200 (EET)

>   RFCs, or in Internet-Drafts."

Please note the next paragraph; even though starting as "For example, ..." 
it seems to paint a different meaning for the intent of the paragraph.

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 13 Nov 2003 19:19:00 -0600

Come on !

"For example, important pieces of the Internet infrastructure
  such as DNS, SMTP and SIP have specific operational issues when
  they operate in a shared IPv4/IPv6 network. The v6ops WG will
  cooperate with the relevant areas and WGs to document those
  issues, and find protocol or operational solutions to those
  problems."

This is providing a few clear examples, but at no way excluding whatever else can come from operational experience.

I'm starting to believe that we are not in the OPS area ?

Regards,
Jordi

---

From: Fred Templin <[email-masked]>
Date: Tue, 18 Nov 2003 09:55:14 -0800

Jordi,

You can count me as favoring this work going forward, but I'd like to
suggest that a NAT that does the proper proto41 forwarding is unlike
a NAT in the traditional sense and perhaps in need of a new name. My
suggestion is:

  Network Organizational Translator (NOT)

Fred
[email-masked]

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 18 Nov 2003 18:56:04 +0100

Hi Fred,

I'm not sure to catch what do you mean and how much is serious in "NOT" ...

Do you mean only some "expensive" (corporate ?) NATs do this ? I tried with very low cost models, and it works.

Of course, actually it worked for me with the bigger networks (I assume more expensive routers), like the Minnesota airport one when waiting for my flight ...

Regards,
Jordi

---

From: Fred Templin <[email-masked]>
Date: Tue, 18 Nov 2003 10:20:07 -0800

Jordi,

>Do you mean only some "expensive" (corporate ?) NATs do this ? I tried with very low cost models, and it works.

Pardon any misconceptions my message may have imparted. The
term "organizational" is just like the term "enterprise" in that it
may suggest to some a large, elaborate, expensive, corporate, etc.
entity.

In networking terms, however, an "organization" or an "enterprise"
could constitute anything from the simplest 1-2 node site to the
most complex internetwork in the world. So I did indeed intend
to cover everything from the least expensive home gateway to
the most elaborate corporate router in my blanket statement.

Fred
[email-masked]

---

From: Carlos Friacas <[email-masked]>
Date: Tue, 18 Nov 2003 18:14:07 +0000 (WET)

Hello,

Has the "uniqueness" problem been solved/sorted out?

E.g.:

If i and Jordi attend the same conference and stay on the same hotel,
which only has a nat box, can we both use this "mechanism"?
Or should i have to phone Jordi and say: "Hey, can you disconnect for 5
mins, i need to use IPv6!".

Is this still true? Is this *clearly* reflected on the current draft
version?

Regards,
Carlos

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 18 Nov 2003 19:43:26 +0100

Carlos,

I think is indicated by the applicability section that is expected to be used in SOHO. But you're right, I need to check it and we can complete more that text to explain this situation. Only happens if both users are using the same tunnel end point.

Actually I expect the hotel to provide native or 6to4, or even use proto-41 but with a local IPv6 router (a simple PC can do it) providing IPv6 to all the guest.

Actually if you are in the Minnesota airport at the same time, I provided RA to allow anyone to use my laptop as an IPv6 router ;-)

Regards,
Jordi

---

From: Carlos Friacas <[email-masked]>
Date: Wed, 19 Nov 2003 08:07:48 +0000 (WET)

On Tue, 18 Nov 2003, JORDI PALET MARTINEZ wrote:

> Carlos,
>
> I think is indicated by the applicability section that is expected to be used
> in SOHO. But you're right, I need to check it and we can complete more
> that text to explain this situation. Only happens if both users are
> using the same tunnel end point.

SOHO = Small Office, Home Office
Whereas, *not* one-man office, home office.
Even for a very smal office (<5 people) i still fail to see this mechanism
a a good tool for transition. This "mechanism" only provides v6
connectivity to *one* IPv6 geek inside the SOHO. This is (IMHO) what i
wish to fight. IPv6 is not for geeks, IPv6 should be for everyone (without
any knowledge about it needed!)

> Actually I expect the hotel to provide native or 6to4, or even use proto-41
> but with a local IPv6 router (a simple PC can do it) providing IPv6 to
> all the guest.

How many hotels will do this on a permanent basis? (adding a PC for the
sole purpose of v6 routing). Hotels (and others) only worry about
providing IP. The v6 bit will be only provided properly with a minimum
requirement: 6to4!

> Actually if you are in the Minnesota airport at the same time, I provided RA
> to allow anyone to use my laptop as an IPv6 router ;-)

If i were in the minnesota airport i had to discard your RAs (if i were in
the US, i wouldnt like all the packets going through Spain! --different
continent, bigger RTT), and find an appropriate RA, or instead find a tunnel
endpoint geographically nearby (which might be an impossible task if you
were already making a tunnel to spain using the proto-41 hack).

Regards,
Carlos