Subject: RE: 3gpp-analysis-07: (semi-)editorial issues

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Mon, 17 Nov 2003 18:06:19 +0100

> On Mon, 17 Nov 2003, Karim El-Malki (HF/EAB) wrote:
 > > OK I see. Reread the original now. I think the meaning of the
 > > "peer address" part of the sentence was along the lines of: if you
 > > only have a v4 pdp context and you discover that the peer 
 > is v6-only
 > > then set up a v6 pdp ctxt. Is the issue that this was not clear or
 > > that this does not make sense?
 > 
 > Isn't it already way too late to activate the v6 PDP context 
 > if you wait 
 > until looking up the addresses, because PDP context 
 > activation takes a lot 
 > of time?

As you say it would be better if the pdp context was already there
but in the above case you have little other choice? (also some
other considerations on "in advance" activation below)

 > 
 > And actually, if an application gets e.g. both AAAA and A 
 > records back
 > from the DNS, you don't know which will end up being used.

True, if both are returned then we don't know since it's up
to the app. I was taking the case where there is only a AAAA
record and you only have a v4 pdp ctxt.

 > 
 > The point of the reword was to state that activating based 
 > on the peer 
 > address basis doesn't usually make sense, and 
 > application-based activation 
 > may not either..

You could activate pdp contexts in advance or you may do
that based on app.s and in special cases (above) peer
addresses.  The "in advance" option is attractive but there
are cases where it doesn't work well: if the application needs
a pdp context with certain QoS and APN (e.g. corporate)
characteristics that is not currently active. So I am not
convinced that we should be making the above point.

/Karim

---

From: Pekka Savola <[email-masked]>
Date: Mon, 17 Nov 2003 19:22:49 +0200 (EET)

> other considerations on "in advance" activation below)

Sure, but activating both v4 and v6 to begin with (if there are any 
v6-using apps on the UE) should be the safest choice..

> record and you only have a v4 pdp ctxt.

Sure, if we can assume something about apps and the scenarios where the UE 
will be used, fine.

> convinced that we should be making the above point.

I'm not sure how common those cases are. I'd assume they are not too 
common.  Therefore, it would seem to clarify better how the PDP contexts 
are typically used.

Could you care to try to suggest a different reword to clarify the 
different considerations with PDP context activation?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings