Subject: RE: "ROUTERS" vs. "routers"

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 25 Nov 2003 15:22:43 -0000

Hi Havard

I believe it's worth opening the Pandora's box. I agree with Fred that things and usages have changed.

On top of the MANET based examples that Fred proposed, I have in mind an other 'Half and half' case. That's the concept on "Network in node" which is a basically a host with a network attached to it or inside it. Examples:

- A traffic dispatcher
- A PC with multiple Network addressable entities such as storage media
- A PC with multiple users or applications, each one with a addressable with different IP address from an "inner" network
- A mobile router (still shows as a Host on the roaming interface) acting as a bridge when at home
- A ND proxy that is not exposed as a router, eg a Home Network behind a Home Gateway.

I'm not sure if in Fred's term I'm introducing "HOST" vs "host", but it appears that the old paradigm of routers vs hosts seems limited for some applications that IPv6 enables.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Havard Eidnes
> Sent: mardi 25 novembre 2003 15:29
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: "ROUTERS" vs. "routers"
> 
> Hm,
> 
> I hope I'm not the only one who find the choice of wording to be
> unfortunate.
> 
> From the 10km-high perspective, there should be other and more
> fundamental distinguishing marks than the prefix length of
> advertisments or more general protocol behaviour to draw the line
> between what has traditionally been named "hosts" and "routers".
> 
> I'll therefore give some pushback on introducing a subtle
> for-ipv6-only distinction between "ROUTERS" and "routers".
> 
> Regards,
> 
> - Håvard
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Havard Eidnes <[email-masked]>
Date: Tue, 25 Nov 2003 16:43:28 +0100 (CET)

Hm,

maybe I was unclear -- let me try to clarify.

The distinction between routers and hosts and the criteria to separate
between them is one which I perceive as having been well established
in Internet technology for a Long Time.  I think we should think twice
before obfuscating this distinction, or try to sneak in something
which is claimed to be somewhere between them.

I'm therefore reacting negatively to the attempt at abusing the
"router" term by introducing new and subtle meaning with a distinction
between "ROUTER" and "router".  Choose a different word if you insist
on pursuing this, please!

I've heard in other discussions the distinction between hosts
implementing a "strong" versus a "weak" model, typically used as a
distinguishing additional criteria when hosts are attached to multiple
networks and/or have multiple addresses.  However, my local RFC
repository does not have any mention of that term.  I wonder if this
direction is something which could be pursued.

Regards,

- Håvard

---

From: Fred Templin <[email-masked]>
Date: Tue, 25 Nov 2003 08:01:44 -0800 (PST)

The goal of my message is to get a message out; not to
push new terminology. See RFC 1122 for a discussion
of the "strong" vs "weak" ES models.
 
Thanks - Fred
[email-masked]
[email-masked]
 
Havard Eidnes <[email-masked]> wrote:

---

From: Mark Smith <[email-masked]>
Date: Wed, 26 Nov 2003 16:15:24 +1030

On Tue, 25 Nov 2003 15:22:43 -0000

> - A PC with multiple Network addressable entities such as storage media

I had the maybe not so strange idea a while back of having all components within a PC have an IPv6 address, or at least represented within the OS by an IPv6 eg keyboard, mouse, HDD etc. I'm not necessarily suggesting that inter-device communication occurs over TCP or UDP though. Just IPv6 addresses for management, and possibly other uses that I haven't thought of.

You could then do tricks such as if the user complains that their HDD has stopped working, you could ping it over the network. Or have SNMP agents issue traps when eg. the keyboard stops working.

I don't know whether this model would make the PC a router, or just that the PC's interface to the network acts as a proxy for all the device's "internal" IPv6 addresses, performing things such as DAD on their behalf.

Regards,
Mark.