Subject: 2001:db8::/32 IPv6 Documentation Prefix currently not in whois

From: "Jeroen Massar" <[email-masked]>
Date: Tue, 25 Nov 2003 02:26:49 +0100

-----BEGIN PGP SIGNED MESSAGE-----

Hi,

The RFC1918 prefixes are available in whois:

NetRange:   192.168.0.0 - 192.168.255.255
CIDR:       192.168.0.0/16
NetName:    IANA-CBLK1
NetHandle:  NET-192-168-0-0-1
Parent:     NET-192-0-0-0-0
NetType:    IANA Special Use
NameServer: BLACKHOLE-1.IANA.ORG
NameServer: BLACKHOLE-2.IANA.ORG
Comment:    This block is reserved for special purposes.
Comment:    Please see RFC 1918 for additional information.
Comment:
RegDate:    1994-03-15
Updated:    2002-09-16

But the documentation prefix 2001:db8::/32 isn't and
falls under the 2001:c00::/23 prefix by APNIC:

inet6num:     2001:0C00::/23
netname:      APNIC-AP-ALLOCATED-PORTABLES2
descr:        Asia Pacific Network Information Center, Pty. Ltd.
descr:        Regional Internet Registry for the Asia-Pacific Region
descr:        Level 1 - 33 Park Road.
descr:        PO Box 2131
descr:        Milton QLD 4064
descr:        Australia
country:      AU
<SNIP>

Shouldn't it be handy if the prefix was also recorded in whois
along with at least the draft's urls or even maybe an RFC when
that is done? Currently the draft is to be expired the February 25th,
a well known date to me, the draft is at:

http://www.ietf.org/internet-drafts/draft-huston-ipv6-documentation-prefix-01.txt

APNIC also has a FAQ about it here:
http://www.apnic.net/info/faq/ipv6-documentation-prefix-faq.html 

But a plain google on 2001:db8::/32 doesn't bring these up directly
so it could be confusing for people not knowing what these prefixes
are, who might know that whois should contain the information.
What is next for this draft btw? Is it going up for RFC?

Greets,
 Jeroen

---

From: David Malone <[email-masked]>
Date: Tue, 25 Nov 2003 18:22:42 +0000

I though the IPv4 doc prefix was 192.0.2.0/24 (as mentioned in
RFC 3330). It doesn't seem to be listed in as clear a way in
whois as 192.168.0.0/16 is.

	David.

---

From: "Jeroen Massar" <[email-masked]>
Date: Tue, 25 Nov 2003 19:47:40 +0100

-----BEGIN PGP SIGNED MESSAGE-----

> whois as 192.168.0.0/16 is.

ARIN has it listed as:

$ whois 192.0.2.0
Internet Assigned Numbers Authority RESERVED-192 (NET-192-0-0-0-1)
                                  192.0.0.0 - 192.0.127.255
Internet Assigned Numbers Authority IANA (NET-192-0-2-0-1)
                                  192.0.2.0 - 192.0.2.255

$ whois -h whois.arin.net NET-192-0-2-0-1

NetRange:   192.0.2.0 - 192.0.2.255
CIDR:       192.0.2.0/24
NetName:    IANA
NetHandle:  NET-192-0-2-0-1
Parent:     NET-192-0-0-0-1
NetType:    Reassigned
Comment:    Please see RFC 3330 for additional information.
RegDate:
Updated:    2002-10-14

(ARIN still doesn't do CIDR queries)

Better comparison indeed than the RF1918 prefixes.
This does make clear that the draft should be advanced
and the prefix documented IMHO.

Greets,
 Jeroen