Subject: RE: manual config of UE tunnel [RE: 3gpp-analysis: Recommendation on tunneling in the UE]

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Wed, 26 Nov 2003 16:25:02 +0100

> > > It is implemented
 > > > on 4 different products that I know of (2 host platforms
 > > > and two router platforms) and are all interoperable. 
 > > 
 > > Implementatable & interoperable is VERY FAR from being well
 > > understood.
 > 
 > We have to look at this. However, I have come to the same 
 > conclusion about the implementation status of ISATAP. Maybe 
 > some vendors that have implemented ISATAP could indicate 
 > which version of the ISATAP they are shipping.

I think this is a good idea and would take it a step further.
If the ISATAP authors are willing to analyse what has been
implemented to possibly simplify the spec and address some other
concerns (e.g. host-to-host) that would be the best outcome.
/Karim

---

From: Soliman Hesham <[email-masked]>
Date: Wed, 26 Nov 2003 10:27:22 -0500

> 
 > But in any case, whether the router is a PC or something else is
 > rather irrelevant; the point is that it's probably some standard ISP
 > industry equipment without a 3GPP "price added" tag.

=> So what? It still needs to be developed. And this takes
time. Unless people agree that the current alternative
is unworkable it wouldn't make sense to start new work.

 > Are we asking anyone to remove anything?  Is it the IETF's fault if 
 > someone wastes resources in a dead-end solution?  

=> That's your opinion. And this is why I want to know
if it's a WG opinion as well. We can't have specs hanging 
for years and expect people to wait for IETF to produce
the utopian solution before they can roll out products. 
Definitely not for a transition tool!
The fact that several vendors developed it tells me that 
they understand it and are happy to roll it out. 

   In any case, 
 > resources needed for a "simple" product, like the one I described, 
 > would be rather minimal.

=> There is a minimum development cost that is independent
of whether you're adding an if statement or 10,000 loc. 
People won't do that minimum unless they are convinced
that the alternative is unworkable. 

 > [[ whether or not now is the appropriate time to call for WG 
 > consensus 
 > on which way to go remains to be considered ]]

=> I'll wait till that concensus call is made then.

Hesham