Subject: NAT-PT: DNS ALG question

From: "CTO WEI Renxiang" <[email-masked]>
Date: Wed, 19 Nov 2003 10:59:44 +0800

Hi,

I wanted to know what would be the correct behavior for the following
scenario.

Suppose a mix(include both IPv4 and IPv6 host) network with a NAT-PT and DNS-ALG deployed
on the border. An outside IPv4 client host sends a A query, thru NAT-PT, to a DNS 
server in this mix network. NAT-PT RFC says that a A need to be translated into AAAA,
but if the host in this mix network been queried is an IPv4-only host, the result will not be correct.
The RFC really doesn't say anything like that.

Should DNS-ALG need to query the DNS server in this mix network before it translates the A to AAAA?

Thanks
Renxiang

---

From: Senthil Sivakumar <[email-masked]>
Date: Tue, 18 Nov 2003 22:31:30 -0800

>The RFC really doesn't say anything like that.

These two v4 devices should have had some means of communicating before 
NAT-PT, which is
probably NAT. And I would assume that they continue to talk to each other 
using NAT. If
you say that the NAT and NAT-PT are running in the same box, then it would 
become a coexistence
and/or implementation issue and you won't find those issues in NAT-PT RFC.

---

From: "CTO WEI Renxiang" <[email-masked]>
Date: Wed, 19 Nov 2003 15:40:44 +0800

I'm not sure if I got what do you mean. Maybe we can clarify by a typical sequence:
 
DNS server (D)
V4 host(A)      NAT-PT                         v4 host(X)   
V6 host(B)      DNS-ALG   
 
1. X sends DNS query to D, which will be intercepted by NAT-PT;
2. NAT-PT modifies the query to AAAA.
3. NAT-PT relay the query to D;
4. D replise that that are no AAAA RR.
 
If NAT is used, it'll function after the DNS query returned by DNS server. that's after step 4.
If we explore some other means of communication before NAT-PT, modification to the applications
will be needed.
 
My suggestion is DNS-ALG query the DNS server before it translates the A to AAAA.
 
R.G.
Renxiang

----- Original  -----
 Sender: Senthil Sivakumar [mailto:[email-masked]]
 Time: 2003年11月19日 14:32
 Receiver: CTO WEI Renxiang
 CC: [email-masked]
 Title: Re: NAT-PT: DNS ALG question

Hi,

These two v4 devices should have had some means of communicating before NAT-PT, which is
probably NAT. And I would assume that they continue to talk to each other using NAT. If
you say that the NAT and NAT-PT are running in the same box, then it would become a coexistence
and/or implementation issue and you won't find those issues in NAT-PT RFC. 

Thanks
Renxiang