Subject: RE: 3gpp-analysis: Recommendation on tunneling in the UE

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Tue, 18 Nov 2003 14:50:13 +0100

> On Mon, 17 Nov 2003, Fred Templin wrote:
 > > >.. I think ISATAP is definitely an overkill in this 
 > specific scenario.
 > > 
 > > If by "overkill" you mean that it *works better* than the other
 > > alternatives, then I agree since ISATAP is more automatic, 
 > agile and
 > > efficient than the other alternatives. But, this would amount to an
 > > attarctive incentive and not a negative as is usually 
 > implied by the
 > > term "overkill".
 > 
 > Yes, in this particular case, ISATAP provides more features 
 > than I believe
 > we need (such as, automatic tunneling between ISATAP nodes, prefix
 > delegation support, etc.).  Thus, a more simplified 
 > mechanism would be
 > better.

I don't think the above "extra" features are in the current ISATAP
spec and agree that it should focus on the basic host-to-router
mechanism. Would satisfying the above make it acceptable?
I think draft-16 does that. I'll review it myself and hope the wg
finds time for that too.

 > 
 > I'm also not confortable running ISATAP over administrative 
 > borders, as
 > has been suggested here.  This applies in a similar fashion and to a
 > lesser extent also to the unmanaged case where the ISP is 
 > doing NAT but
 > wanting to offer IPv6.

Comment on this in a previous email.
I don't think the 3gpp ue case involves crossing L3 admin borders.

/Karim

---

From: Tim Chown <[email-masked]>
Date: Tue, 18 Nov 2003 13:58:52 +0000

> I think draft-16 does that. I'll review it myself and hope the wg

I would agree with that.
 
Tim

---

From: Pekka Savola <[email-masked]>
Date: Tue, 18 Nov 2003 16:47:56 +0200 (EET)

> > I think draft-16 does that. I'll review it myself and hope the wg

Please read the draft.  Only, the facts do not change: ISATAP does provide
these features (and more besides!) which are completely unnecessary and
even counter-productive in this scenario.

ISATAP simply is *not* a simple host-to-router mechanism. (Of course, 
"simple" is subjective, but at least it's much more complicated than you 
thought.)

(I reviewed isatap-15 in detail, and I don't think -16 changed much in 
this regard.)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Tim Chown <[email-masked]>
Date: Tue, 18 Nov 2003 14:50:55 +0000

> "simple" is subjective, but at least it's much more complicated than you 

Sorry Pekka, I was agreeing that it would be easier to adopt formally if 
it was a simple host-to-router mechanism.
 
Tim