Subject: Router Advertisement message

From: "Damir Bilajbegović" <[email-masked]>
Date: Mon, 24 Nov 2003 13:55:59 +0100

Hi,
    I have got one hard question: 
Network is simple; only one user is on link (no neighbours). He got address
via DHCP v6 (no stateless address autoconfiguration), no Mobile IPv6 and no
multicasts. User is not going to check router reach ability (e.g. he is not
going to check is there is router advertisement messages...)
Can be such network where is no Router Advertisement?
I really do not know. My bosses asked me this question and I do not know if
such network can exist. 
	Thanks in advance
                   Damir Bilajbegovic
P.S: It must be supported if user send Router Solicitation message, but
such user won&#8217;t sent such message.
 Router reachability is going to be checked via other low layer mechanism
(physics layer in OSI)
In Stateless address Autoconfiguration procedures is needed, but it is not
going to support- address is going to be reached via DHCPv6.
I can not think of any other usage of Router Advertisement message

--
Trebate bolji pristup internetu?
Nazovite IskonInternet na 0800 1000 ili pogledajte
http://www.iskon.biz/individualni/usluge/dialup/

---

From: Jeff Doyle <[email-masked]>
Date: Mon, 24 Nov 2003 10:27:06 -0700

Sure, this can be done... on Juniper and Cisco routers, anyway. I'm 
sure other vendors can also do it.

- Juniper routers do not send RAs unless explicitly configured to do so.
- Cisco routers send an RA by default, but can be configured to not 
send them ("ipv6 nd suppress-ra").

Jeff