Subject: how to get DNS server address

From: "CTO WEI Renxiang" <[email-masked]>
Date: Fri, 28 Nov 2003 11:24:00 +0800

Hi,

IPv6 support both stateless(no DHCP) and stateful(DHCP) configuration, but DNS server address can only be obained through DHCP. How to get DNS server address in stateless configuration mode? 

Thanks.

Renxiang Wei

---

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 28 Nov 2003 13:58:02 +0900

> IPv6 support both stateless(no DHCP) and stateful(DHCP) 
> configuration, 

Yes !

>  but DNS server address can only be obained through DHCP. 

Never !

>  How to get DNS server address in stateless configuration mode? 

This issue has being discussed in DNSOP WG mailing list...
Please move to there...
http://www.cafax.se/dnsop/maillist/

Regards

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics

---

From: Martin Stiemerling <[email-masked]>
Date: Fri, 28 Nov 2003 10:36:06 +0100

--On Freitag, 28. November 2003 11:24 +0800 CTO WEI Renxiang 
<[email-masked]> wrote:

| Hi,
|
| IPv6 support both stateless(no DHCP) and stateful(DHCP) configuration,
| but DNS server address can only be obained through DHCP. How to get DNS
| server address in stateless configuration mode?

You can get the DNS server information (as well as any other service 
information) via DHCP even in IPv6 stateless address autoconfiguration. For 
this you have to use the O flag in the router advertisements (RA)  and a 
DHCP server in stateless mode. With the O flag set in the RA the client 
should consult a DHCP server for further information, for instance DNS 
server's address.

 Martin

|
| Thanks.
|
| Renxiang Wei
|

Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de