Subject: Re: draft-palet-v6ops-proto41-nat-03 as WG item

From: [email-masked]
Date: Thu, 20 Nov 2003 14:25:15 -0800

>I'd like to suggest that a NAT that does the proper proto41 forwarding is 
unlike a NAT
> in the traditional sense and perhaps in need of a new name. 
>My suggestion is:Network Organizational Translator (NOT)

Fred, technically speaking NAT for forwarding packets with protocol field 
41 is the same as NAT for forwarding packets with protocol field 6 (TCP) 
and 17 (UDP). Well, the entities in the NAT table are different, e.g. for 
41 it's
 (source IP address, target IP address, IP protocol) 
whereas for 6 and 17 it's
(source IP address, source TCP/UDP port, target IP address, target TCP/UDP 
port)
but the principle of address translation is the same. The difference in 
the entity comes from the fact that 41 forwarding happen on IP layer 
whereas the 6 and 17 forwarding happen on TCP/UDP layer, taking into 
accoun the ports numbers as well. 
 
Frankly speakning I do not see any reason to go for another name. 

Mariana
-----------------------------------------------------------------------------------------------------------------
Dr. Mariana Nikolova 
Philips Research Laboratories Eindhoven (IST/SwA/DS)
Prof. Holstlaan 4, 5656 AA, Eindhoven, The Netherlands
room: WDC 1.35,     phone: +31-40-27-45455
e-mail: [email-masked] 
-----------------------------------------------------------------------------------------------------------------

---

From: Fred Templin <[email-masked]>
Date: Thu, 20 Nov 2003 14:46:15 -0800

[email-masked] wrote:

>
> >I'd like to suggest that a NAT that does the proper proto41 
> forwarding is unlike a NAT
> Fred, technically speaking NAT for forwarding packets with protocol 
> field 41 is the same as NAT for forwarding packets with protocol field 
> 6 (TCP) and 17 (UDP). Well, the entities in the NAT table are 
> different, e.g. for 41 it's

Perhaps it should be:

  (source IP address, target IP address, IP protocol, IPv6 flow_label) ?

> (source IP address, source TCP/UDP port, target IP address, target 
> TCP/UDP port)
> but the principle of address translation is the same. The difference 
> in the entity comes from the fact that 41 forwarding happen on IP 
> layer  whereas the 6 and 17 forwarding happen on TCP/UDP layer, taking 
> into accoun the ports numbers as well.
>  

I won't push hard for another name. We already have enough
confusing TLAs runnining around for the forseeable future.

Thanks - Fred
[email-masked]