Subject: RE: 3gpp-analysis-07: (semi-)editorial issues

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Mon, 17 Nov 2003 17:23:09 +0100

>       If the
 > >  >     3GPP network supports both IPv4 and IPv6 PDP 
 > contexts, the UE may
 > >  >     activate the appropriate PDP context depending on 
 > the type of
 > >  >     application it has started; it may also make sense to 
 > >  > open both PDP
 > >  >     contexts in advance, before they are used, because the 
 > >  > activation of
 > >  >     a context may take a relatively long time.
 > >  > 
 > >  > .. somehow I don't think activating PDP context based on the 
 > >  > peer address is
 > >  > a realistic option right?
 > > 
 > > The above talks about application not peer address.
 > > So it is referring to IPv6-only applications for example.
 > > When these are started they may prompt the v6 pdp context 
 > activation.
 > 
 > Agreed -- but the original document included "peer address" 
 > as well.  That 
 > should be gone in my proposed text..?

OK I see. Reread the original now. I think the meaning of the
"peer address" part of the sentence was along the lines of: if you
only have a v4 pdp context and you discover that the peer is v6-only
then set up a v6 pdp ctxt. Is the issue that this was not clear or
that this does not make sense?

/Karim

---

From: Pekka Savola <[email-masked]>
Date: Mon, 17 Nov 2003 18:32:08 +0200 (EET)

> that this does not make sense?

Isn't it already way too late to activate the v6 PDP context if you wait 
until looking up the addresses, because PDP context activation takes a lot 
of time?

And actually, if an application gets e.g. both AAAA and A records back
from the DNS, you don't know which will end up being used.

The point of the reword was to state that activating based on the peer 
address basis doesn't usually make sense, and application-based activation 
may not either..

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings