Subject: Issue tracker introduced for the v6ops WG

From: <[email-masked]>
Date: Mon, 10 Nov 2003 19:14:40 +0200

Hello v6ops,

we (the chairs) have been discussing changes for the process of the working group. The idea is to change the processes to enable open, traceable, and more efficient process for the WG. This is to speed up, facilitate better the work of the document editors, and to make sure all comments are addressed in the group. To achieve this we are proposing to introduce the issue tracker for all WG drafts. We are going to use the issue tracker from psg.com (http://rt.psg.com/). 

Issue tracker is going to be used for all documents when they get to the WG draft status. The comments to the documents are sent as issues and the issues are registered to the issue tracker. For submitting issues a simple template is used. To make sure that every issue is registered, only the issues submitted using the template are registered. The template has also space for proposing text to solve the issue. It is encouraged to use this section when submitting an issue... 

The issues are registered to the issue tracker for your convenience by one of the chairs. The editor of the document will be responsible to propose action to the individual issues. The action is accept, accept with modification, and reject. The submission of issues and the discussion about the issues is, of course, done on the list. So, the issue tracker is mostly a documentation tool for the discussion and facilitating the work of the editor.

We have had good experiences with the initial trial on the 3GPP analysis draft(will stay at http://danforsberg.info:8080/draft-ietf-v6ops-3gpp-analysis/index). I hope this will also revive and focus the discussion on other items as well.

Let's try this out and see how it works! And we'll discuss this in the meeting today as well.

The chairs
(Bob, Jonne, Pekka)

PS. The template is the following. Thanks for AAA WG letting us use theirs:
[Document]<Subject> 
Submitter name: <Your_Name_Here> 
Submitter email address: <Your_Email_Address_Here> 
Date first submitted: <Insert_Date_Here> 
Reference: <URL to e-mail describing problem, if available>
Comment type: ['T'echnical | 'E'ditorial] 
Priority: ['MUST' Must fix | 'SHOULD' Should fix | 'MAY' Nice to have ] 
Section: <Insert_Section_Number_Here> 
Rationale/Explanation of issue: 
<Detailed explanation of the issue>
 
Requested change: 
<Proposal of text> 

--------
Jonne Soininen
Nokia

Tel. +358 40 527 4634
Email: [email-masked]

---

From: [email-masked] (Jun-ichiro itojun Hagino)
Date: Tue, 11 Nov 2003 02:24:14 +0900 (JST)

> Hello v6ops,
> 
> we (the chairs) have been discussing changes for the process of
> the working group. The idea is to change the processes to enable
> open, traceable, and more efficient process for the WG. This is to
> speed up, facilitate better the work of the document editors, and
> to make sure all comments are addressed in the group. To achieve
> this we are proposing to introduce the issue tracker for all WG
> drafts. We are going to use the issue tracker from psg.com
> (http://rt.psg.com/).

	what is the username/password to browse the list of issues?
	at least we need to be able to browse it anonymously (i.e. without
	creating user/password pair) otherwise lots of lots of user will be
	registered just to browse the list of issues.

	secondly, how can i register username/password?

	in other words, where is the user manual (for v6ops people)?

itojun

---

From: Pekka Savola <[email-masked]>
Date: Mon, 10 Nov 2003 19:26:21 +0200 (EET)

> 	in other words, where is the user manual (for v6ops people)?

ietf/ietf, as stated at the bottom of the page :-)

registering a user name is not needed.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Fred Templin <[email-masked]>
Date: Mon, 10 Nov 2003 11:42:26 -0800 (PST)

Hi,
 
The question I was intending to ask on this subject before Randy
shut down  the discussion is how do you propose to mitigate abuse
of the mechanism, i.e., so that document authors aren't spammed?
(The two examples Jonne provided were prime examples of what
I would consider "issue spamming". :^} )
 
Any thoughts on this?
 
Fred
[email-masked]

Pekka Savola <[email-masked]> wrote:

---

From: Pekka Savola <[email-masked]>
Date: Mon, 10 Nov 2003 22:23:55 +0200 (EET)

> I would consider "issue spamming". :^} )

We'll deal with it if it becomes a problem :-)

The chairs are responsible for recording issues.  They could also be 
edited to fit, or rejected outright if there seems to be abuse in 
progress..