Subject: ISATAP in unmanaged networks?

From: Fred Templin <[email-masked]>
Date: Thu, 13 Nov 2003 06:53:38 -0800 (PST)

Hello,
 
It just now occurs to me that Christian's unmanaged networks
presentiation during v6ops yesterday did not mention ISATAP
as one of the automatic tunneling alternatives, and I wonder
why this is so.
 
I have not studied this space, but it occurs to me that ISATAP
could be tried as a first alternative to check whether the two
hosts are separated by a NAT. If there is no intervening NAT,
it seems to me that ISATAP would provide the benefit of not
needing the UDP header and "bubble" packets, yielding
greater efficiency. Otherwise, if blocked by a NAT the
initiating host coud after a short timeout try again with
Teredo.
 
I know that ISATAP has been seen as in the Enterprise
space, but I see potential applicability here for the
unmanaged. Comments?
 
Fred Templin
[email-masked]

---

From: [email-masked]
Date: Thu, 13 Nov 2003 23:58:09 +0900

>initiating host coud after a short timeout try again with

	ISATAP requires an ISATAP router in a site to advertise RA in a
	pretty weird fashion, which is clearly a drawback.

itojun

---

From: Pekka Savola <[email-masked]>
Date: Thu, 13 Nov 2003 17:09:40 +0200 (EET)

I removed [email-masked] from Cc: to avoid unnecessary cross-posting.

> initiating host coud after a short timeout try again with

There are multiple cases to consider:

 - host/router is not behind a NAT:
   * the ISP is providing the ISATAP service
    ==> this is a cornercase of tunnel service by the ISP

 - host/router is behind a NAT:
   * .. when the ISP is doing the NAT (e.g., GPRS -kind of scenario, also 
sometimes used for commmon xDSL networks)
    ==> same as above, the service provided by the ISP

I don't think there's really applicability for ISATAP in this space if the 
ISP is co-operating (which is the requirement for ISATAP anyway).  
Configured tunneling (+ enhancements) is simpler and more generic.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Fred Templin <[email-masked]>
Date: Thu, 13 Nov 2003 07:15:29 -0800 (PST)

Pekka,
 
It is not at all true that the cooperation of an ISP is needed to
support ISATAP. ISATAP works just fine in intermittently
connected/disconnected networks - even of the mobile ad-hoc
variety. I spent several years proving this in my previous
employment at SRI, and nothing has changed since then.
 
See the "goals for local communications within sites" document
in the IPv6 space for other scenarios that would benefit from ISATAP.
 
Fred
[email-masked] 

Pekka Savola <[email-masked]> wrote:
I removed [email-masked] from Cc: to avoid unnecessary cross-posting.

---

From: Fred Templin <[email-masked]>
Date: Thu, 13 Nov 2003 07:09:08 -0800 (PST)

Itojun,
 
I subscribe to the model that all nodes may indeed be routers.
This comes mainly from my background in MANET, but I see
the paradigm as possibly appropriate here as well. If each node
in the site were a router, we would be sending an RS in the
expectation of getting back an RA with more-specific routes
and (in most cases) zero in the router_lifetime field.
 
We will certainly still have our default router(s) as told by the
Potential Router List. But, if we view the global DNS as an
extension to the PRL, we can select ISATAP routers for more
specific routes on an on-demand basis.
 
Sorry for not saying all of this at the microphone yesterday, but
I was preoccupied with other matters at the time.
 
Thanks - Fred
[email-masked]

itojun

---

From: Bob Hinden <[email-masked]>
Date: Thu, 13 Nov 2003 07:23:29 -0800

[ post by non-subscriber.  with the massive amount of spam, it is easy to miss
  and therefore delete posts by non-subscribers.  if you wish to regularly
  post from an address that is not subscribed to this mailing list, send a
  message to <listname>[email-masked] and ask to have the alternate
  address added to the list of addresses from which submissions are
  automatically accepted. ]

Folks,

Please keep this thread on the v6ops list and do not cross post to ipv6.

Thanks,
Bob

---

From: Pekka Savola <[email-masked]>
Date: Thu, 13 Nov 2003 17:43:52 +0200 (EET)

> employment at SRI, and nothing has changed since then.

What you're referring to is (AFAIR) some kind of localized networks, so
that one guy in the neighborhood gets IPv6 connectivity, and provides it
to the others using ISATAP.  (Btw, you should be careful to analyze how
the ISATAP users verify that the ISATAP router is legal in this case.)

I really don't see that as a relevant _mainstream_ scenario in the
ISP/unmanaged scenarios.  MANETs are outside of the scope of v6ops 
scenarios work AFAICS.