Subject: RE: WG Last Call: draft-ietf-v6ops-mech-v2-01.txt

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 14:49:39 -0500

Nevermind I was sure it was DS for some reason.  My issue is irrelevant.
My mistake. Not sure why I thought that though????????????  But none of
these are major.  Is it worth me going thru that still?  I don't mind?

For example we all killed the auto tunnels and compatible addreses long
ago.  What we did as this spec is so key to base transition is
implemented as the changes took place.  None of them were any large code
or architecture changes to the code base.  Not saying all were done but
the important ones.  And running now.  

I was sure we did implementor reports and all of that for 2893
??????????????

Yes it should move to DS when this completes.  I think you can get
implementor reports too.

This took too long to recycle for what was changed is other input to you
as chair. Perfect example of how ineffective we are with our process.  

My mistake,
/jim

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Thursday, November 06, 2003 1:41 PM
> To: Bound, Jim
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: WG Last Call: draft-ietf-v6ops-mech-v2-01.txt
> 
> 
> On Thu, 6 Nov 2003, Bound, Jim wrote:
> > Given that we have so much work to do and given the IETF 
> does agree we 
> > have a time-to-market or get the spec done problem it is a backward 
> > step to go to PS and we should remain DS.
> 
> I'm not sure what you mean with "remain DS".
> 
> Do you mean, "go from PS to DS, as planned previously" ?
> 
> Or, "remain at the DS level" (taken literally) -- which would 
> be factually incorrect, because RFC2893 is only PS.  (If 
> RFC2893 was DS, I'd certainly
> agree.)
> 
> > There is nothing technically complex changed or even required to 
> > change in implementation.
> 
> I think the MTU sections, at least, have seen some rather 
> extensive changes.  (Of course, the amount of editorial 
> corrections and clarifications is also large.)  I'm not sure 
> if we could find many conformant implementations out of the 
> box (not sure if that'd be required, of course).
> 
> Some further modifications based on LC comments are also very 
> likely.  
> What is the amount (and scope) of those changes is of course still a 
> question mark.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> 
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 7 Nov 2003 08:14:07 -0800

> Yes it should move to DS when this completes.  I think you can get

process-nazi nit:

it is not 'implementor reports' we need for ds.  it is
'interoperability reports'.  what we are doing is testing
the spec to see if it is sufficiently clear that multiple
implementors get the same semantics for each bit of the
spec.

so, for example, we don't care if implementors I0 and I1
don't fully interoperate.  heck, formally, we don't even
care if there are no two interoperable implementations.

we do care that, for each feature/aspect of the spec, F0
through FN, some set of implementations consisting of more
than one member interoperate for that feature.

randy