Subject: RE: focussing energies

From: "Carl Williams" <[email-masked]>
Date: Mon, 15 Mar 2004 14:12:38 -0800

Good points.

There is also the case whereby the ISP or carrier will
deploy a native IPv6 service but the customer's environment
(or network) is unable to become native IPv6 initially or the
entire access network (or components of) may not be upgraded 
all at once.

So the service provider may also need to be proactive 
in helping the customer in transition by providing 
offering transition services.  

We are looking at transition methods for moving our network
- both fixed line service and 3G services - to native IPv6.
We are also looking at helping the end customer transition
(be it home networking, services to the enterprise, or other service
deployments).  Here we are looking at automatic tunneling 
methods to aid in those deployment services.

The service provider must have a total plan - and not just
build a native IPv6 network and hope that the IPv6 traffic
will come.  

Carl

Original Message:
-----------------
From: Alain Durand [email-masked]
Date: Mon, 15 Mar 2004 09:44:04 -0800
To: [email-masked]
Subject: focussing energies

So, what to get from these latest discussion?
My 0.02$:

a) the best model is to get ISPs to deploy IPv6 to their customer. No 
transition mechanism is better
than anything else. Most ISPs won't do it unless there is strong 
motivation:
- political mandate to do so
- political incentive (like tax break)
- customer asking for it
The first two are outside the realm of IETF. The last one will only be 
driven by the new applications
requiring/working better with IPv6. Nothing here that this wg can do 
about.

b) assisted tunneling works best in the scenario of an ISP willing to 
offer IPv6 service
but not ready yet to pay to deploy native service. Those mechanisms, 
like tunnel broker,
not only provide IPv6 connectivity to the user, but also to help the 
ISP to jump start
IPv6 service to its customers at low cost. This is an area where 
standardization from
this wg could help a lot.

c) when ISPs are not cooperating, there is the choice between two evils:
- fully automatic solutions, with their share of complexity, security 
issues,...
- tunnel brokers operated by third parties, with possible sub-optimal 
paths and complex set-up.

The point I'm trying to make is that, IMHO, this wg should not spend to 
much effort on c)
[i.e. there are implemented solution, let's document them and move on]
because:
	1) either IPv6 will take off and ISPs will start to cooperate,
thus 
we're back to case b)
	2) ISP still don't cooperate in the near future, meaning that
they see 
IPv6 as going nowhere,
	so why should this wg and software vendors invest in complex 
transition mechanisms?
and focus its energies on standardizing a solution for b)

	- Alain.

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 18 Mar 2004 00:28:32 -0500

U.S. DOD date is 2008.
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of EricLKlein
> Sent: Monday, March 15, 2004 2:03 PM
> To: [email-masked]
> Subject: Re: focussing energies
> 
> From: "Alain Durand" <[email-masked]>
> >
> > transition mechanism is better than anything else. Most 
> ISPs won't do 
> > it unless there is strong
> > motivation:
> > driven by the new applications requiring/working better with IPv6. 
> > Nothing here that this wg can do about.
> >
> Just keep in mind that some governments have mandated that 
> all services be transitioned to IPv6 by fixed dates (off the 
> top of my head I know that Japan and the EU have mandated 
> dates) but I am not sure what the penalties are for failing 
> to meet these mandates.
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 18 Mar 2004 00:39:14 -0500

recommend is not the same as mandate.
/jim 

> Sent: Tuesday, March 16, 2004 4:02 AM
> To: [email-masked]
> From: "Brian E Carpenter" <[email-masked]>
> > The EU has certainly not mandated any such thing. They burnt their 
> > fingers badly with OSI mandates 15 years ago, and are unlikely to 
> > repeat that mistake. There is substantial EU support for IPv6 
> > deployment, but that is far from being a mandate.
> >
> >   Brian
> 
> Correct, they have initiated the eEurope 2005 program that is 
> "recommends"
> deployment by 2005, with each country forming their own plan. 
> It looks like the UK and France are pushing to be first with 
> several others in close second (only Italy seems to be 
> without a plan).
> Eric
> 
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 19 Mar 2004 01:31:28 -0500

Agreed.  I would add telling the market how/what to deploy is out of
bounds too.  Pekka S. is the biggest offender.  Start off with a list of
protocols for design each with their own thread I suggest.
/jim 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, March 18, 2004 2:41 PM
> To: EricLKlein
> Cc: JORDI PALET MARTINEZ; Bound, Jim; [email-masked]
> When I started this thread, the point was  'where this wg 
> should focus' 
> energy
> from a protocol perspective, not on various mandate & killer apps.
> I apologize to this group if the thread I started has derived 
> into this.
> Please, as Pekka asked, lets get back to protocol design.
> 
> 	- Alain.
> 
> 
>