Subject: RE: Using L2TP [RE: Need for TSP? RE: Tunneling scenarios and mechanisms evaluation]

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 03:32:14 -0500

> L2TP appears very heavyweight (even the spec is over 100 pages) for
 > this specific purpose, especially for some scenarios -- e.g., 3GPP
 > network for UE tunneling.

=> I don't think the 3GPP deployments will use either
L2TP or TSP. I think they'll want something like ISATAP
if native connectivity is not available.

 > 
 > So, my personal gut feeling at this point is that L2TP is probably
 > applicable in the environments which already have the machinery in
 > place, but is a pain to set-up, and has significant complexity and
 > overhead which are probably drawbacks in a few scenarios at least.

=> Other than the above scenario, I don't see any problems with
it. Especially when the alternative is to develop a new
protocol. The point is, it's already implemented by several
vendors and deployed, why would we want to invent something 
new in this space? "Too complex" is not a good reason IMHO.

 > 
 > We could actually achieve more than L2TP with simply IPsec with NAT
 > traversal (as outlined in a separate thread previously) -- but there
 > are some issues here to be investigated -- the biggest problem AFAICS
 > is the implementation status.  But I'm not certain this is a feasible
 > approach in all the scenarios either...

=> Exactly, also protecting traffic with IPsec was never a requirement
that must be satisfied by all transition mechanisms.

Hesham

 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 >

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 03:32:14 -0500

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 03:32:14 -0500

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 03:32:14 -0500

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 03:32:14 -0500

Hesham