Subject: RE: v6 deployment in general [Re: tunnel broker deployment [RE: Tunneling scenarios and mechanisms evaluation]]

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 01:11:24 -0500

> -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On
 > Behalf Of Alain Durand
 > Sent: Tuesday, March 16, 2004 12:39 AM
 > To: Pekka Savola
 > Cc: [email-masked]
 > Subject: Re: v6 deployment in general [Re: tunnel broker 
 > deployment [RE:
 > Tunneling scenarios and mechanisms evaluation]]
 > 
 > 
 > 
 > On Mar 15, 2004, at 1:11 PM, Pekka Savola wrote:
 > >
 > >> Stable addresses across reboot may be necessary.
 > >> I want to be able to build apps that take advantage of 
 > the large IPv6
 > >> address space and consider that addresses are stable.
 > >
 > > So, you want to build a simple application.  Don't we 
 > all.. :)  But I
 > > don't think this is something we can guarantee even with native
 > > access.  

=> Yes we can ! Why not? 

   ISPs just aren't offering static v4 addresses 
 > today 

=> Yes they are ! You just pay more for them.

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 01:11:24 -0500

=> Yes we can ! Why not? 

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 01:11:24 -0500

=> Yes we can ! Why not? 

Hesham

---

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 16 Mar 2004 01:11:24 -0500

=> Yes we can ! Why not? 

Hesham

---

From: "Christian Huitema" <[email-masked]>
Date: Tue, 16 Mar 2004 13:16:40 -0800

> > In practice the NAT mappings do not change and the Teredo address
> > remains reasonably stable.
> 
> unless the global IPv4 address of the NAT box is changed every 24
hours
> by the ISP...

The Teredo code will detect that change, and inform the applications on
the box that the local IP addresses have changed. This is supposed to
trigger whatever update is necessary in the application, e.g., a dynamic
DNS update. 

Note that the ISP who go to the trouble of renumbering their
subscribers' IPv4 address every 24 hours are very likely to renumber the
IPv6 prefix every 24 hours, for the same reason. 

-- Christian Huitema

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 17 Mar 2004 08:51:32 -0800

> As for what Christian said about Teredo reacting to these on-the-fly
> address changes -- the spec says nothing of the sort, but may be of
> course done by the implementation.  Might not hurt to add some text on
> that specific case.

Check the section on maintenance. The client is supposed to regularly
repeat the qualification procedure, and will detect a change in
mappings.

-- Christian Huitema

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 18 Mar 2004 00:24:32 -0500

Suggestions to take or leave Pekka: Just build specifications.  Stop
trying to define and mandate policy.  Provide specs that inform of
dangers.  No one cares or listens to anytbing else from a standards
body. 6to4 is a done deal.  Security notes are good.  Other mechansims
are TBD with ISATAP and TSP leading behind 6to4.  Manual config will
always exist.  More adoption will need more mechanisms for the tool box.

/jim 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pekka Savola
> Sent: Monday, March 15, 2004 1:08 PM
> To: Alain Durand
> Cc: [email-masked]
> Subject: v6 deployment in general [Re: tunnel broker 
> deployment [RE: Tunneling scenarios and mechanisms evaluation]]
> 
> On Mon, 15 Mar 2004, Alain Durand wrote:
> > On Mar 14, 2004, at 11:23 PM, Pekka Savola wrote:
> > >> This won't work with non-static IP's and getting the same prefix 
> > >> back though,
> > >
> > > Sure; but this would probably be sufficient for the average John 
> > > Doe, right?
> > 
> > What John Doe wants is irrelevant. What the IPv6 
> applications require 
> > is.
> 
> Also, on the other hand, IPv6 is rather irrelevant unless we 
> can make the assumption that it will be used by John Doe.  
> I.e., if we want to change the Internet, we need mass.  Guys 
> like John Doe are the key to obtaining that critical mass.
> 
> > Now, are you telling us that the potential IPv6 'killer 
> apps' will not 
> > need stable addresses? Making this assumption is very 
> dangerous, IMHO.
> 
> I'm not saying that at all.  I'm just saying that there are 
> limits to the requirements for the duration of such 
> addresses.  For example, must John Doe's address stay stable 
> if he shuts down his home PC, and leavs for 1-week trip to 
> Tahiti, and then returns?  
> 
> It might not hurt, but the applications and the systems must 
> IMHO be designed to deal with the situation that when they 
> (re)start, the address might be different. I.e., the lifetime 
> of the address does not
> *necessarily* have to be longer than the lifetime of the 
> application process.
> 
> On the other hand, as long as John Doe's home PC stays 
> powered on and connected to the Internet, his address should 
> stay stable.
> 
> > >> They found MSN, Yahoo, Google, KaZaA etc. Friends tell 
> that is the 
> > >> trick to it, if there is interresting enough content 
> even 13 year 
> > >> olds can configure it.
> > >
> > > Right. If we assume IPv6 would have killer applications 
> which would 
> > > make the users really eager to get it, sure -- everything would 
> > > probably be simpler.  But in the absence of such, we need 
> to forward 
> > > without them :-).
> > 
> > In the absence of such, what is the justification of IPv6?
> 
> I'd rather not open this can of worms, but leave it as an 
> exercise of the reader.
> 
> As some have pointed out, we wouldn't have needed anything 
> other than dual-stack (or the like) if we assumed that there 
> will be strong killer app.  When such app would appear, 
> everyone would just upgrade, end of story, happy end.  
> Unfortunately, IMHO, we need to move forward without making 
> an assumption that such an app would miraculously appear; 
> there will probably be ones (e.g., some p2p apps) which will 
> help to drive the transition along, but again, this is 
> something we should be counting on.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 18 Mar 2004 00:38:19 -0500

This does not hold true with twice-nat correct?
thanks
/jim 

> [mailto:[email-masked]] On Behalf Of Christian Huitema
> Sent: Tuesday, March 16, 2004 3:18 PM
> To: Erik Nordmark; Pekka Savola
> Cc: Alain Durand; [email-masked]
> Subject: RE: v6 deployment in general [Re: tunnel broker 
> > > The problem is worse with transition mechanisms, 
> especially the ones 
> > > which traverse NATs, but the situation may improve as 
> soon as we can 
> > > get rid of them.  In any case, such mechanisms can 
> provide a stable 
> > > as long as they can keep the NAT/IP mappings stable -- 
> which is, for
> a
> > > properly designed application, maybe sufficient.
> > 
> > I guess I don't understand what "such mechanisms" refer to above.
> > I don't know if mechanisms like Teredo can provide a stable IPv6
> address
> > when the nat mappings change, but doing TB/UDP for nat traversal
> should be
> > able to provide stable IP addresses/prefixes in this case.
> 
> In practice the NAT mappings do not change and the Teredo 
> address remains reasonably stable.
> 
> -- Christian Huitema
> 
> 
>

---

From: "Dave Thaler" <[email-masked]>
Date: Thu, 18 Mar 2004 10:31:51 -0800

Alain Durand writes:
> On Mar 16, 2004, at 12:17 PM, Christian Huitema wrote:
hours 
> by the ISP...

Since we all want to see IPv6 native deployed, I'll point out that the
same sort of ISP could use DHCPv6 and change the IPv6 address every 24
hours too.  Hence providing addresses more stable than native
connectivity gives is not always a good thing as it could result in an
incentive for clients to not want/use native IPv6.

Instead, if an app needs more address stability that what native
connectivity (IPv4 or IPv6) gives, perhaps it would be better off using
a mechanism such as a Mobile IPv6 home address.

-Dave