Subject: RE: 6to4 being replaced by Teredo only? [Re: Tunneling scenarios and mechanisms evaluation]

From: "Christian Huitema" <[email-masked]>
Date: Tue, 16 Mar 2004 21:19:27 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Erik Nordmark
> Sent: Tuesday, March 16, 2004 4:17 PM
> To: Rob Austein
> Cc: [email-masked]
> Subject: Re: 6to4 being replaced by Teredo only? [Re: Tunneling
scenarios
> and mechanisms evaluation]
> 
> > Terado is excessively complex for the case of a user who wants IPv6
> > capability from an IPv4-only ISP and has the ability to replace the
> > NAT box.  Yes, Terado could probably be used in this case instead of
> > 6to4; pigs also fly just fine, given sufficient thrust [RFC1925],
but
> > that doesn't make either of these a good idea.
> 
> Since I feel responsible for triggering Pekka's question let me
> try to explain myself.
> 
> In a world with native, 6to4, and teredo we need to be concerned with
> the operational issues of gettting relays deployed to enable
communication
> between the 3 different universes:
>  - native to/from 6to4
>  - native to/from teredo
>  - 6to4 to/from teredo
> 
> Can we simplify the deployment of these so that we can reduce the
> likelihood of ending up with a partitioned IPv6 Internet?

In fact, Teredo will work if we have: 
  - native to/from 6to4
  - native to/from Teredo
You will simply get 6to4-native-Teredo.

Note that we are also deploying host-based Teredo relay in the next
Windows XP service pack. A dual-stack Windows host with either 6to4 or
native connectivity will know how to send packets to Teredo peers using
Teredo over UDP and IPv4, effectively offloading the network based
Teredo relays.

-- Christian Huitema

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Mar 2004 12:40:40 +0100

> You will simply get 6to4-native-Teredo.

I fully agree. I think we should use native IPv6 as the "lowest common
denominator" (although "lowest" is perhaps the wrong word :-). This seems
to give a much better exit strategy from coexistence.

   Brian

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 17 Mar 2004 14:24:27 -0800 (PST)

> Teredo over UDP and IPv4, effectively offloading the network based

That helps, but I think we also need to look at what can be done from
IETF's perspective to "encourage" the deployment of the needed relays
in the network.

  Erik