Subject: RE: draft-daniel-dhc-ipv6in4-opt-03.txt

From: <[email-masked]>
Date: Thu, 27 May 2004 15:26:17 +0300

Hi, Peter!

There is also a simpler, usable mechanism if v6-in-v4 tunneling is needed in a 3GPP UE: ISATAP. That does not require DHCP implementation in the UE. See Dave's comments here:
http://ops.ietf.org/lists/v6ops/v6ops.2004/msg00814.html

BR,
	-Juha-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Grubmair Peter
Sent: 27 May, 2004 14:52
To: V6ops_Discussion (E-mail)
Subject: draft-daniel-dhc-ipv6in4-opt-03.txt

Dear Sirs, 
I highly appreciated finding your draft 
concerning "DHCP Option for Configuring IPv6-over-IPv4 Tunnels" 
at IETF. 
To my mind this is one of the simplest form of a first transition 
for mobile (GPRS) operators to supply IPv6 to 
their customers. 
After finding the tunnel endpoint via your DHCP option 
a dual stack mobile phone can do autoconfiguration (or DHCPv6) 
accros the tunnel and obtain a globally unique IPv6 address, 
allthough its IPv4 address is only private. 
(no DAD is needed as link-local address is constructed from 
IPv4 address, which is unique within operators area). 
tunnel establishment at operator side could be done with adhoc mode
as described in >>Simple IPv6-in-IPv4 Tunnel Establishment Procedure
(STEP)<<
(draft-savola-v6ops-conftun-setup-02.txt)
this could be the m
I hope that your suggestion evolves to an RFC soon. 
Best regards 
   Peter Grubmair

---

From: Pekka Savola <[email-masked]>
Date: Sat, 29 May 2004 08:51:17 +0300 (EEST)

On Thu, 27 May 2004 [email-masked] wrote:
> There is also a simpler, usable mechanism if v6-in-v4 tunneling is
> needed in a 3GPP UE: ISATAP. That does not require DHCP
> implementation in the UE. See Dave's comments here:

While ISATAP may be slightly simpler from the server's implementation 
point-of-view, it has problems of its own.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 01 Jun 2004 09:04:38 +0900

Both drafts need some means to get IPv4 address
of tunnel server. DHCPv4 fits best for this purpose.

This proposal would be directly applycable to the
ad-hoc tunnel servers in this draft

Above all, my original approach is for ISP aspect
to provide IPv6 connectivity though it's a temporary
connection.So far almost ISPs do not need to change
their current network for the IPv6 service, thus as
stated, this mechanism can be used to provide
the IPv6 services without upgrading all their (ISPs)
infrastructure to support IPv6 on day one.

We implemented it and this mechanism is very 
useful for us to connect IPv6 services from our
IPv4 networks (host has a dual stack of course)

- Daniel (Soohong Daniel Park)
- Mobile Platform Lab. Samsung Electronics.

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Thursday, May 27, 2004 9:26 PM
> To: [email-masked]; [email-masked]
> Subject: RE: draft-daniel-dhc-ipv6in4-opt-03.txt
> 
> 
> 
>  Hi, Peter!
> 
> There is also a simpler, usable mechanism if v6-in-v4 tunneling 
> is needed in a 3GPP UE: ISATAP. That does not require DHCP