Subject: Re:Teredo vs Silkroad

From: "Eiffel Wu" <[email-masked]>
Date: Fri, 21 May 2004 16:02:59 +0800

As compared with the Teredo, Silkroad has the following strongpoints:
1. it can provide the users with unchangeable IPv6 addresses, while Teredo address is altered every time the users restart the Teredo service.
2. Silkroad can deploy without the support of relay, while the Teredo needs the relay which advertises the reachability of Teredo Prefix.
3. Silkroad supports all types of NATs, while Teredo doesn't support symmetric NATs.

>Hi,
>
>In draft-liumin-v6ops-silkroad-01.txt it is said that Silkroad wants to enable nodes located behind one or several IPv4 NATs to obtain >IPv6 connectivity and it seems like a tunnel-broker solution. 
>It is known that Teredo is a automatic tunnel mechanism that figures out the same problem.
>
>What's the difference between Silkroad and Teredo?
>
>
>Best regards,
>
>Crisy(Rengrong) Wang
>=======================================
>USC,EE-Systems

---

From: Tim Chown <[email-masked]>
Date: Fri, 21 May 2004 09:56:21 +0100

On Fri, May 21, 2004 at 04:02:59PM +0800, Eiffel Wu wrote:
>    1.  it  can  provide the users with unchangeable IPv6 addresses, while
>    Teredo   address   is   altered  every  time  the  users  restart  the
>    Teredo service.
>    2.  Silkroad can deploy without the support of relay, while the Teredo
>    needs the relay which advertises the reachability of Teredo Prefix.

Any public implementations?

Tim

---

From: "Liu Min" <[email-masked]>
Date: Fri, 21 May 2004 17:30:56 +0800

The SAR(Silkroad Access Server) has been implemented in PC. With
cooperation of Chongqing Netcom, it has been deployed in ChongQing IPv6
MAN. At present, the SC(Silkroad Client) has been implemented based on
Linux. The windows version will be completed soon. Next, we will try to
add silkroad function to some routers.  

Best Wishes,
 
Liu Min
Institute of Computing Technology
Chinese Academy of Sciences
Tel: (86-10) 6256 5533-9240 
E-mail: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Tim Chown
> Sent: Friday, May 21, 2004 4:56 PM
> To: [email-masked]
> Subject: Re: Teredo vs Silkroad
> 
> >    3.  Silkroad  supports all types of NATs, while Teredo doesn't
support
> >    symmetric NATs.

---

From: Pekka Savola <[email-masked]>
Date: Fri, 21 May 2004 13:41:56 +0300 (EEST)

Combining two posts in one..

On Fri, 21 May 2004, Eiffel Wu wrote:
> 2. Silkroad can deploy without the support of relay, while the
> Teredo needs the relay which advertises the reachability of Teredo
> Prefix.

That's not really true, I think.  You can deploy Teredo using your 
own, arbitrary prefix, ("internal Teredo server"), and to the rest of 
the Internet, it looks like native IPv6 service.

> 3. Silkroad supports all types of NATs, while Teredo doesn't support

Obviously, this could be added very easily to Teredo as well, but it 
would require that Teredo servers would act as tunnel endpoints, and 
there would not be direct tunneling.  That would burden the servers to 
that it would probably be undesirable.

> Silkroad can configure the Silkroad Clients with structured consecutive
> global IPv6 addresses, without any special prefix like Teredo, 

Teredo can be deployed (internally) using any prefix, but there is
likely going to be one well-known prefix.

> this feature
> will do good to the IPv6 routes aggregation in the network, which will
> condense the amount of IPv6 routes entries.

This isn't a real problem as those routes don't need to be exported 
out of one router.

> To deploy Teredo, Teredo Server should be added to help setup the connection
> with Teredo Client, and Teredo Relay function is needed at the routers
> access to IPv6 sites, and Teredo Relay Teredo Server should both traverse
> NAT, all these demands requires the updation to the router access to IPv6
> sites. and the number of such routers will be very large, so the updation
> work is somewhat painful for the customers.

The part about Teredo Relay is untrue.  Yes, a relay is needed, 
somewhere in the network (or hosts), but it doesn't need to be done in 
every routers.  Most likely it won't, but there would be e.g., just 
one relay in the network.

> While Silkroad can be compatible with the current network, the routers
> needn't be updated, even the Silkroad Navigator is not needed in the simple
> netowrk,and the SAR(Silkroad Access Server) can be deployed at any place in
> the network.

The deployment complexity is likely very close to Teredo.  You only
need one box, Teredo server which also acts as a relay, anywhere in
the network, and you don't need to change anything else.  (This
doesn't work through symmetric NATs without tricks of course.)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings