Subject: POLL: SPs' IPv6 (tunnel) deployment requirements (fwd)

From: Pekka Savola <[email-masked]>
Date: Tue, 2 Nov 2004 13:00:00 +0200 (EET)

FYI -- let's see if we manage to get any SP operator feedback on 
tunneling requirements...

---------- Forwarded message ----------
Date: Tue, 2 Nov 2004 12:59:00 +0200 (EET)
From: Pekka Savola <[email-masked]>
To: [email-masked]
Subject: POLL: SPs' IPv6 (tunnel) deployment requirements

Hi,

(To avoid a lot of spamming on nanog, please send the replies to me off-list 
and I can summarize, or only to [email-masked] if you think it deserves 
wider attention.)

IPv6 Operations WG at IETF is considering requirements and scenarios for 
v6-in-[udp]v4 solutions, especially as would be deployed by ISPs.

Unfortunately, there has been rather low amount of feedback from the operators, 
and we'll need more to find solutions that are actually close to what the 
operators want.. so, I'm trying here.. Please respond within a week or so.

A couple of questions (no need to answer to all if you don't want to):

  1. have you yet made plans how to deploy IPv6 towards
    (home) customers?
    a/ If yes, have you planned to use (only) dual-stack?
    b/ If yes, have you planned to use some form of tunneling?
    c/ If yes, using both as appropriate?

[[ The rest are relevant only with 1.b) or 1.c) ]]
  2. are you currently using L2TP or some other infrastructure for
     IPv4?
    a/ Is that adaptable to IPv6 (e.g., by adding v6 support to PPP)?
    b/ If yes, would it be a sufficient solution for your needs.  If
       not, please elaborate?

  3. in case L2TP is not done towards v4 customers now, have you
     planned or would you be interested in deploying v6 tunneling
     towards customers?
    a/ for free? (added value, competitional advantage, etc.)
    b/ for a fee?

  4. what would be your requirements for 3)?  Please elaborate a bit.
    For example, are some (which ones?) of the following relevant:
    - need to be used for own customers only
    - authentication based on IP addresses or similar
    - must it be capable to offer service to non-customers or roaming
      own customers through some registration process?
    - capability for doing prefix delegation to the customers
    - must work through a NAT (e.g., non-upgraded CPE)
    - should be possible to deploy multiple boxes easily
    - should be capable of v4-in-v6 tunneling also

  5. any other comments or questions?
    - shoot!

...

The two existing requirements documents, for two slightly different problem 
spaces (first for "easy set-up within your access network", the second 
"registered, more complicated mode for more extensive use"), are the following:

http://www.v6ops.euro6ix.net/ietf/draft-suryanarayanan-v6ops-zeroconf-reqs-01.txt
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-assisted-tunneling-requirements-01.txt

For a lengthier document describing BB ISP IPv6 deployment options, see:

http://www.ietf.org/internet-drafts/draft-asadullah-v6ops-bb-deployment-scenarios-01.txt

Feedback on these is also welcome, of course!

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Ralph Droms <[email-masked]>
Date: Tue, 02 Nov 2004 08:37:20 -0500

Pekka - you've aimed some interesting questions in a good direction.  Thanks.

Would you be willing to make the full text of any responses available in 
some form?  Perhaps forward responses directly to v6ops or post the 
responses on the v6ops web page?

- Ralph

At 01:00 PM 11/2/2004 +0200, Pekka Savola wrote:
>FYI -- let's see if we manage to get any SP operator feedback on tunneling 
>requirements...
>
>(To avoid a lot of spamming on nanog, please send the replies to me 
>off-list and I can summarize, or only to [email-masked] if you think 
>it deserves wider attention.)
>
>Unfortunately, there has been rather low amount of feedback from the 
>operators, and we'll need more to find solutions that are actually close 
>to what the operators want.. so, I'm trying here.. Please respond within a 
>week or so.
>
>The two existing requirements documents, for two slightly different 
>problem spaces (first for "easy set-up within your access network", the 
>second "registered, more complicated mode for more extensive use"), are 
>the following:
>

---

From: Pekka Savola <[email-masked]>
Date: Tue, 2 Nov 2004 15:42:06 +0200 (EET)

On Tue, 2 Nov 2004, Ralph Droms wrote:
> Would you be willing to make the full text of any responses 
> available in some form?  Perhaps forward responses directly to v6ops 
> or post the responses on the v6ops web page?

The responses might be subject to anonymity/confidentiality, but I'll 
see what I can do depending on the responses obtained during the week.

Certainly if there are a lot of responses there will be interesting 
data points beyond the tunnel deployment requirements.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 02 Nov 2004 18:22:24 +0100

Agree very good movement. I've forwarded it to other mail exploders where
some operators may provide inputs from other regions.

Regards,
Jordi

> De: Ralph Droms <[email-masked]>
> Responder a: [email-masked]
> Fecha: Tue, 02 Nov 2004 08:37:20 -0500
> Para: Pekka Savola <[email-masked]>
> CC: [email-masked]
> Asunto: Re: POLL: SPs' IPv6 (tunnel) deployment requirements (fwd)
> 

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 3 Nov 2004 20:47:47 -0600

Hi, Pekka,

Thank you for sending this off to NANOG.

I applaud anything the Operations Area does to increase dialog with 
NANOG, and the nice people at the NANOG 31 IETF feedback BoF said they 
really were interested in talking to us, they just had no clue how to 
figure out what we are doing or who to give feedback to...

Spencer