Subject: updated v6ops agenda, presentation of way forward

From: Pekka Savola <[email-masked]>
Date: Wed, 10 Nov 2004 01:51:59 +0200 (EET)

Hi,

Slightly modified agenda for tomorrow (relating to the way forward and 
tunneling discussions) is below and posted at:

   http://netcore.fi/pekkas/ietf/61/v6ops-agenda.txt

Also, the rough slides (these will be updated a bit) are available 
beforehand at:

   http://netcore.fi/pekkas/ietf/61/way-forward.pdf

....

Wednesday 10th November -- 0900-1130
====================================

*** CRITICAL PATH ACTIVITIES ***

Introduction, agenda bashing, document status - 5 mins, Chairs/Savola
   - Scribes! (Jabber also?)

Enterprise Analysis Discussion, 15 mins, Bound
  - draft-ietf-v6ops-ent-analysis-00.txt
  - GOAL: discuss issues, so that the revision can be WGLC'ed

Discussion of the way forward - 30 mins, Chairs/WG
  - http://netcore.fi/pekkas/ietf/61/way-forward.pdf
  - http://netcore.fi/pekkas/ietf/61/v6ops-dow.txt
  - http://netcore.fi/pekkas/ietf/61/v6tc-charter.txt
  - http://netcore.fi/pekkas/ietf/61/v6tc-justification.txt
  - GOAL: discuss the scope of v6ops WG work; gain consensus on the way forward

Goals for Zero-Configuration Tunneling in 3GPP, 1 min, Nielsen
  - draft-nielsen-v6ops-3GPP-zeroconf-goals-00.txt
  - GOAL: To highlight the particularities of the 3GPP case

Generic Zero-Configuration Tunneling, 10 mins, Palet
  - http://www.v6ops.euro6ix.net/ietf/draft-suryanarayanan-v6ops-zeroconf-reqs-01.txt
  - GOAL: Discuss the issues raised, if needed.

*** OTHER IMPORTANT WORK ***

IPv6 Network Architecture Protection, 10 mins, Van de Velde
  - draft-vandevelde-v6ops-nap-00.txt
  - GOAL: introduce and start the discussion about v4 NAT alternatives in IPv6

Reason to Deprecate NAT-PT, 15 mins, Davies
  - draft-aoun-v6ops-natpt-deprecate-00.txt
  - GOAL: 5 mins presentation, 10 mins trying to decide next steps

ISP IPv6 Deployment Scenarios in Broadband Access Networks, 15 mins, Popoviciu
  - draft-asadullah-v6ops-bb-deployment-scenarios-01.txt
  - GOAL: get feedback; gauge interest and the direction

IPv6 Fix: an activity to solve barriers to IPv6 transition, 7-10 mins, Tatuya
  - A new WIDE project to fix practical IPv6 deployment issues
  - GOAL: inform the WG of activities, solicit the interested people

*** MAY BE SKIPPED IF RUNNING OUT OF TIME ***

Discussion of Teredo IETF LC comments, 5 mins, Huitema
  - draft-huitema-v6ops-teredo-02.txt
  - GOAL: describe and discuss the important IETF LC comments

IPv6 Security Overview - 5-7 mins, Davies
  - draft-savola-v6ops-security-overview-03.txt
  - GOAL: talk about differences, solicit more feedback

Things to think about when renumbering, 5-7 mins, Thompson
  - draft-chown-v6ops-renumber-thinkabout-00.txt
  - GOAL: introduce the draft, solicit feedback for next revision

IP Mobility Scenarios discussion, 5 mins, Gustafsson
  - draft-larsson-v6ops-mip-scenarios-00.txt
  - GOAL: update from the IP mobility scenarios/requirements discussion

-END-

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 10 Nov 2004 07:53:23 -0500

Pekka,

For clarity.  You say multiple proposals are "probably" ok?  That sounds
dictatorial and I don't think you mean't it that way did you?  The
objective of the IETF is to bring good ideas to our body?

Please clarify for the community your statement?

Thanks
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pekka Savola
> Sent: Wednesday, November 10, 2004 7:10 AM
> To: Syam Madanpalli
> Cc: [email-masked] 
> Subject: Re: updated v6ops agenda, presentation of way forward
> 
> On Wed, 10 Nov 2004, Syam Madanpalli wrote:
> > We are going to develop an entirely new protocol based on the ZCT 
> > Requirements?
> 
> If you read it carefully, the proposal goes a bit further 
> than the original ZCT proposals, because the authentication 
> scenario is also included. (Feedback is welcome on this.)
> 
> > or WG wants to start with some existing methods and form a 
> design team 
> > to develop an unified method?
> 
> That would remain to be seen.  Multiple proposals are 
> probably also OK.  I would expect at least some small team is 
> going to get together and try to propose at least one solution.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 10 Nov 2004 07:56:03 -0500

Pekka,

Thanks for the response.  No I had not heard that about Teredo status
only that it had went to the IESG so that is good I agree.

I will think about it I am thinking now it might be faster to do this
out of the IETF if a process can be created and support an open
standards view in another body.

Thanks
/jim 

> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Wednesday, November 10, 2004 7:43 AM
> To: Bound, Jim
> Cc: [email-masked]
> Subject: RE: updated v6ops agenda, presentation of way forward
> 
> Jim,
> 
> Just clarifying a few points below..
> 
> On Wed, 10 Nov 2004, Bound, Jim wrote:
> > I want to be sure I read this correctly.  But, the way I 
> read the URLs 
> > below, which are all pretty good, there is no place to work on 
> > transition mechanisms we all have been waiting to work on since 
> > NGTRANS in the IETF. There is no protocol group to work on 
> transition 
> > mechanisms other than v6ops.
> 
> It was thought to be a good idea not to create a generic 
> protocol working group, but rather use very focused ones or 
> individual submission as appropriate.  This can of course be 
> discussed during the sessions.
> 
> > But, the IETF again pokes a sharp stick in the eye of all 
> the authors 
> > of Teredo, DSTM, ISATAP, and Tunnel Brokers.  Not to good 
> from my view 
> > and cowardly indirect act, dishonroable, but as it was done in a 
> > process we can't really blame individuals can we now.
> 
> In case you haven't followed closely what has been happening, 
> Teredo has already passed IETF Last Call for PS through an 
> individual submission, and the WG being proposed seems to 
> fulfill the problem space solved by tunnel brokers.
> 
> When the proposal was formulating, there was actually 
> initially some discussion whether v4-over-v6 should be 
> somehow included there. 
> However, it was felt that that would de-focus this work, 
> because we don't really know the scenarios and the 
> requirements yet.  When those are clearer, it could be then 
> decided what would be the most appropriate way to go forward 
> with that work.
> 
> But again, this is something that can be discussed.
> 
> --

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 10 Nov 2004 07:58:14 -0500

Pekka,

I think it is fine to say also that we have tunneling proposals which
exist and what we want to do is work the security which you did follow
up on.  If we believe there are no other good ideas out there right now
because we must ship something which I think is the first priority.

Thanks
/jim 

> [mailto:[email-masked]] On Behalf Of Bound, Jim
> Sent: Wednesday, November 10, 2004 7:53 AM
> To: Pekka Savola; Syam Madanpalli
> Cc: [email-masked]
> For clarity.  You say multiple proposals are "probably" ok?  
> That sounds dictatorial and I don't think you mean't it that 
> way did you?  The objective of the IETF is to bring good 
> ideas to our body?
> 
> > If you read it carefully, the proposal goes a bit further than the 
> > original ZCT proposals, because the authentication scenario is also 
> > included. (Feedback is welcome on this.)
> > 
> > That would remain to be seen.  Multiple proposals are probably also 
> > OK.  I would expect at least some small team is going to 
> get together 
> > and try to propose at least one solution.
> > 
> > --

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 10 Nov 2004 08:10:49 -0500

Thanks for my answer I agree and makes sense to get this done.  FYI
early adopters are setting up tunnels now and using multiple approaches
to discover TEPS.  The ones I am seeing dominant right now are private
company/provider tunnel brokers with set up and hand configured TEPs,
mannual tunnel configured TEPs at edges, and to lesser degree DHCPv6
with custom extensions.  So a TEP discovery solution is required for
sure.

/jim 

> Sent: Wednesday, November 10, 2004 8:05 AM
> To: Jeroen Massar
> Cc: [email-masked]
> First, a clarification to Jim:
> 
> > For clarity.  You say multiple proposals are "probably" ok?  That 
> > sounds dictatorial and I don't think you mean't it that way did you?
> > The objective of the IETF is to bring good ideas to our body?
> 
> Sorry for the word: too few words.  What I meant to say is 
> that multiple proposals are of course OK, but because then 
> the WG would have to apply a selection process, it would be 
> desirable (for speed,
> etc.) not to have *too* many proposals: i.e., having multiple 
> proposals doesn't have inherent value in itself :).  
> Selection among many would likely be a time-consuming 
> process, so the attempt would be to try to propose one that 
> most people would be comfortable with.
> 
> On Wed, 10 Nov 2004, Jeroen Massar wrote:
> > 8<-----------------
> > Propose a new WG to write a new IPv6 over IPv4 tunneling 
> protocol 1. 
> > Based on the tunneling requirements write one new protocol 
> 2. Work on 
> > two components of the solution:
> >   a) method to discover the tunnel end-point
> >   b) specification of the tunnel set-up protocol
> > ----------------->8
> >
> > There are three components to "Tunneling", the third is the actual 
> > protocol, but you mention that in the first part, probably 
> a rephrase 
> > would be better.
> 
> Agreed.  We'll try to do that before the final presentation.
> 
> > Is this only about Tunneling IPv6 over something, or is it 
> a generic 
> > tunneling solution,
> 
> Only about v6 over v4[-udp].  It was felt that the focus must 
> be on what we know reasonably well.
> 
> That is not to say that the solution could not be done in 
> such a way that extending it would be simple later on, but 
> that is not a goal of the work.
> 
> > next to that there are a number of drafts which have been submitted 
> > for quite some time already surrounding this subject and 
> specifically 
> > for doing IPv6 over NAT- crippled IPv4 hosts. I don't 
> recall seeing a 
> > draft about Hexago's v6udpv4 protocol though, not that it 
> is complex 
> > but still.
> 
> Yes, there have definitely been drafts :).  It seemed that 
> these have some short-comings though, so that trying to merge 
> the best parts of each to one proposal might make sense.
> 
> --