Subject: RE: IPv4 consumption statistics and extrapolations

From: "Soliman, Hesham" <[email-masked]>
Date: Sat, 6 Nov 2004 18:10:57 -0500

I think Christian made very important points. 
I'd like to add one point that I'm sure will sound like a broken record to some 
people. Mobile mobile mobile! There are more mobile devices today than IPv4
can handle, period. Everyone is using NATs to build their mobile networks. The question
here is will NATs survive the types of services that operators want to provide? 
From where I'm looking, the problems are profound and extremely difficult to solve. 
 
I think the reason this hasn't been more widely understood is that we're still not close
to seeing those mobile peer to peer services over IP. But when that happens (no speculation
from me here), I think operators will realise what they're in for. This is especially true 
for large operators.
 
So, there is more to this than simply looking at the remaining address space and 
the rates of allocation.
 
Hesham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Christian Huitema
Sent: Saturday, November 06, 2004 5:06 PM
To: Bob Braden; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: IPv4 consumption statistics and extrapolations

> Some 10 years ago, every IETF plenary meeting had a soothsayer session,
> projecting how soon we would run out of IPv4 addresses.  Has anyone
> looked to see how today's data extrapolates from the predictions then?
> Was it as "S" curve, after all??

There are two kinds of S curves, depending on what creates the asymptote. You may have an S curve that flattens when everybody is served (e.g. everybody on earth has a TV set), and another that flattens when the resource is exhausted (e.g. the last cod has been fished). Whether the address allocation falls in one or the other category will certainly be debated...
 
As for extrapolating IANA assignment of /8 addresses, it is an interesting game. The data is available for everybody to look at http://www.iana.org/assignments/ipv4-address-space. If you sort allocations by date, you see three phases:
 
- an initial allocation phase that ends in May 1993 when addresses start to be allocated by RIR using the CIDR policy. At the end of May 93, 94 prefixes are allocated or otherwise reserved.
- a relatively slow growth from May 93 to April 04, during which 50 new prefixes are allocated
- a recent spurt of activity causing 20 allocations between April and November 04.
 
Depending over which period you average, we can argue that the allocation rate is:
- 6.8 per year between 1981 and 2004 (163 blocks divided by 24 years)
- 4.5 per year between May 1993 and April 2004 (50 blocks divided by 11)
- 6 per year between May 1993 and November 2003 (70 divided by 11.5)
- 34 per year lately (20 blocks over the course of 7 months)
I can assume that different soothsayers will pick different values, depending on whether they want to tell us that the sky is falling, or on the contrary that we should not worry.
 
Another point of debate is how many blocks are actually available. Right now, 163 are in use, out of a total of 256, so we may assume that 93 are available. However, 16 of these blocks fall in the former "class E" category, and may or may not be easy to use...
 
-- Christian Huitema

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 07 Nov 2004 07:49:25 -0500

--On 6. november 2004 17:15 -0800 Christian Huitema 
<[email-masked]> wrote:

> By the way, I must apologize. I had a bug in the spreadsheet that I used,
> and the numbers that I quoted are goofy. The consumption did increase
> during the last year, but not quite that fast. Let's say that, depending
> on which number you pick, the consumption per year is between 4 and 10
> blocks, which means an exhaustion in 10 to 15 years if the rates
> continue. But it also mean that we are de facto in the upper size of the
> S curve, because we have passed the 50% capacity point.

your remark reminds me of the red-and-black chart of allocated and routed 
addresses that someone (KC?) showed at an IETF plenary some years back.

Other people called it "proof that there is no problem".

I called it "halfway to Hell".

---

From: "Tony Hain" <[email-masked]>
Date: Sun, 7 Nov 2004 13:18:12 -0800

And for further clarification... I put this response together based on the
data I saw from Geoff a couple of months ago, and couldn't check the URL in
the air. Everyone should check the site because he has included further
evaluation of the data. I apologize for any perception or inference that
Geoff may not have been presenting valid data. The data he has been
presenting is valid for what it measures, our differences of opinion have
been over what and where to measure.

That said, I stand by the point that if the recent depletion rate of 9 /8s
in 6 months holds, there are only 58 months left. That event may have been
an anomaly, or it may be the precursor to an even more accelerated run rate.
We won't know for several years which it was.

Tony

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tony Hain
> Sent: Sunday, November 07, 2004 12:37 PM
> To: 'Geoff Huston'; 'Harald Tveit Alvestrand'
> Cc: [email-masked]; [email-masked]; 'Pekka Savola'
> Geoff Huston wrote:
> > I would like to correct a few numbers in Tony's comments based on my
> work
> > in this area that Tony has referred to.
> >
> > The least squares best fit of advertised address space in the IPv4
> domain
> > over the past 5 years is a consumption rate of 4 /8s per year, slightly
> > less than half of Tony's number
> 
> To continue the refinement; as you frequently point out as well, there is
> a
> lag between request/assignment from the RIR and advertisement. Given that,
> the advertisement growth you are quoting does not account for the recent
> slope change in the IANA pool depletion I am referencing, and won't even
> start to do so for another 6-12 months.
> 
> >
> > Even over the past 10 months the least squares best fit of data is a
> > consumption rate of 5.5/8's per year
> 
> Let's be clear, consumption rate from the pool is not the same as
> advertisement rate you are basing your measurements on. The size of the
> advertised pool has absolutely no bearing on the size of the remaining
> stock
> held by IANA or the RIR's. The slopes may be on a time delayed track, but
> there is always the opportunity for addresses to be pulled from the pool
> yet
> never advertised. As my I-D on 1918bis points out there are organizations
> that have outgrown the available private space, so there only current
> option
> is to acquire public space they never intend to route.
> 
> >
> > At this rate the central pool will exhaust in 2018, some 14 years hence.
> 
> No, by your measure this is the date the advertised pool will be receiving
> all possible prefixes. As we have discussed before, there are two problems
> with these numbers, the first is that it assumes all currently reserved /8
> prefixes can and will be used (by my count there were really only 78
> useful
> ones left in August), and second that it assumes that someone will find
> and
> reclaim the ~13% of the space currently 'lost in the system' (the
> difference
> between the IANA reserved and RIR-assigned).
> 
> > i.e. some 168 months hence. Allowing for an accelerating consumption
> rate
> > at an exponential rate brings this forward to 10 years, or 120 months.
> > (details of the analysis are at http://bgp.potaroo.net/ipv4/)
> >
> > (Of course you should consult your favourite oracle, mystic, soothsayer
> or
> > whatever for your own preferred version of the future.)
> 
> We can probably all agree that the 'last IPv4 address' will never be
> acquired. Policies will become stricter until the price is so high that
> nobody can afford it; or nobody will care once the replacement is
deployed.
> 
> Tony
> 
> >
> > regards,
> >
> >     Geoff
> >
> >
> > At 07:38 AM 6/11/2004, Tony Hain wrote:
> > >Harald,
> > >
> > >I would like to congratulate you on your successes, and suggest you
> have
> > the
> > >opportunity to be the last chair to preside over active work related to
> > >version 4 of the IP protocol suite. With the publication of the
> tunneling
> > >drafts that v6ops has been sitting on, there is no further need to
> > discuss
> > >32 bit address objects. At the same time, there is really no further
> > >justification for any other IETF working group to be discussing 32 bit
> > >addresses in current work. With all due respect to Geoff's efforts to
> > >document the address growth rate in the routing system, even he
> > acknowledges
> > >that measure lags the allocation timeframe and assumes the RIRs will
> > recover
> > >all space currently considered lost. Given that IANA allocated 9 /8's
> > over a
> > >6 month period this year, coupled with the fact that only 78 /8's
> remain
> > in
> > >the useful part of the pool (ie: 52 month burn out), it should be clear
> > to
> > >everyone that products that rely on current standards activities will
> > appear
> > >in the market place after the central pool of 32 bit values has run
dry.
> > As
> > >such I would recommend your legacy include an active review of all
> > working
> > >group discussions next week for items related to IPv4, followed by
> > closure
> > >of all 32 bit address related work items before your departure in
March.
> > >Tony
> > > > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of
> > > > Harald Tveit Alvestrand
> > > > Sent: Friday, November 05, 2004 1:20 AM
> > > > To: [email-masked]
> > > > Subject: Stepping down as IETF chair in March
> > > >
> > > > Thomas' note reminded me that there are probably some people who
> > haven't
> > > > heard this yet....
> > > >
> > > > I'm stepping down as IETF chair in March, and I am not a candidate
> for
> > > > reappointment.
> > > >
> > > > It's been a great four years, containing lots of learning
experience,
> > lots
> > > > of hard work and lots of joy - but after four years as IETF chair,
> and
> > ten
> > > > years total on the IESG/IAB, March seems an appropriate time for me
> to
> > > > leave this stage of my life behind.
> > > >
> > > > The IETF is a great organization. I will enjoy watching it continue
> to
> > > > grow
> > > > and prosper under new leadership.
> > > >
> > > > Thank you!
> > > >
> > > >                   Harald
> > > >
> > > > _______________________________________________
> > > > Ietf mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/ietf
> > >
> > >
> > >_______________________________________________
> > >Ietf mailing list
> > >[email-masked]
> > >https://www1.ietf.org/mailman/listinfo/ietf
> >
> >
> >
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Sat, 6 Nov 2004 12:16:53 -0800 (PST)

*>
   *> At this rate the central pool will exhaust in 2018, some 14 years hence.
   *> i.e. some 168 months hence. Allowing for an accelerating consumption rate
   *> at an exponential rate brings this forward to 10 years, or 120 months.
   *> (details of the analysis are at http://bgp.potaroo.net/ipv4/)
   *>
   *> (Of course you should consult your favourite oracle, mystic, soothsayer or
   *> whatever for your own preferred version of the future.)
   *>
   *> regards,
   *>
   *>     Geoff
   *>
   *>

Just wondering...

Bob Braden