Subject: RE: PI addressing in IPv6 advances in ARIN

From: "Craig Huegen \(chuegen\)" <[email-masked]>
Date: Fri, 14 Apr 2006 09:21:03 -0400

On Friday, April 14, 2006 6:54 AM, Alain Durand wrote:

> A) if PI addresses are to be returned at some point in time,
> they loose a dreat deal of their value. Folks like PI because
> it shields them from renumbering.

I'd like to clarify this a bit.  As a large enterprise network operator,
I'm less concerned about the need to renumber the network once than I am
the need to renumber every time that I want to change a service
provider.  Don't take that the wrong way:  renumbering is still a
significant pain, but the real reason that enterprises haven't adopted
PA space is that it represents a de-facto "lock-in" to the service
providers they choose initially and they're faced with a network-wide
renumber any time they drop or add a service provider.

Most enterprise network operators that I have spoken to would be willing
to renumber once in the future, in exchange for a reasonable way to get
portable IPv6 space today.

> B) any address reclaim process might be lenghty and costly

Maybe I'm being overly simplistic, but the policy can set a recovery
timeframe in its allocation of PI space to end users and the market
forces can drive the recovery based on the impact to the infrastructure.
If only a few hundred prefixes are handed out, it might not be enough of
a problem to force recovery.

This may be a moot point for the ARIN discussion, though, as ARIN
typically doesn't play all that much of an enforcer role.  It can
declare prefixes and prefix ranges as dead, but reachability is
determined by the service providers.

> C) given how long the shim6/multi homing has taken so far, it
> seems hazardous to make any bet that in 3 years it will be
> finish, implemented, adopted, deployed...

I think that Jordi was referring to 3 years after the solution is
declared "available" -- admittedly that's a tough milestone to set.

Finally, I agree with all four other points you make; adoption of IPv6
has been held up because the capabilities offered lack a critical
requirement for enterprise networks (connectivity without de-facto
service provider lock-in).  The agreement to move forward with a policy
is a very positive thing that enables IPv6 to work for large enterprises
while the right solution is determined and rolled out.

/cah

---
Craig A. Huegen, IT Solutions Architect       C i s c o  S y s t e m s
IT - Intelligent Network Solutions                  ||        ||
Cisco Systems, Inc., 400 East Tasman Drive          ||        ||
San Jose, CA  95134, (408) 526-8104                ||||      ||||
email: [email-masked]       CCIE #2100      ..:||||||:..:||||||:..

---

From: "Durand, Alain" <[email-masked]>
Date: Fri, 14 Apr 2006 07:53:33 -0400

Wrt Jordi's proposal:

I have sympathy to the idea of balancing PI need with routing table growth, however:

A) if PI addresses are to be returned at some point in time, they loose a dreat deal of their value. Folks like PI because it shields them from renumbering.

C) given how long the shim6/multi homing has taken so far, it seems hazardous to make any bet that in 3 years it will be finish, implemented, adopted, deployed...

D) I am sensitive to the argument that v4 has not "melted" with PI, so why should v6 melt more? I believe the benefits of handing out PI *now* outweight the cost of a *small* swamp. 

E) given the state of v6 deployment now, I do not think there is much risk with this policy at this moment. And as Thomas relayed, this policy could be changed anyway if things get out of control.

F) if this means giving advantage to the early adopters by offering them PI, I look at this as a positive thing.

G) a key thing is to limit the size of the swamp that would be created, or more specifically limit its growth. So it might be a good idea to have a sunset clause in the policy, like it will have to be revisited in 2 years or when a certain allocation (or allocation rate) threshold will be reached.

    - Alain.

---

From: "Craig Huegen \(chuegen\)" <[email-masked]>
Date: Fri, 14 Apr 2006 10:36:32 -0400

On Friday, April 14, 2006 9:02 AM, Durand, Alain
<mailto:[email-masked]> wrote:

>> -----Original Message-----
>> From: Craig Huegen (chuegen) [mailto:[email-masked]]
>> Maybe I'm being overly simplistic, but the policy can set a
>> recovery timeframe in its allocation of PI space to end users
>> and the market forces can drive the recovery based on the impact to
>> the infrastructure. If only a few hundred prefixes are handed out,
>> it might not be enough of a problem to force recovery.
> 
> One could argue that if we are only talking about a few hundred
> prefixes, Why do we care reclaiming them?

I agree with that argument, _if_ there are only a few hundred.  I'm also
leaving room for a case here that results in tens of thousands of these
prefixes being routed (for instance, if the community can't reach any
consensus on architectures for many years).

I believe that the RIR's who assign PI space should do so with explicit
agreement that there may need to be a reclamation in the future, when a
new architecture exists.  RIR's do not have the ability to enforce that
today except through some specific policy hurdles and perhaps some fee
structuring.  The primary enforcer will likely need to be service
providers, depending upon the pain they feel from having to carry these
prefixes.

/cah

---

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Apr 2006 17:46:48 -0400

Jordi, thanks.  I completely disagree with you.  So we can debate as apppropriate, but at the end of the day any RIR only accepts input from "individuals" not organizations. 

Thanks for your response.

/jim 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of JORDI PALET MARTINEZ
> Sent: Friday, April 14, 2006 6:20 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: PI addressing in IPv6 advances in ARIN
> 
> Hi Jim,
> 
> Not sure if I got your question correctly, but let me try to 
> explain my view.
> 
> I understand the position of the people that say they need PI 
> today, especially because not having it may be hurting the 
> advancement of the IPv6 deployment.
> 
> However, I want to balance this with the medium-long term 
> implications created in the routing table and with the time 
> needed to build and deploy a better technical solution (or 
> several) which is accepted by the community.
> 
> So my proposal basically is about having PI now everywhere 
> (once ARIN adopt it, is unfair not having it in other 
> regions), but those PI allocations for multihoming should be 
> temporary and those address blocks returned to the RIRs some 
> time (lets say 3 years) after the new technical solution is 
> declared as a valid one.
> 
> At this way, on the long-run, we will not have routing table 
> implications, but we allow now the people that want to move 
> ahead only if they have a multihoming solution doing so.
> 
> This 3-years time for getting a multihoming network back to 
> the new technical solution (once adopted) is enough time, I 
> think (it could be changed to 5 years if needed, or 
> whatever), so nobody today see the temporarily of the 
> proposal as a showstopper to go for it now.
> 
> Regards,
> Jordi
> 
> 
> 
> 
> > De: "Bound, Jim" <[email-masked]>
> > Responder a: <[email-masked]>
> > Fecha: Fri, 14 Apr 2006 03:11:58 -0400
> > Para: <[email-masked]>, <[email-masked]>
> > Conversación: PI addressing in IPv6 advances in ARIN
> > Asunto: RE: PI addressing in IPv6 advances in ARIN
> > 
> > Jordi, why this will work as is for now?
> > /jim
> > 
> >> From: [email-masked]
> >> [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
> >> Sent: Thursday, April 13, 2006 5:28 PM
> >> To: [email-masked]
> >> Subject: Re: PI addressing in IPv6 advances in ARIN
> >> 
> >> Hi Thomas, all,
> >> 
> >> During my fly-back from Montreal, I've worked in a 
> proposal and I'm 
> >> talking to folks in each RIR/region, with the idea to submit it to 
> >> all them as a kind of (if possible), global policy.
> >> 
> >> The idea is based on the comments that I did at the mic during the 
> >> ARIN meeting.
> >> 
> >> I will try to get this submitted next Monday/Tuesday and get ready 
> >> for a formal presentation during the next RIPE meeting at Istanbul 
> >> (following week).
> >> 
> >> Regards,
> >> Jordi
> >> 
> >> 
> >> 
> >> 
> >>> De: Thomas Narten <[email-masked]> Responder a: 
> >>> <[email-masked]>
> >>> Fecha: Thu, 13 Apr 2006 17:14:54 -0400
> >>> Para: "Gunter Van de Velde (gvandeve)" <[email-masked]>
> >>> CC: "[email-masked]" <[email-masked]>
> >>> Asunto: Re: PI addressing in IPv6 advances in ARIN
> >>> 
> >>>> What would be the prefix allocation per organization?
> >>> 
> >>> /48, though can be larger in some cases. Watch for the revised 
> >>> proposal that gets last called for details.
> >>> 
> >>>> (Me being in Europe and not attending ARIN sessions)
> >>> 
> >>> Note: none of the other RIRs have such a policy in place
> >> today, though
> >>> I wouldn't be surprised if they now followup with proposals
> >> of their
> >>> own (though someone has to do it).
> >>> 
> >>>> Has there been study on the # of organizations going for
> >> this and if
> >>>> the impact will be more significant then more's law on 
> technology 
> >>>> enhancement?
> >>> 
> >>> Mostly just hand waving, with a lot of "IPv4 hasn't melted today,"
> >>> "looking at the impact of the current IPv4 policies, the
> >> number of PI
> >>> assignments is only on the 100s per year", and "we can update the 
> >>> policy if things get problematical".
> >>> 
> >>> Thomas
> >>> 
> >> 
> >> 
> >> 
> >> 
> >> **********************************************
> >> The IPv6 Portal: http://www.ipv6tf.org
> >> 
> >> Barcelona 2005 Global IPv6 Summit
> >> Slides available at:
> >> http://www.ipv6-es.com
> >> 
> >> This electronic message contains information which may be 
> privileged 
> >> or confidential. The information is intended to be for the 
> use of the 
> >> individual(s) named above. If you are not the intended 
> recipient be 
> >> aware that any disclosure, copying, distribution or use of the 
> >> contents of this information, including attached files, is 
> >> prohibited.
> >> 
> >> 
> >> 
> >> 
> >> 
> > 
> 
> 
> 
> 
> **********************************************
> The IPv6 Portal: http://www.ipv6tf.org
> 
> Barcelona 2005 Global IPv6 Summit
> Slides available at:
> http://www.ipv6-es.com
> 
> This electronic message contains information which may be 
> privileged or confidential. The information is intended to be 
> for the use of the individual(s) named above. If you are not 
> the intended recipient be aware that any disclosure, copying, 
> distribution or use of the contents of this information, 
> including attached files, is prohibited.
> 
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Apr 2006 17:51:03 -0400

I am not sure this is valid discussion for v6ops with respect to a
deliverable from v6ops because IETF has no more input to the RIRs than
GM, BT, Governments etc.  

V6ops Chairs: Is this valid discussion to any of our working group
deliverables other than good fyi to the team?  Thanks

/jim 

> [mailto:[email-masked]] On Behalf Of Durand, Alain
> Sent: Friday, April 14, 2006 7:54 AM
> D) I am sensitive to the argument that v4 has not "melted" 
> with PI, so why should v6 melt more? I believe the benefits 
> of handing out PI *now* outweight the cost of a *small* swamp. 
> 
> E) given the state of v6 deployment now, I do not think there 
> is much risk with this policy at this moment. And as Thomas 
> relayed, this policy could be changed anyway if things get 
> out of control.
> 
> F) if this means giving advantage to the early adopters by 
> offering them PI, I look at this as a positive thing.
> 
> G) a key thing is to limit the size of the swamp that would 
> be created, or more specifically limit its growth. So it 
> might be a good idea to have a sunset clause in the policy, 
> like it will have to be revisited in 2 years or when a 
> certain allocation (or allocation rate) threshold will be reached.
> 
>     - Alain.
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Apr 2006 17:55:50 -0400

Regarding Address Reclaim.  My private individual input to RIR is that
the private sector should have binding legal agreement with any LIR that
they cannot force a renumber without proper X time to renumber which
would be different depending on the business impact real time of a
renumbering operation.  Not clear how Governments will operate as they
are truly ISPs and the issue could be moot to them.

/jim

> [mailto:[email-masked]] On Behalf Of Craig Huegen (chuegen)
> Sent: Friday, April 14, 2006 9:21 AM
> To: Durand, Alain; [email-masked]; [email-masked]; [email-masked]
> Subject: RE: PI addressing in IPv6 advances in ARIN
> 
> > A) if PI addresses are to be returned at some point in time, they 
> > loose a dreat deal of their value. Folks like PI because it shields 
> > them from renumbering.
> 
> I'd like to clarify this a bit.  As a large enterprise 
> network operator, I'm less concerned about the need to 
> renumber the network once than I am the need to renumber 
> every time that I want to change a service provider.  Don't 
> take that the wrong way:  renumbering is still a significant 
> pain, but the real reason that enterprises haven't adopted PA 
> space is that it represents a de-facto "lock-in" to the 
> service providers they choose initially and they're faced 
> with a network-wide renumber any time they drop or add a 
> service provider.
> 
> Most enterprise network operators that I have spoken to would 
> be willing to renumber once in the future, in exchange for a 
> reasonable way to get portable IPv6 space today.
> 
> and the market forces can drive the recovery based on the 
> impact to the infrastructure.
> If only a few hundred prefixes are handed out, it might not 
> be enough of a problem to force recovery.
> 
> This may be a moot point for the ARIN discussion, though, as 
> ARIN typically doesn't play all that much of an enforcer 
> role.  It can declare prefixes and prefix ranges as dead, but 
> reachability is determined by the service providers.
> 
> > C) given how long the shim6/multi homing has taken so far, it seems 
> > hazardous to make any bet that in 3 years it will be finish, 
> > implemented, adopted, deployed...
> 
> I think that Jordi was referring to 3 years after the 
> solution is declared "available" -- admittedly that's a tough 
> milestone to set.
> 
> Finally, I agree with all four other points you make; 
> adoption of IPv6 has been held up because the capabilities 
> offered lack a critical requirement for enterprise networks 
> (connectivity without de-facto service provider lock-in).  
> The agreement to move forward with a policy is a very 
> positive thing that enables IPv6 to work for large 
> enterprises while the right solution is determined and rolled out.
> 
> /cah
> 
> ---

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 16 Apr 2006 17:58:09 -0400

ALso if those prefixes are for a nuclear power plant I want them to have
proper time to renumber for sure.  It is relevant to what business
impact it has specifically in mission critical environments.  I am
removing all but IETF lists in my responses.
/jim 

> [mailto:[email-masked]] On Behalf Of Iljitsch van Beijnum
> Sent: Friday, April 14, 2006 10:41 AM
> To: Durand, Alain
> Cc: Craig Huegen (chuegen); [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> On 14-apr-2006, at 16:02, Durand, Alain wrote:
> 
> >> If only a few hundred prefixes are handed out, it might 
> not be enough 
> >> of a problem to force recovery.
> 
> If the number of prefixes becomes large enough to be 
> problematic, reclaiming those to solve these problems isn't 
> going to work. For one thing, it's likely that such problems 
> won't be experienced to the same degree by different people: 
> people with a few large routers (and deep pockets) will be in 
> a much better position than people with a larger number of 
> smaller routers (and less money). Also, policy development is 
> done regionally while the results are suffered globally. But 
> even discounting all of that, if ARIN were to decide that the 
> prefixes must be revoked, it will take a significant amount 
> of time before that actually happens. It gets worse when 
> people start to sue.
> 
> So in practice the only thing that can happen is that if the 
> problem is severe (i.e., that 51% of all people in the (rich) 
> ARIN region feel the pain) the policy is changed so that no 
> _new_ prefixes of this type are given out, and then we have 
> to wait for the increase in router performance over time to 
> make the problem disappear.
> 
> If it gets really bad a quick "ipv6 prefix-list no-v6-pi deny 
> ::/0 ge 48" will clean up the routing table and a timeout or 
> two later you're back on IPv4 when trying to reach the 
> holders of these PI blocks.
> 
>