Subject: RE: PI addressing in IPv6 advances in ARIN

From: "Bound, Jim" <[email-masked]>
Date: Fri, 14 Apr 2006 03:11:58 -0400

Jordi, why this will work as is for now?
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
> Sent: Thursday, April 13, 2006 5:28 PM
> To: [email-masked]
> Subject: Re: PI addressing in IPv6 advances in ARIN
> 
> Hi Thomas, all,
> 
> During my fly-back from Montreal, I've worked in a proposal 
> and I'm talking to folks in each RIR/region, with the idea to 
> submit it to all them as a kind of (if possible), global policy.
> 
> The idea is based on the comments that I did at the mic 
> during the ARIN meeting.
> 
> I will try to get this submitted next Monday/Tuesday and get 
> ready for a formal presentation during the next RIPE meeting 
> at Istanbul (following week).
> 
> Regards,
> Jordi
> 
> 
> 
> 
> > De: Thomas Narten <[email-masked]>
> > Responder a: <[email-masked]>
> > Fecha: Thu, 13 Apr 2006 17:14:54 -0400
> > Para: "Gunter Van de Velde (gvandeve)" <[email-masked]>
> > CC: "[email-masked]" <[email-masked]>
> > Asunto: Re: PI addressing in IPv6 advances in ARIN
> > 
> >> What would be the prefix allocation per organization?
> > 
> > /48, though can be larger in some cases. Watch for the revised 
> > proposal that gets last called for details.
> > 
> >> (Me being in Europe and not attending ARIN sessions)
> > 
> > Note: none of the other RIRs have such a policy in place 
> today, though 
> > I wouldn't be surprised if they now followup with proposals 
> of their 
> > own (though someone has to do it).
> > 
> >> Has there been study on the # of organizations going for 
> this and if 
> >> the impact will be more significant then more's law on technology 
> >> enhancement?
> > 
> > Mostly just hand waving, with a lot of "IPv4 hasn't melted today,"
> > "looking at the impact of the current IPv4 policies, the 
> number of PI 
> > assignments is only on the 100s per year", and "we can update the 
> > policy if things get problematical".
> > 
> > Thomas
> > 
> 
> 
> 
> 
> **********************************************
> The IPv6 Portal: http://www.ipv6tf.org
> 
> Barcelona 2005 Global IPv6 Summit
> Slides available at:
> http://www.ipv6-es.com
> 
> This electronic message contains information which may be 
> privileged or confidential. The information is intended to be 
> for the use of the individual(s) named above. If you are not 
> the intended recipient be aware that any disclosure, copying, 
> distribution or use of the contents of this information, 
> including attached files, is prohibited.
> 
> 
> 
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 14 Apr 2006 12:20:06 +0200

Hi Jim,

Not sure if I got your question correctly, but let me try to explain my
view.

I understand the position of the people that say they need PI today,
especially because not having it may be hurting the advancement of the IPv6
deployment.

However, I want to balance this with the medium-long term implications
created in the routing table and with the time needed to build and deploy a
better technical solution (or several) which is accepted by the community.

So my proposal basically is about having PI now everywhere (once ARIN adopt
it, is unfair not having it in other regions), but those PI allocations for
multihoming should be temporary and those address blocks returned to the
RIRs some time (lets say 3 years) after the new technical solution is
declared as a valid one.

At this way, on the long-run, we will not have routing table implications,
but we allow now the people that want to move ahead only if they have a
multihoming solution doing so.

This 3-years time for getting a multihoming network back to the new
technical solution (once adopted) is enough time, I think (it could be
changed to 5 years if needed, or whatever), so nobody today see the
temporarily of the proposal as a showstopper to go for it now.

Regards,
Jordi

> De: "Bound, Jim" <[email-masked]>
> Fecha: Fri, 14 Apr 2006 03:11:58 -0400
> Para: <[email-masked]>, <[email-masked]>
> Conversación: PI addressing in IPv6 advances in ARIN
> Asunto: RE: PI addressing in IPv6 advances in ARIN
> 

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Fri, 14 Apr 2006 12:43:31 +0200

Hi Jordi,

Please see inline.

>RIRs some time (lets say 3 years) after the new technical solution is

That will never happen i suppose... once there is PI space out there, then
it will be there forever.... the discussion in 2 a 3 years will be the same 
as now because
Network Management staff just don't like to renumber their infrastructures 
(and that is
for valid reasons), and this is even more valid when speaking about the very
large enterprise organizations. If PI is accepted now, then i suppose it 
will be out there
forever and ever.

When PI space is out there then i wonder who of these organizations would 
actually
still be interested in a shim solution and further development may result 
in an academical
effort.

Brgds,
G/

>This electronic message contains information which may be privileged or 
>confidential. The information is intended to be for the use of the 
>individual(s) named above. If you are not the intended recipient be aware 
>that any disclosure, copying, distribution or use of the contents of this 
>information, including attached files, is prohibited.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 14 Apr 2006 13:24:31 +0200

See below.

Regards,
Jordi

> De: "Gunter Van de Velde (gvandeve)" <[email-masked]>
> Fecha: Fri, 14 Apr 2006 12:43:31 +0200
> Para: <[email-masked]>
> CC: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>

Precisely, writing it in the policy will make clear what is not forever.

Even if the policy don't say it is temporary, it can be changed at any time.
I think is more fair to tell it clearly since the time time the policy is
accepted.

By the way, something else that I've in my proposal is clarifying that if a
use of this policy don't want to go to the technical solution later on, he
has, of course, the chance to become an LIR at that time and avoid
renumbering (of course, needs to qualify for LIR).

> still be interested in a shim solution and further development may result

I'm not necessarily talking about shim or only about shim. I hope there will
be solutions that will make attractive going for this change.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 14 Apr 2006 13:14:49 +0200

While I'm in a nasty mood anyway, let me make the most of it...

Would you people prune the god damn quotes already!!!!!!

On 14-apr-2006, at 12:43, Gunter Van de Velde (gvandeve) wrote:

> it will be there forever.... the discussion in 2 a 3 years will be  
> the same as now because
> Network Management staff just don't like to renumber their  
> infrastructures (and that is
> large enterprise organizations. If PI is accepted now, then i  
> suppose it will be out there
> forever and ever.
>
> When PI space is out there then i wonder who of these organizations  
> would actually
> still be interested in a shim solution and further development may  
> result in an academical
> effort.
>
> Brgds,
> G/
>
>> privileged or confidential. The information is intended to be for  
>> the use of the individual(s) named above. If you are not the  
>> intended recipient be aware that any disclosure, copying,  
>> distribution or use of the contents of this information, including  
>> attached files, is prohibited.
>
>

-- 
I've written another book! http://www.runningipv6.net/

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 14 Apr 2006 11:21:34 -0400

> Would you people prune the god damn quotes already!!!!!!

It might be a good idea to stop cross posting to 3 lists while you  
are at it.

Regards
Marshall (who will send future replies to ppml only)