Subject: draft-ietf-v6ops-addcon WGLC

From: Fred Baker <[email-masked]>
Date: Sat, 24 Mar 2007 22:37:16 +0100

This is to initiate a two week working group last call of draft-ietf- 
v6ops-addcon. Please read it now. If you find nits (spelling errors,  
minor suggested wording changes, etc), comment to the authors; if you  
find greater issues, such as disagreeing with a statement or finding  
additional issues that need to be addressed, please post your  
comments to the list.

We are looking specifically for comments on the importance of the  
document as well as its content. If you have read the document and  
believe it to be of operational utility, that is also an important  
comment to make.

---

From: "Templin, Fred L" <[email-masked]>
Date: Sun, 25 Mar 2007 19:53:21 -0700

A request was posted on the RAM list to have RFC4214 progressed to
standards-track through AD sponsorship; see:

  http://www1.ietf.org/mail-archive/web/ram/current/msg00900.html
  http://www1.ietf.org/mail-archive/web/ram/current/msg00902.html
  http://www1.ietf.org/mail-archive/web/ram/current/msg00903.html
  http://www1.ietf.org/mail-archive/web/ram/current/msg00904.html

Since RFC4214 originally came from this wg, can we have wg input
as to whether it is suitable for advancement to standards-track
through AD sponsorship at this time?

Thanks - Fred
[email-masked]

---

From: [email-masked]
Date: Mon, 26 Mar 2007 01:46:45 -0600

> through AD sponsorship at this time? 

Fred, 

Based on the initial request(msg00900) this request is based on multiple 
implementations. 

<cut from msg00900>
  This is a request to advance RFC4214 to Proposed Standard, since
  multiple and widely-deployed implementations exist. See: 

     http://isatap.com 

If that is the case then I am all for moving this from experimental to 
standard or even best practice. 

But in reviewing the link I find several examples of how to, and test sites 
but nothing about actual installations that are up and running. 

Can you provide some examples of where this is "widely-deployed" so we can 
judge if it really is ready to move from experimental to standards track. 

Thanks,
Eric

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Mar 2007 15:53:16 +0200

...
> Can you provide some examples of where this is "widely-deployed" so we 
> can judge if it really is ready to move from experimental to standards 
> track.

I'd have similar questions about Teredo and DSTM, if we are
reopening the discussion on ISATAP.

I believe we have already loaded stack implementors and
network operations staff with enough coexistence standards
to support. As we saw in Prague, the operational effect of
your favourite coexistence protocol can even be embarassing.

    Brian

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 26 Mar 2007 10:10:01 -0700

Brian,

> As we saw in Prague, the operational effect of

Is there anything more you could say about this?

Thanks - Fred

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 26 Mar 2007 10:08:26 -0700

Eric,

> judge if it really is ready to move from experimental to 

The widely-deployed implementations I am aware of are in
Windows XP and Vista, cisco IOS, *BSD/Kame, and an older
version of the Linux/USAGI kernel. There are probably
others as well.

Fred

---

From: "Durand, Alain" <[email-masked]>
Date: Mon, 26 Mar 2007 13:38:26 -0400

Fred,

Those OS are widely deployed,
Those OS implement isatap,
this does not mean that isatap,
nor any transition mechanism for that matter,
is widely used.
If the point is to treat all those mechanism fairly,
it would make sense to reclassify them all as experimental.

My .02$

   - Alain.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Templin, Fred L
> Sent: Monday, March 26, 2007 1:08 PM
> To: [email-masked]
> Cc: [email-masked]; Dan Romascanu; Ronald Bonica
> Subject: RE: RFC4214 to standard?
> 
> Eric,
> 
> version of the Linux/USAGI kernel. There are probably others as well.
> 
> Fred

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Mon, 26 Mar 2007 20:46:40 +0300

Le lundi 26 mars 2007 20:08, Templin, Fred L a écrit :
> an older version of the Linux/USAGI kernel.

With all due respect, I would not call that *particular* 
one "widely-deployed".

-- 
Rémi Denis-Courmont
http://www.remlab.net/

---

From: [email-masked]
Date: Mon, 26 Mar 2007 12:55:58 -0600

Fred,
> version of the Linux/USAGI kernel. There are probably

IPv6 is also found in Windows XP and Vista, cisco IOS, and Linux. 

Do we count this as accepted and no need to push for more acceptance because 
IPv6 is available in more than 80% of all computers (assuming that not all 
of the 90% that are running Windows are running XP or Vista)? 

How is this in actual usage? which networks are carrying traffic ? what 
companies have deployed it? 

being available is not the same as widely deployed.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Mar 2007 08:54:54 +0200

I guess I used "your" colloquially to mean "one's".
You (Fred) may have noticed some discussion about RA
problems caused by one's (my) favourite solution,
6to4. Sorry to be obscure. However, I was trying to
make a general point - about the only technique where
I feel we have solid trouble-free operational experience
is plain old dual stack. I don't see any real grounds to
demote any of the existing PS mechanisms except NAT/PT,
but I don't see any grounds for promoting anything either.

     Brian

---

From: Tim Chown <[email-masked]>
Date: Tue, 27 Mar 2007 08:22:12 +0100

> but I don't see any grounds for promoting anything either.

I'd add the tunnel broker model to the list of (relatively) widely deployed 
and reasonably robust methods.   Promoting its status doesn't make it any
more widely deployed though, really.

Tim

---

From: "Soininen Jonne (Nokia-NET/Espoo)" <[email-masked]>
Date: Wed, 28 Mar 2007 14:58:21 +0300

Brian,

Teredo (RFC4380) is actually a proposed standard. So, I think that deals at
least 50% of you can of worms... ;)

Anyways, to my understanding getting something to proposed standard does not
need wide deployment or great level of usage. You need something like that
when moving from proposed upwards. So, in that regard I would see this whole
discussion missing the point.

I also agree with FredT that there is some evidence of ISATAP being deployed
(at least as much as TEREDO as it seems to be in the XP stacks, and I have
heard that it would be also in Vista - perhaps somebody from Microsoft can
verify that).

I think the main point of the discussion should be if there is enough
experience gathered to move ISATAP from experimental to PS. I think the
people who are deploying it might be the best people to answer.

I'm sure that Kurtis and FredB can state then depending the conclusion of
the discussion, if v6ops is the right place, or would individual submission
to the IESG be better if it is decided to go forward at this point.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 28 Mar 2007 14:12:26 +0200

> least 50% of you can of worms... ;)

Yeah, my bad. I must have balloted on that one too. Red face.

> discussion missing the point.

Not entirely. With something as operational as an IPv6 coexistence mechanism,
I would rate evidence of deployability as quite important in the decision.

> people who are deploying it might be the best people to answer.

Yes, I don't disagree with that. In fact that's why I think v6ops is
the right place for the discussion.

    Brian

---

From: Jim Hoagland <[email-masked]>
Date: Wed, 28 Mar 2007 13:55:23 -0700

> heard that it would be also in Vista - perhaps somebody from Microsoft can

I'm not from Microsoft, but I have done a "bit" of playing with Vista.  An
extended version of RFC 4380 is implemented.  In fact, Teredo functionality
is enabled by default in Vista.

  http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/teredo.mspx

-- Jim

-- 
Jim Hoagland, Ph.D., CISSP
Principal Security Researcher
Advanced Threats Research
Symantec Security Response
www.symantec.com

---

From: Fred Baker <[email-masked]>
Date: Thu, 29 Mar 2007 08:26:40 -0400

On Mar 24, 2007, at 5:37 PM, Fred Baker wrote:

> This is to initiate a two week working group last call of draft- 
> ietf-v6ops-addcon. Please read it now. If you find nits (spelling  
> errors, minor suggested wording changes, etc), comment to the  
> authors; if you find greater issues, such as disagreeing with a  
> statement or finding additional issues that need to be addressed,  
> please post your comments to the list.
>

Still looking for comments on the addcom draft.